(Topic ID: 153689)

Electrical problem causing ejecting balls?


By n1teowl

4 years ago



Topic Stats

  • 12 posts
  • 4 Pinsiders participating
  • Latest reply 4 years ago by Mbecker
  • No one calls this topic a favorite

You

Linked Games

You're currently viewing posts by Pinsider n1teowl.
Click here to go back to viewing the entire thread.

#1 4 years ago

I've had a continuing problem with my World Cup Soccer. It occasionally and randomly ejects balls into the shooter lane during a game. It's very unpredictable. For example, I played 10 games tonight with no issues and then it started firing additional balls into the shooter lane and stacked up two or three. I've noticed it happens more often when the slingshots are both kicking back and forth or during multiball. I also noticed today that it might be related to the right flipper. The opto transmitter board has been replaced and the optos have tested out okay. No issues with any switches firing on the switch test when I bang on the playfield. Any ideas on what could be causing this? Ideas for what to try? I've considered replacing the 7 opto switch board - am I on the right track?

#4 4 years ago

I've taken a look and haven't found anything obvious - no loose solder joints that I can see. I can't seem to cause the machine to act up by shaking, smacking, or generally abusing it. I even checked all of the diodes on the switches in the same row and column as the ball jam opto. The ball jam opto is suspect as the solenoid will kind of "half-fire" a few times before kicking the balls out as if they were trying to unjam something. Unfortunately, the ball jam opto checks out.

#6 4 years ago

It's very variable as to when it happens. It is usually brought on by a lot going on (e.g. multiball) but I've also had it happen even after all the balls have drained and nothing is really going on. I replaced the opto transmitter board, which contains the ball jam opto, but not the reciever board. It could be the receiving opto, but I read that the transmitters are more often the problem (and my soldering skills are pretty crappy). I've never gotten the ball jam opto to show any problem in test mode, which makes me a bit suspect, but who knows. I'm willing to try anything at this point. Any thoughts on the 7 opto switch board that the two opto boards plug into?

#9 4 years ago

Thanks for the replies schudel5 and Mbecker. I will start at the optos and work my way back. Although I've tested them using the switch test and blocking the beam, it would be pretty unlikely for me to identify the issue that way because it happens so infrequently. I'll go over all of the connections carefully and see if I can see anything janky. I meant to say that I have already tried reflowing the opto switch board and the problem hasn't gotten any worse or any better (not sure how good I job I did though). Thanks again and I'll let you know what I discover.

#11 4 years ago

I had a chance to work on this tonight. I did what you suggested schudel5 and got the switch edge test going and really gave it a going over. Of course, nothing seemed wrong as the other times I tried this. I stuck with it though and started firing off the slings (as this sometimes seemed to cause the problem). I would see the slings listed on the switch edge test, back and forth, and spent a good couple of minutes doing this. And then...one time...the ball jam opto fired. I pressed on the opto board, the ball jam opto, and banged on the playfield and couldn't get it to fire again. And then, as I was pressing on the contacts for the ball jam opto with a pencil, it fired again. Those were the only two timies I could get it to fire, but that was enough for me. I took the opto receiver board out and reflowed the contacts to the ball jam opto. It's back in now, and I'm cautiously optimistic after playing three games with no issues at all. No more "mini-multiball"! Mbecker, you helped me realize that I was probably overthinking things and I should start at the beginning and the most obvious place. It's amazing how you get an idea in your head of what the problem is and stop thinking about other options. I'm hoping this fix sticks, I'll let you know how it turns out. Thanks again for your help, an objective look was what I needed.

Promoted items from the Pinside Marketplace
$ 17.50
Playfield - Plastics
Pinball Haus
$ 11.00
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
From: $ 27.00
Boards
KAHR.US Circuits
From: $ 40.00
Cabinet - Other
Rock Custom Pinball

You're currently viewing posts by Pinsider n1teowl.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside