(Topic ID: 233278)

EBD everything working wont start a game

By zello

2 years ago


Topic Heartbeat

Topic Stats

  • 17 posts
  • 9 Pinsiders participating
  • Latest reply 2 years ago by FatPanda
  • Topic is favorited by 1 Pinsider

You

Linked Games

No games have been linked to this topic.

    Topic Gallery

    View topic image gallery

    75174A53-0548-41B4-A324-A97077F3AE54 (resized).jpeg

    #1 2 years ago

    I have an EBD That was working years ago but now wont start a game.
    The MPU boots the attract fully work lights and sound. All the Selonids fire. The ball through switch seems to work. The coin door start but seems to work. It makes the sound. no fuses are blown.
    any ideas?
    I have an altek mpu i will dig out and try.
    Thanks

    #2 2 years ago

    Is it in free play? Did you put quorters in?

    #3 2 years ago

    Freeplay. Everything seems to work just wont start a game.

    #4 2 years ago

    Switch in outhole working so the game knows a ball is there ?

    LTG : )

    #5 2 years ago

    It is physicaly working and making contact... been so long i forgot how to switch test on the machine

    #6 2 years ago

    Put the machine in self-test mode, get to the switch test, and make sure the coin door credit button is being recognized during the test. The credit button is switch 06.

    #7 2 years ago

    switch test.... when the ball is in the out hole switch 8 registers till i remove the ball. the coin door button switch 9 registers when held as well.

    #8 2 years ago

    I had a shorted tilt causing the same symptom when I first got my Paragon.

    #9 2 years ago

    wouldn't that show in the switch test ?

    #10 2 years ago
    Quoted from zello:

    the coin door button switch 9 registers when held as well.

    If you are in switch test mode and you press the credit button and a "9" is displayed, you have a problem because the credit button should register a "06". "9" is for one of the coin switches on the inside of the coin door.

    #11 2 years ago

    So the start button makes a sound but the game doesn’t leave attract mode? Or the start button sounds and a game starts but ball is not sent out into the shooter lane?

    #12 2 years ago
    75174A53-0548-41B4-A324-A97077F3AE54 (resized).jpeg
    #13 2 years ago

    Check ball roll tilt mech

    #14 2 years ago

    If there is a capacitor on a tilt switch, I would clip one leg to check if it has shorted out.

    #15 2 years ago

    I reseated all the connectors. its running now!

    #16 2 years ago
    Quoted from zello:

    I reseated all the connectors. its running now!

    Sounds like you have a little repinning job in your future

    #17 2 years ago

    Reflowing solder on the header pins does wonders

    Hey there! Got a moment?

    Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside