(Topic ID: 253322)

Earthshaker game locks up when a coil is activated - Please Help!


By Zek_Pinball

41 days ago



Topic Stats

  • 23 posts
  • 9 Pinsiders participating
  • Latest reply 38 days ago by Dent00
  • Topic is favorited by 3 Pinsiders

You

Linked Games

Topic Gallery

There have been 9 images uploaded to this topic. (View topic image gallery).

pin (resized).jpg
IMG_20191013_105854848 (resized).jpg
IMG_20191013_105836676 (resized).jpg
IMG_20191013_105807231 (resized).jpg
IMG_20191013_105948003 (resized).jpg
IMG_20191013_105917334 (resized).jpg
IMG_20191013_105825905 (resized).jpg
IMG_20191013_105533828 (resized).jpg
IMG_20191013_105515740 (resized).jpg

#1 41 days ago

So I just recently purchased my first pin. I've had it for a few days and I haven't experienced any issues with it until now. I noticed a few lamps were out so I lifted the playfield to get a closer look. I also unplugged and re-plugged a few connectors that appeared to be somewhat loose, I then lower the playfield back into its correct position. Now here is my issue. When I start a game everything works fine until a coil/solenoid is activated, then the game locks/freezes. All power to the playfield is lost and I have to turn the machine off. I ran the coil diagnostic test and a they all operated correctly. I am completely stumped on on why the game is locking/freezing when a coil is activated when a ball is in play. Any help would be greatly appreciated!

Name of game, manufacturer and year:
-Earthshaker, Williams, 1989

Did it ever work in your Possession?:
-Yes, worked fine except a few lamps are out (Right ramp Jackpot lamp, Right ramp Million lamp, Center ramp 2 mile lamp, and Center ramp 50,000 lamp). So I lifted the playfield to get a closer look. When I put the playfield back into place I'm now having the issue

Did You Run the Diagnostics?:
-Yes. In the Coil diagnostics test, all the Coils fire as they should. No apparent issues.

Where did the game come from?:
-Private Seller

Have needed MODS been done?
-Has been converted to using NVRAM

Are any aftermarket boards installed?:
-None

What was the last service you performed?:
-Machine has been completely shopped.

Battery Corrosion:
-None, has NVRAM

LED or Incandescent lighting?: Complete LED conversion

Blown fuses:

Do you have a Volt Meter?:
-Yes, I have DMM

Can you solder?:
-Yes

Location:
-Charlotte, NC

#2 41 days ago

I have had something similar to this (not quite the same), I'd removed some connectors to get to an underside ramp and then put it back and not noticed one connector was one pin out when I put it back on. The coil just kept freezing in place when it was operated. Took me two hours to find what I'd done. Luckily no damage other than to pride.

#3 41 days ago

Sounds like a bad coil diode..
The diode protects against a voltage spike when the coil de-energizes.

#4 41 days ago

Okay well now I just re-ran the Coil and Switch diagnostic test and the game will now freeze when a coil and/or switch is activated. Though it's intermittent because I can play a complete game and everything is fine. Then when I start another game it will freeze again. I'll recheck all of the connectors and I'll test the diodes on the coils but it freezes at random times. It's not always the same switch or the same coil.

#5 41 days ago

Is it always the same coil?

#6 41 days ago

No its not always the same coil. Like just now I turn it on and started a game. Before I even launched the ball I pressed the left flipper and it froze, the display cut out/stopped working and no power to any of the switches nor coils on the playfield. Only the GI lights were on. The sound was frozen also. I looked under the playfield for a stuck/activated coil but none of them were activated. The Blanking LED was off on the CPU board and the Diagnostic LED on the CPU board was on constant (non-blinking) and the +5 volt LED was on.

#7 41 days ago

Given your new info, that sounds very much less like a connector problem since I would expect that to effect every game. To isolate you could disconnect some coils and replay and see if the issue does or doesn't re-appear, hopefully narrowing down the field for you. Best of luck.

#8 41 days ago

That now sounds much more related to cross board connection problems. No chance of a poor ribbon connection between boards? Even eprom poor leg contact?

#9 41 days ago

Yeah and now it won't even start a game. As soon as I turn it on and press the start button. The pin freezes, display stops working and the blanking LED turns off, Diagnostic LED turns on constant and the +5 volts LED is on constant. So idk what to really test other than what has been stated above since I'm still new to pin ownership and repair. Also the CPU board has new Williams licensed ROM chips.

#10 41 days ago

Check the voltages on the power supply. Let us know what you get.

#11 40 days ago

Okay so I've tested the voltage at the power supply board and I get 4.98v at the TP1 +5v pin, I get 12.25v at the TP3 +12v pin, and I get -14.41v at the TP4 -12v pin. So does the -14.41v reading mean that their could possibly be a capacitor on the power supply board mean it's going bad?

#12 40 days ago

When you turn on the power, tell me the order in which the LEDs on the CPU light up.

#13 40 days ago

So I figured out that I can get the game to work by unplugging and re-plugging the connectors at the power supply board and the game will boot and play normally for extended periods of time. Then the same issue will occur randomly. I'm having a hard time purposely reproducing the issue. As per your question GRUMPY the +5v LED lights first, then both the Diagnostic and Banking LEDs light almost simultaneously...possibly the blanking LED lights right before the Diagnostic LED (the Diagnostic LED is blinking).

#14 40 days ago

Can you remove the power supply and take a pic of the back side of 3J-1 header pins.

#15 39 days ago

Okay so I'm just going to provide multiple pics of the power supply board. All capacitors except C9 have been replaced. BR1 bridge has been replaced and the IC1 chip has been replaced. Also the pins on all of the connection sockets appear to be clean. I'll check the connectors themselves for possible corrosion.

IMG_20191013_105515740 (resized).jpgIMG_20191013_105533828 (resized).jpgIMG_20191013_105825905 (resized).jpgIMG_20191013_105917334 (resized).jpgIMG_20191013_105948003 (resized).jpgIMG_20191013_105807231 (resized).jpgIMG_20191013_105836676 (resized).jpgIMG_20191013_105854848 (resized).jpg
#16 39 days ago

Check these 2 pins to see if the solder is cracked around the pin. Remove solder and resolder if needed. If not then you need to inspect the + 12 pin on 1J-17 of the CPU board for cracked solder on the pin.

pin (resized).jpg
#17 39 days ago

Okay I'll take a look tomorrow when I have free time and I'll post an update after checking them. Thanks GRUMPY for the help!

#18 38 days ago

Okay so I've checked the solder on all of the power board connections and none of them are cracked/broken. The only questionable solder joint on the power supply board is the negative solder joint on the C10 capacitor. I've also checked the solder on the power connector for the CPU board and none appear to be cracked/broken. I'm now gonna check all of the wires from the power supply board to cpu board for continuity. Also the issue is now becoming very intermittent. It's only happening a 1 or 2 times out of maybe 40 games.

#19 38 days ago

If you get desperate and decide that you have an intermittent problem with that power supply, you can get a new one here, but it is not cheap:
https://www.marcospecialties.com/pinball-parts/D-12246

#20 38 days ago

I would go back to the beginning when your first started monkeying with connectors under the playfield. Did the game work prior to that state? Then I would go through and re seat ALL the connectors on the boards. Ribbon cables. Power connectors etc. Before you turn on closely inspect everything under the playfield, you may have some coil wires or diodes that need some reconnection.

#21 38 days ago

If you dissconnect the coils and play a game your self by just pressing switches does it play ok? no lock up?

If all looks ok start to look at the coil diodes.

#22 38 days ago

Trollsp

#23 38 days ago
Quoted from Eric_S:

Sounds like a bad coil diode..
The diode protects against a voltage spike when the coil de-energizes.

Might be a good idea to check all your diodes...
Diodes are cheap (like 7 cents each) and pretty easy to replace...
https://www.pinballlife.com/diode-1n4004.html

Promoted items from the Pinside Marketplace
$ 49.95
Lighting - Led
Pin Stadium Pinball LEDs
$ 39.99
Eproms
Matt's Basement Arcade
From: $ 129.10
Cabinet - Sound/Speakers
PinWoofer
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
From: $ 18.00
Apparel - Men
Pinside Shop
3,995
Machine - For Sale
West Chicago, IL
$ 259.95
Lighting - Led
Pin Stadium Pinball LEDs

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside