(Topic ID: 210786)

DW issue with Opto


By mwrussel

1 year ago



Topic Stats

  • 11 posts
  • 4 Pinsiders participating
  • Latest reply 1 year ago by mwrussel
  • No one calls this topic a favorite

You

Linked Games

#1 1 year ago

I was changing out bulbs in my DW. After I changed out a couple of burnt out bulbs in the coin door, I noticed the miniplayfield started malfuctioning. The playfield randomly stopped and the opto was randomly triggering. The outhold for the Tardis fires randomly, the ball kickers in the mini playfield started firing randomly. the 5 bank opto switches on the miniplayfield don't respond...pretty much every opto I've checked isn't responing. Not sure what caused it or how to fix it. Any advice would be helpful. Thanks

#2 1 year ago

Step 1) do a full switch test... check everything (including Test 14)
Step 2) do a full solenoid test
Step 3) do a full lamp/flasher test

This could go a few ways. Power driver or possibly opto.

The more things you rule out the better.

After that checking the test points on the power driver board will make sure you have clean power.
faz

#3 1 year ago

Ran the tests...

All solenoids tests passed

All GI tests passed

Only one flasher did not work, that was the backbox head. I put in an a wobblehead several years ago. With the current issues, the wobblehead has turned to the left and stays there.

On the switch test, there were 10 bad switches, all seeming to be related to optos, switches 31-33( opto popper, MPF Home opto and Enter top ramp opto) flickered continuously, switched 71-77 also flickered (71-75 are the 5 bank MPF, 76 and 77 are the MPF optoejects)

MPF pretty much failed all, the kickers worked, the flasher worked, but all optos were lit up and non repsonsive on the DMD board, and the miniplayfield would move but didn't seem to know its position and would fail.

Haven't checked the power yet, but I do have a DMM. Looks like these are all realted to pins 206 and 208. What would I be looking for there?

Thank you again for all your help.

#4 1 year ago

Just went to the CP board and there is nothing plugged into J206 or 208. There is nothing plugged into those, the plugs are in 207 and 209 which my manual says are not used. I haven't touched those in years.

#5 1 year ago

Excellent diagnostics this will help... since the issue is so broad it probably points a shared system. But now you are out of my level of expertise. wayout440 zaza this is more your deal.

faz

#6 1 year ago
Quoted from mwrussel:

Just went to the CP board and there is nothing plugged into J206 or 208. There is nothing plugged into those, the plugs are in 207 and 209 which my manual says are not used. I haven't touched those in years.

Doesn't matter, they do the same thing. Not your issue.

LTG : )

#7 1 year ago

Best is to start with the unregulated 12Volt at J116,J117,J118.
One of this connectors supplies 10-optoboard under playfield. Measure J1-4 to J1-5, (apprx 14 Volts).
Check wiring at connectors powerdriverboard J116-118 and 10-optoboard under playfield.
Inspect capacitor C2 on optoboard for leaking.

#8 1 year ago

Thank you for that help....so, I got out my DMM and started to check plugs. I noticed that J117 is where my wobblehead dalek mod is plugged and since it was acting funny I started there. when I jiggled the plug, the wobblehead started moving and the solenoids related to the bad optos started firing. So, I removed the wobblehead insert plug from the series and plugged the original back directly into the board and it all came back to life. MPF working fine, optos came back on and playable once again.

Thank you all for helping me get to the root of all this.

I really like the wobblehead and would like it back in play, do you think I just need to repair the connection?

#9 1 year ago

Yeah, it seems that the wobblehead mod connector (piggyback ?) causes this problem.
That must be fixable. Probably a new connector will help but inspect the connector J117 on the driverboard as well.

#10 1 year ago

Sweet!

Told you that this forum is pretty awesome!

Thanks zaza!
faz

#11 1 year ago

Thank you to everyone that helped zero in on the problem!

Also, I need to correct myself, the piggyback WASN"T the wobblehead, it was actually to the lighted flipper button mod. Which seems to be intact and working fine. So maybe it is the actual connection around 117 and just moving it around temporarily fixed it...not sure. Wobblehead seems to have died though, maybe this problem fried it.

Promoted items from the Pinside Marketplace
$ 74.00
Cabinet - Armor And Blades
Id Rather Play Pinball
$ 69.50
Boards
Pinball Haus
$ 229.99
Lighting - Other
Lighted Pinball Mods

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside