(Topic ID: 40984)

Dredd Owners Thread. Members Only!


By Anim8ormatt

6 years ago



Topic Stats

  • 3,251 posts
  • 383 Pinsiders participating
  • Latest reply 1 day ago by ThatOneDude
  • Topic is favorited by 145 Pinsiders

You

Linked Games

Topic Gallery

There have been 870 images uploaded to this topic. (View topic image gallery).

reactorsss (resized).jpg
E65D50FF-E68D-4469-9222-94FC73D59490 (resized).jpeg
WhatsApp Image 2019-09-30 at 16.35.47 (resized).jpeg
JD plastics location (resized).jpg
WhatsApp Image 2019-09-30 at 15.09.52 (resized).jpeg
DSC_0674 - Edited (resized).jpg
fuRW0uusT_mvnTSBDFsWDw (resized).jpg
mKqt5TO2RMSczT_oETwk3g (resized).jpg
hI260BxsTOeM4Q6V5l5CzQ (resized).jpg
PYMGaIZEQ2qa-WQzbralnQ (resized).jpg
lM89L14cRJqIdlYNh3-URA (resized).jpg
28O4uN87S56-iqQ1ZaiE-w (resized).jpg
DSC04377 (resized).JPG
DSC04361 (resized).JPG
DSC04340 (resized).JPG
DSC04339 (resized).JPG

There are 3251 posts in this topic. You are on page 65 of 66.
#3201 44 days ago

Anyone install a set of Decals from Retro Refurbs? I am digging this alternate Blue version.

judge-dredd-blue-two-alternate-pinball-cabinet-decals-artwork-alternative-comic-flipper-side-art (resized).jpg
#3202 44 days ago

Joined the club on Saturday. It had been sitting unused for many years.
Bad Cpu corrosion. Replaced with a spare.
Display driver had a bad ram. Replaced and all up and running sweet after a good clean, LEDs, flippers rebuilt and all things adjusted.
Now it’s time to play!!!

F03B0162-644B-43DA-89EF-80A49307229D (resized).jpeg
#3203 44 days ago

I got a Dead Dredd no really it's down for the count, until it gets new clothes that is and yep copped 1 year for littering!!
DSC04339 (resized).JPGDSC04340 (resized).JPGDSC04361 (resized).JPGDSC04377 (resized).JPG

#3204 43 days ago
Quoted from Mancave:

I got a Dead Dredd no really it's down for the count, until it gets new clothes that is and yep copped 1 year for littering!!

I was a little confused at first! A Dredd with no boards used to be a common sight sadly, but who parts out a game these days?? Then I scrolled down a bit and it all made sense.

#3205 43 days ago

I am curious about the setting for how many crime scenes it takes to award an extra ball. When I set this to a higher number it respects the setting for the first extra ball, but then always reverts to 6 crime scenes after the first is awarded. This makes the game last way too long, I don’t feel like there is enough to do in JD to warrant 40 minute games. I have the L7 rom. Is this a known bug, or am I missing something in the settings?

#3206 43 days ago
Quoted from ziz:

I am curious about the setting for how many crime scenes it takes to award an extra ball. When I set this to a higher number it respects the setting for the first extra ball, but then always reverts to 6 crime scenes after the first is awarded.

If you leave it on default does it do 7 for the first EB then 15 for each additional? I feel like 6 per EB would lead to an infinite game as it's pretty easy to collect more than 6 crime scenes per ball.

I have L6, but I'll give it try tomorrow. I've never set it to anything other than the default 7/15.

#3207 43 days ago

I just rejoined the club yesterday, uninstalled the dead world mod and changed roms because the game was going on location. Replaced right flipper opto board to fix a weak flipper and I still have to fix one drop target tonight.

Only thing I'm not sure how to tackle is my Crane makes a terrible squeak/squeal when it moves...it works and is picking up and dropping the ball correctly but the sound is really bad...anyone have suggestions on where to start with that? Does something just need some lubrication or am I looking at a lot more?

#3208 42 days ago
Quoted from HowardHurtz:

If you leave it on default does it do 7 for the first EB then 15 for each additional? I feel like 6 per EB would lead to an infinite game as it's pretty easy to collect more than 6 crime scenes per ball.
I have L6, but I'll give it try tomorrow. I've never set it to anything other than the default 7/15.

For me the default is 6. I feel like there must be a different setting that works in conjunction with that one that I am missing. I find it odd that I haven’t seen others complaining about this, so there must be something up.

#3209 41 days ago
Quoted from ziz:

For me the default is 6. I feel like there must be a different setting that works in conjunction with that one that I am missing. I find it odd that I haven’t seen others complaining about this, so there must be something up.

I did a factory reset on the settings yesterday and no help, still gives an extra ball every 6 crime scenes. I must have a bad code version, I can't think of anything else it could be.

#3210 40 days ago
Quoted from Tsskinne:

I just rejoined the club yesterday, uninstalled the dead world mod and changed roms because the game was going on location. Replaced right flipper opto board to fix a weak flipper and I still have to fix one drop target tonight.
Only thing I'm not sure how to tackle is my Crane makes a terrible squeak/squeal when it moves...it works and is picking up and dropping the ball correctly but the sound is really bad...anyone have suggestions on where to start with that? Does something just need some lubrication or am I looking at a lot more?

If I was putting a Dredd on location I’d unplug the planet motor, the crane motor, disconnect the planet diverter, and bypass the planet load lane on the ramp.

I know that sounds lame, but those parts don’t last forever and they are ample ball traps if they fail.

Weirdly enough the game plays really nice that way. While I have gotten kinda used to the planet lock, my original Dredd had a broken planet and with the ball never stopping in it it keeps the game moving.

If you are like, nope, not gonna do that, you probably should crack into and clean and regrease both the planet and the crane gearboxes and clean the motors themselves with some electrical motor cleaner. That’ll probably help with your screech too.

#3211 40 days ago
Quoted from gunstarhero:

If I was putting a Dredd on location I’d unplug the planet motor, the crane motor, disconnect the planet diverter, and bypass the planet load lane on the ramp.
I know that sounds lame, but those parts don’t last forever and they are ample ball traps if they fail.
Weirdly enough the game plays really nice that way. While I have gotten kinda used to the planet lock, my original Dredd had a broken planet and with the ball never stopping in it it keeps the game moving.
If you are like, nope, not gonna do that, you probably should crack into and clean and regrease both the planet and the crane gearboxes and clean the motors themselves with some electrical motor cleaner. That’ll probably help with your screech too.

Thank you for the tips man. I think I will disable the crane at least. Like I said it’s working fine but the sound is like nails on a chalkboard

#3212 37 days ago

I finally tore my JD down after a couple of years to fill in the old lockbar holes and give it some new vibrant clothing. It isn't a HEP job for sure, but its a lot better than it was. Now I just need to get it all back together and fix a few playfield issues...

24uN87S56-iqQ1ZaiE-w (resized).jpglM89L14cRJqIdlYNh3-URA (resized).jpgPYMGaIZEQ2qa-WQzbralnQ (resized).jpghI260BxsTOeM4Q6V5l5CzQ (resized).jpgmKqt5TO2RMSczT_oETwk3g (resized).jpgfuRW0uusT_mvnTSBDFsWDw (resized).jpg
#3213 36 days ago

All these vibrant colors remind me how drab mine actually are. Glad to see new members here !! Welcome!!

#3214 34 days ago

Someone is selling some of the Judge flipper toppers that were available a few years ago but are no longer made... 1 set left!

ebay.com link

#3215 32 days ago

More of the Dark Judge flipper toppers are listed. Looks like these are being made again finally!

ebay.com link

#3216 31 days ago
Quoted from calfdemon:

More of the Dark Judge flipper toppers are listed. Looks like these are being made again finally!
ebay.com link

Thanks for the link man, looks cool, just ordered!

#3217 31 days ago
Quoted from calfdemon:

More of the Dark Judge flipper toppers are listed. Looks like these are being made again finally!
ebay.com link

I don’t think there being made again. Description says “Last 4 sets” Look just like the ones I got years ago. Probably they bought a bunch of sets years ago too

Added 28 days ago:

I guess they are remakes after all

#3219 28 days ago

Ok, i feel i should set this straight once and for all. The flipper toppers are NOT the originals as in "Probably they bought a bunch of sets years ago too". I bought an original set years ago, probably around the same time PinRob did. A mate of mine has been bugging me for most of the time i've had them to recreate a set for him as he knows that i also do scale modelling and have "some" experience in painting, plus i have also done some shooter rod mods among other things. I finally got around to creating a mold of the originals, casting a couple of sets (1 for him and a spare set for myself) and then hand painting them so they were as true to the originals as i could possible do them. As things like this progress, the word happened to get around, so i created a few more sets for the Oz JD fans. The 6 sets that were listed were the only ones i had left (now all gone). I'm well aware that the original design was not my own but of course the work involved in redoing them is genuinely my own efforts. The intention was NEVER to profit from someone else's design!! It really did come about cause i got fed up with my mate hassling me about it and before i knew it the monster was running so to speak. I was not planning on making more of these after i completed the said 6 sets and my mindset hasn't changed on that score.

#3220 28 days ago

For the sake of your karma, I'll gladly take that last set for the cost of shipping.

#3221 25 days ago
Quoted from Mancave:

Ok, i feel i should set this straight once and for all. The flipper toppers are NOT the originals as in "Probably they bought a bunch of sets years ago too". I bought an original set years ago, probably around the same time PinRob did. A mate of mine has been bugging me for most of the time i've had them to recreate a set for him as he knows that i also do scale modelling and have "some" experience in painting, plus i have also done some shooter rod mods among other things. I finally got around to creating a mold of the originals, casting a couple of sets (1 for him and a spare set for myself) and then hand painting them so they were as true to the originals as i could possible do them. As things like this progress, the word happened to get around, so i created a few more sets for the Oz JD fans. The 6 sets that were listed were the only ones i had left (now all gone). I'm well aware that the original design was not my own but of course the work involved in redoing them is genuinely my own efforts. The intention was NEVER to profit from someone else's design!! It really did come about cause i got fed up with my mate hassling me about it and before i knew it the monster was running so to speak. I was not planning on making more of these after i completed the said 6 sets and my mindset hasn't changed on that score.

Thank your mate for me as I ordered a set! And thanks whoever posted the ebay link too!

#3223 23 days ago
Quoted from Mancave:

Ok, i feel i should set this straight once and for all. The flipper toppers are NOT the originals as in "Probably they bought a bunch of sets years ago too". I bought an original set years ago, probably around the same time PinRob did. A mate of mine has been bugging me for most of the time i've had them to recreate a set for him as he knows that i also do scale modelling and have "some" experience in painting, plus i have also done some shooter rod mods among other things. I finally got around to creating a mold of the originals, casting a couple of sets (1 for him and a spare set for myself) and then hand painting them so they were as true to the originals as i could possible do them. As things like this progress, the word happened to get around, so i created a few more sets for the Oz JD fans. The 6 sets that were listed were the only ones i had left (now all gone). I'm well aware that the original design was not my own but of course the work involved in redoing them is genuinely my own efforts. The intention was NEVER to profit from someone else's design!! It really did come about cause i got fed up with my mate hassling me about it and before i knew it the monster was running so to speak. I was not planning on making more of these after i completed the said 6 sets and my mindset hasn't changed on that score.

Well, I thank you a TON for doing what you did (and glad I found them on eBay in time). I have been looking for those toppers for years as I got my JD after they stopped making them. They have been that "grail" piece for my JD since I got it and I had pretty much given up on ever finding a set for sale as the people that had them kept them and never parted them once on their game. Finding your sets made me pretty happy (and glad that others were able to get in on it!). Looking forward to receiving them and they will be on my JD once I finish putting it all back together!

EDIT- And upon coming home from work, I found my JD toppers in the mailbox. They look even better in person than the photos! Can't wait to get my game back together and in one piece.

#3224 23 days ago

I just joined the club today. Never have played this one before, but dang, this game is awesome! I have some major cleaning to do (smells a little like wet dog, which he had a big one) and the dead world seems to get stuck when rotating. If I help it out it gets going again but eventually sticks. Just the rings, planet is fine. Lights in the planet don’t go very bright too, flasher works fine though. Other than that, drop targets need some work, but I’m super excited!

#3225 23 days ago

Welcome to the club! JD is an underrated game and a lot of fun to play. Once you get it dialed in, it's a blast to play! Congrats on your purchase.

#3226 23 days ago

Welcome to the club!

#3227 21 days ago

Does anyone else ever have issues with the center drop not dropping to expose the subway like it's supposed to during multiball and safe cracker? I lived with it for a long time but finally took the plunge and figured out the issue. The linkage on the drop coil is a poor design and took some slight modification, but I'm happy to report it is now functioning with 100% success.

#3228 21 days ago
Quoted from HowardHurtz:

Does anyone else ever have issues with the center drop not dropping to expose the subway like it's supposed to during multiball and safe cracker? I lived with it for a long time but finally took the plunge and figured out the issue. The linkage on the drop coil is a poor design and took some slight modification, but I'm happy to report it is now functioning with 100% success.

can you share what modification you did?

#3229 21 days ago
Quoted from HowardHurtz:

Does anyone else ever have issues with the center drop not dropping to expose the subway like it's supposed to during multiball and safe cracker? I lived with it for a long time but finally took the plunge and figured out the issue. The linkage on the drop coil is a poor design and took some slight modification, but I'm happy to report it is now functioning with 100% success.

Would love to learn more. Mine drops, but doesn’t always come back up. Looks like it struggles a lot!

#3230 21 days ago

Once I removed the drop target unit from the playfield I was able to manipulated the coil plungers by hand. It appeared that the problem was the link from the plunger to the drops was not rotating to extend the protrusion at the middle drop. Instead, the entire link was just sliding along the metal foundation without rotating.

To fix, I drilled a hole and installed a screw to keep the link from sliding along the foundation. I had to thread the screw almost all the way down so that the screw head was lightly touching the linkage, otherwise the link would ride up the screw and get caught in the threads potentially dropping more than just the center targets or preventing them from going back up.

While I was in there I also filed back some of the spacer that the drops bite into to stay up since the link seemed to sometimes ride up onto it and get out of place.

I have put this thing through the works since putting in the screw and it has been 100%. Attached is my best attempt at a photo. I wish I took photos while the assembly was out of the machine.
DSC_0674 - Edited (resized).jpg

#3231 20 days ago
Quoted from wildside:

can you share what modification you did?

I had the same problem, butt, it was the blue rubber bumper...
My blue bumper plug is degrading; it is very sticky/gooey.
The plunger could not pull in.
I was able to solve the problem by
1) cleaning the bumper plug.
2) rotating the bumper plug
and finally,
3)using talcum powder to make the bumper plug dry.
It has been awhile...
I need to check the game to see if it solved the problem.

#3232 17 days ago

Where does these plastics go?

WhatsApp Image 2019-09-30 at 15.09.52 (resized).jpeg
#3233 17 days ago
Quoted from SlowEssy:

Where does these plastics go?[quoted image]

Pretty sure the blue one goes on the inside of the orbit, behind the sniper tower, way in the back. No idea on that white one tho!

#3234 16 days ago
Quoted from SlowEssy:

Where does these plastics go?[quoted image]

I think the white piece goes in front of Tower 2.

#3235 16 days ago
Quoted from SlowEssy:

Where does these plastics go?[quoted image]

Both are at the back of the playfield, the white one in the middle above the orbit wireform and the blue one under the Air Raid ramp to the right:

JD plastics location (resized).jpg

#3236 16 days ago

Thank you all! And the bigger one, up above? Couldn't find it either....

#3237 16 days ago

Another one that I ain't got a clue,

WhatsApp Image 2019-09-30 at 16.35.47 (resized).jpeg
#3238 16 days ago
Quoted from SlowEssy:

Another one that I ain't got a clue,[quoted image]

No one?

#3240 16 days ago

Spotted it in the link provided by Davi It's directly below the shafts for the crane.

#3241 14 days ago

SEEKING ADVICE -- The Right Popper that pops ball out after hitting the Sniper Tower suddenly stopped working when I installed a replacement opto board for the planet interrupter ring (I've been dealing with other issues to get the Deadworld mod & crane fully operational). I'm guessing something came loose or broke when I raised and lowered the playfield. Now, when a ball enters the Sniper Tower it gets stuck below the playfield and doesn't pop out, effectively killing the play. I've done a little tinkering but am stuck and cannot find a replacement assy (part A-15769) on line. I'm seeking advice before trying anything more radical. Here's what I know:

* The opto seems operational, as when I run Test Mode, it clearly switches on to off when I pass something into the Sniper Tower and through the sensor path just above the right popper

* When I pass something through the opto of the left popper (subway exit), the opto also is operational, and there is a voltage spike measured when I place multimeter leads at the two wire junctions (where the wires attach to the assembly) of the popper assembly when the opto is activated.

* However, there is NO voltage spike measured on the right popper assembly wire junctions when I place leads on them and activate the opto.

* When I run the switch test, the globe twitches when the left popper switch is tested. The globe does nothing (no response) when the right popper switch is tested -- there is zero response seen on the playfield.

* A previous owner soldered one of the right popper wire junctions -- the job appears to be intact, but there is a blob of solder masking the actual connection.

Please pass along any advice you may have to further diagnose -- the pin is pretty much un-playable (and certainly un-fun) without a functioning Sniper Tower. If you have a replacement A-15769, I might be interested in that too.

#3242 14 days ago

I don't think you will need to replace the entire assembly. All those parts are easy to find accept maybe the metal bracket itself...
If you have pictures that may help diagnosis...

#3243 14 days ago

Check your 12v, I find that opto problems often start there.

However, I just had the sniper popper opto fail too and I replaced the emitter and receiver and that fixed me right up. Sometimes they just fail. Mine was intermittent for like one game and then deadsville.

You’ll never find that whole assembly btw, and it’s total overkill for a couple bucks worth of optos.

#3244 14 days ago

In case anyone is curious, I've hooked up a PIN2DMD LED display that I built to my game. What you are seeing is the default colour palette that is built into the board, nothing colourized. The PIN2DMD board allows me to switch to about 10 different solid colours. I know that someone is working on full colourization but I don't think it's ready yet.

Apologize if this has been previously posted.

1 week later
#3245 3 days ago

OK - update on post #3241. I know a few other clues to my "right popper" issue... (1) It isn't just the right popper that isn't working. Other things not working include a non-working diverter that pushes locked ball 3 into the planet, many lights including the "D" of the drop targets, the "PURSUIT" light in the chain, the "MISDEMEANOR" light just below that, add-on stadium lights and add-on LED lights back by trough. I swear the crane magnet isn't as powerful too during the test. (2) I removed all fuses from the power board, tested for resistance with multimeter, and all tested good. (3) After re-installing all fuses and turning the game back on, EVERYTHING started working again......(4) But, 5 plays later all malfunctions simultaneously re-appeared and have stayed.

Can a partially faulty fuse cause multiple random intermittent issues to appear/disappear? Is there something else on the power board I should be checking, or elsewhere? These different malfunctions simultaneously coming and going may be a clue. This is so flippin weird......has something like this happened to any of you?

#3246 3 days ago
Quoted from Baron_VonLoppnow:

OK - update on post #3241. I know a few other clues to my "right popper" issue... (1) It isn't just the right popper that isn't working. Other things not working include a non-working diverter that pushes locked ball 3 into the planet, many lights including the "D" of the drop targets, the "PURSUIT" light in the chain, the "MISDEMEANOR" light just below that, add-on stadium lights and add-on LED lights back by trough. I swear the crane magnet isn't as powerful too during the test. (2) I removed all fuses from the power board, tested for resistance with multimeter, and all tested good. (3) After re-installing all fuses and turning the game back on, EVERYTHING started working again......(4) But, 5 plays later all malfunctions simultaneously re-appeared and have stayed.
Can a partially faulty fuse cause multiple random intermittent issues to appear/disappear? Is there something else on the power board I should be checking, or elsewhere? These different malfunctions simultaneously coming and going may be a clue. This is so flippin weird......has something like this happened to any of you?

Did you test your 12v? When my STTNG was going all nuts it was the cap at C2 had failed and leaked.

#3247 2 days ago

Hey guys, Planet question here, specifically about gears under the planet. The planet itself spins fine, but I noticed the rings stop at a consistent spot. Getting under the playfield, I see the top gear slips because one of the teeth is either gone or bent, so it doesn’t catch unless I push the rotation. It’s not in the gear box, it’s above it. In the pic below, above these gears is the playfield and below is the gearbox.

I read another thread where they said contact Steve for a rebuild, but do I need a rebuild since I can see the gear that needs replacing? Anyone done this?

E65D50FF-E68D-4469-9222-94FC73D59490 (resized).jpeg
#3248 2 days ago

Made some "extra" cooling reactor mod. Need to learn how to setup a store here.
reactorsss (resized).jpg

#3249 2 days ago
Quoted from ragefactory:

Made some "extra" cooling reactor mod. Need to learn how to setup a store here.
[quoted image]

I've got my set on the way!! It will be some time before mine are installed as I have my JD getting ready to get the HEP treatment (shipping to Chris in November), but once it is all done and back home, I will post some pics. Probably next summer sometime... Cant wait!!

#3250 1 day ago

gunstarhero, thanks for your reply. I'm not sure what testing a 12v means (pardon my ignorance). Can you elaborate a little? Feel free to reply privately to me if you wish to avoid diluting this thread. Thx!

Quoted from gunstarhero:

Did you test your 12v? When my STTNG was going all nuts it was the cap at C2 had failed and leaked.

Promoted items from the Pinside Marketplace
$ 19.95
Playfield - Toys/Add-ons
ULEKstore
2,700 (OBO)
Machine - For Sale
San Ramon, CA
From: $ 19.99
Eproms
Matt's Basement Arcade
$ 28.00
There are 3251 posts in this topic. You are on page 65 of 66.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside