(Topic ID: 40984)

Dredd Owners Thread. Members Only!


By Anim8ormatt

7 years ago



Topic Stats

  • 3,770 posts
  • 433 Pinsiders participating
  • Latest reply 13 hours ago by Shredso
  • Topic is favorited by 169 Pinsiders

You

Linked Games

Topic Gallery

There have been 1,088 images uploaded to this topic. (View topic image gallery).

IMG_20200918_203032086 (resized).jpg
IMG_9826 (resized).JPG
IMG_20200909_170338836 (resized).jpg
IMG_20200909_171125209 (resized).jpg
IMG_20200905_090255566 (resized).jpg
IMG20200822180916 (resized).jpg
IMG20200822180900 (resized).jpg
DSC_0528 (resized).JPG
DSC_0562 (resized).JPG
DSC_0560 (resized).JPG
DSC_0559 (resized).JPG
DSC_0561 (resized).JPG
f03d6ee5edcaeaf3e5195a6c2c0cf3b359a494f8 (resized).jpg
Screenshot_20200816-054427_Gallery (resized).jpg
IMG_1804 (resized).JPG
16929back (resized).jpg

There are 3770 posts in this topic. You are on page 64 of 76.
#3151 1 year ago
Quoted from La4s:

I second this. I would be down for a set of these reactors. They look amazing.

I third this! I would also be down for a set of these reactors as well. They look really amazing!

#3152 1 year ago
Quoted from shepP:

I would also be down for a set of these reactors as well.

Have a look here:

https://www.thingiverse.com/thing:1374215

Find a location such as a library that will let you do 3d printing and go to town...

#3153 1 year ago
Quoted from calfdemon:

Have you considered making and selling a batch or 2 of these? I would be first in line with cash in hand! That looks GREAT!!!

First thanks to everyone for the compliments! I'm really flattered.
I would be happy to create a kit for each of you.
Due to long print/assembly/paint time the final product won't be cheap: the best net sales price i can do is 100€ (aroud 110$). If you still interested to buy a kit, i need to check the shipping costs (from Italy) and taxes to ship in US because atm i have absolutly no idea of the amount.
Also i tryed to create a shop on Pinside because i think its not possibile to sell product in other way here.
I will post soon more detailed photos of final version of the kit (with vynil sticker to cover the upper part of the support between the reactors).
Thanks

#3154 1 year ago
Quoted from dzorbas:

Have a look here:
https://www.thingiverse.com/thing:1374215
Find a location such as a library that will let you do 3d printing and go to town...

Yes, like i said, that's the base model i started from. But you can't use it as it is: many modifications needed to fit it in the playfiled.

#3155 1 year ago
Quoted from ragefactory:

First thanks to everyone for the compliments! I'm really flattered.
I would be happy to create a kit for each of you.
Due to long print/assembly/paint time the final product won't be cheap: the best net sales price i can do is 100€ (aroud 110$). If you still interested to buy a kit, i need to check the shipping costs (from Italy) and taxes to ship in US because atm i have absolutly no idea of the amount.
Also i tryed to create a shop on Pinside because i think its not possibile to sell product in other way here.
I will post soon more detailed photos of final version of the kit (with vynil sticker to cover the upper part of the support between the reactors).
Thanks

PM sent!

#3156 1 year ago
Quoted from ragefactory:

Yes, like i said, that's the base model i started from. But you can't use it as it is: many modifications needed to fit it in the playfiled.

Not being critical of your efforts in any way. I think your end result is fantastic and if you can build and sell this as a mod, that's great. Everyone will appreciate it. I'm a tinkerer and like building stuff on my own, that's why I posted the link to the 3d model.

Good luck with the mod, I hope you sell hundreds of them!

#3157 1 year ago
Quoted from ragefactory:

Yes, like i said, that's the base model i started from. But you can't use it as it is: many modifications needed to fit it in the playfiled.

So you also made the base plate the 3 cooling towers are attached to?

#3158 1 year ago
Quoted from mbwalker:

So you also made the base plate the 3 cooling towers are attached to?

Yes, that's the main part. Took lot of time to take measures and design it to avoid to hide "captive balls" on the left and block ball launch on the right.
Also it perfect hide the 6 wires that come out from the cooling towers.

#3159 1 year ago

Hi all. My dredd is having an issue with the Deadworld mod in that once you lock a 2nd ball the machine won’t plunge a 3rd ball into play and then does a ball search, thereby putting the 2 balls in the lock into play. Has anyone had this issue or ideas here?

#3160 1 year ago
Quoted from allsportdvd:

Hi all. My dredd is having an issue with the Deadworld mod in that once you lock a 2nd ball the machine won’t plunge a 3rd ball into play and then does a ball search, thereby putting the 2 balls in the lock into play. Has anyone had this issue or ideas here?

Check your trough optos.

#3161 1 year ago
Quoted from gunstarhero:

Check your trough optos.

Did that, seem fine

#3162 1 year ago

Check the opto at the planet entrance. It may be flaky or dirty or even out of alignment. That is the only way the game knows there is a ball there.

#3163 1 year ago
Quoted from ragefactory:

cooling reactor from thingiverse;
cooling reactor support designed by me;
led MATRIX 4 SMD 6.3V POST LIGHT green
The support is necessary to hide cables and increase the height of the 3d reactor to avoid ball collision during launch.
I add some photo.[quoted image][quoted image][quoted image][quoted image][quoted image][quoted image]

Would you be willing to share your support files? My Ultimaker is collecting dust right now and needs a job Installing the cooling tower mod was next on my list, but this might be a better option!

#3164 1 year ago
Quoted from o-din:

Check the opto at the planet entrance. It may be flaky or dirty or even out of alignment. That is the only way the game knows there is a ball there.

That would be my thought too but he said it’s only happening after lock 2? Wouldn’t it happen after lock 1 in that case?

#3165 1 year ago
Quoted from gunstarhero:

That would be my thought too but he said it’s only happening after lock 2? Wouldn’t it happen after lock 1 in that case?

Good question, but ball search tells me it doesn't know at least the second ball is there. It would be good to know if it happens like that exactly every time. It would be easy to recreate with the glass off.

#3166 1 year ago

It does do that every time. In switch test the opto at the top of the ramp works but the opto halfway up the left ramp says not used?

#3167 1 year ago

Now it’s just done it on first ball lock too

#3168 1 year ago
Quoted from allsportdvd:

Now it’s just done it on first ball lock too

I'd take a better look at that planet entrance opto. The ball may not be triggering it each time by or perhaps a problem somewhere else in the circuit.

Quoted from allsportdvd:

the opto halfway up the left ramp says not used?

Early and later Dredds came with different switch locations for the left ramp entrance and unfortunately they changed the switch designation on the matrix itself when they did that. Which caused a few problems depending on what rom was used.

Mine is a sample game with the earlier matrix so I opted to just get the L1 rom with the dead world mod which is sitting in a box on the porch as we speak. I've got L4 now and it shows left ramp entrance error code.

I've installed the kit in two other games that came with the later matrix and used the L1AT and it always worked great as long as both optos going in and out of the planet sensed every ball. Not sure how compatible the two roms are with the other matrixes.

#3169 1 year ago
Quoted from o-din:

I'd take a better look at that planet entrance opto. The ball may not be triggering it each time by or perhaps a problem somewhere else in the circuit.

Early and later Dredds came with different switch locations for the left ramp entrance and unfortunately they changed the switch designation on the matrix itself when they did that. Which caused a few problems depending on what rom was used.

That, and I still have a feeling one of your trough optos is probably dead or flaky... by the description of your issues I’d imagine it is trough 4 or 5. Dredd does some very interesting compensation for dead trough optos.

#3170 1 year ago

Hey all...

I've run into a switch matrix issue with my Judge Dredd. I've got a pretty good lead on the solution (I hope). I didn't want to keep posting updates in this thread and create a bunch of noise here, so I created my own thread.

https://pinside.com/pinball/forum/topic/wpc-judge-dredd-switch-matrix-craziness#post-5117148

Love to hear any thoughts. Especially on the 2nd issue where the crane and the global rotate just a little when a phantom switch occurs.

... Altan

#3171 1 year ago
Quoted from gunstarhero:

Dredd does some very interesting compensation for dead trough optos.

Aint that the truth!

Also you can get divots in the trough that can stop the balls from rolling freely.

#3172 1 year ago

Deadworld mod installed and all adjustments of the planet and crane fine tuned for optimal performance and it is working perfect. The crane is always a little tricky as it has to drop the ball right over the exit opto every time.

L1 rom gives me the option now of coin drop or free play which is nice as the L1AT is stuck with free play only. However L1 will only work with sample games or ones that have the earlier switch matrix I believe. Still don't know how the L1AT would work in this game.

I like that the kit also comes with a plastic trough liner for divots or magnetization that I have used on other games before. Thank you Pinbits!

#3173 1 year ago

Pinbits all the way!

#3174 1 year ago
Quoted from altan:

Love to hear any thoughts. Especially on the 2nd issue where the crane and the global rotate just a little when a phantom switch occurs.

That little movement is normal in Dredd. Even during some testing. All of mine did that.

Hopefully you didn't do what I did. Game was working perfect until I installed a color DMD. Then I got all kinds of crazy stuff going on. Message says a whole row is shorted and it is putting two balls in the shooter lane but won't fire them. Switch test show's I've got two rows shorted and switches firing other switches.

Looked back over everything and a green switch wire that goes to the cpu got caught under the nut on the ground post where all the green ground wires go in the backbox. After pulling it out of there it all went back to normal.

Green is green, what can I say?

1 week later
#3175 1 year ago

I'm thinking about buying a color dmd for my recently purchased Dredd. I was told by someone that I may need to buy a secondary power supply for it since it's already running with set of pinstadiums. Anyone have any experience with this?

#3176 1 year ago
Quoted from BirdForce1:

I'm thinking about buying a color dmd for my recently purchased Dredd. I was told by someone that I may need to buy a secondary power supply for it since it's already running with set of pinstadiums. Anyone have any experience with this?

Don’t pinstadiums draw power from the service outlet in the lower cab and not from the power driver board?

#3177 1 year ago
Quoted from PinRob:

Don’t pinstadiums draw power from the service outlet in the lower cab and not from the power driver board?

Nothing plugged in the service outlet. The gentleman that sold this to me said the main problem would be the ball not making it up the ramp because the flippers would weaken if I installed a color dmd.

#3178 1 year ago
Quoted from BirdForce1:

Nothing plugged in the service outlet. The gentleman that sold this to me said the main problem would be the ball not making it up the ramp because the flippers would weaken if I installed a color dmd.

I had a LED ColorDMD on my Dredd and it makes no difference that I could tell, before I installed it or after I moved it to another game.

Plus I am pretty sure that the ColorDMD and flippers don’t draw from the same section of the power board.

#3179 1 year ago

FYI - there is a shiny gold JD eagle topper on eBay for $119 (OBO) plus shipping if anyone needs one. Also another set of JD decals in another listing.

(I have no affiliation with these listings - just posting a FYI to be helpful)

#3180 1 year ago

On my JD I have a ColorDMD wired in as per its instructions without any perceived negative impact. I also have Pinstadiums plugged into the service outlet. I highly recommend both. While on the topic, I also have OCDLED boards that make all of my LEDs nice and smooth, and a pinsub board out to a subwoofer for some added oomph. I am sure I have a few other mods but can't recall them at this time.

#3181 1 year ago

My Super Game doesn’t start and upon putting it into switch test the button doesn’t register. Is there supposed to be a diode on this switch? The regular start button doesn’t have one.

3F3E7F7C-AB32-4334-92DB-9C82A2BE509E (resized).jpeg
#3182 1 year ago
Quoted from allsportdvd:

My Super Game doesn’t start and upon putting it into switch test the button doesn’t register. Is there supposed to be a diode on this switch? The regular start button doesn’t have one.

My supergame button has the diode and looks just like yours. My supergame button also didn't work when I first got the game. My issue was mechanical--there was too much space between the exterior button and the switch.

#3183 1 year ago
Quoted from allsportdvd:

My Super Game doesn’t start and upon putting it into switch test the button doesn’t register. Is there supposed to be a diode on this switch? The regular start button doesn’t have one.[quoted image]

Short the switch button with a wire and see if registers in switch test or starts a game. The switch might just be bad.

#3184 1 year ago

After moving JD to a new home, the planet on my JD dead world isn't staying connected.

How does the planet piece attach?

Does it kind of just sit there or should it snap on? Or something else?

... Altan

#3185 1 year ago
Quoted from altan:

After moving baby JD to a new home, the planet on my JD dead world isn't staying connected.
How does the planet piece attach?
Does it kind of just sit there or should it snap on? Or something else?
... Altan

The top threads on to the bottom. Carefully though - the plastic is thin and easily can crack if tightened too much

#3186 1 year ago

Just got a JD the other day with 2 other games.Got it up and running after sitting idle for over 2 years.Luckily it had lithium batteries installed which were dead resulting in no cpu damage.Other than being a little dirty the game seems to be a diamond in the ruff.Playfield is perfect without wear,Cabinet is real nice with no fading.The reds really pop,and gameplay is fast and furious.The dilemma is how far to take this game.Its all original with matching boards ,incandescent bulbs and clean plastics and ramps.So I’m in the club for the time being.Just want to beat the piss out of it for a while and then decide what to do with it.Im putting some leds in as it seems to be a no brainer.Any thoughts on further mods or bullet proofing would be appreciated.

042EC38D-7BEA-45C4-88CA-824EFE099CC8 (resized).jpeg44F46588-12C0-4681-802D-AE74E576BFC6 (resized).jpeg5B412618-34D0-46BE-9E4E-EAAFF435C129 (resized).jpeg93D73AAC-4B0A-4DE6-A62E-7DCED17E5312 (resized).jpegB88749A6-E3C7-48A3-9E4A-E9586764D3EC (resized).jpegD15E8520-17C6-4A09-8127-1CB32A150850 (resized).jpeg
#3187 1 year ago
Quoted from locksmith:

Just got a JD the other day with 2 other games.Got it up and running after sitting idle for over 2 years.Luckily it had lithium batteries installed which were dead resulting in no cpu damage.Other than being a little dirty the game seems to be a diamond in the ruff.Playfield is perfect without wear,Cabinet is real nice with no fading.The reds really pop,and gameplay is fast and furious.The dilemma is how far to take this game.Its all original with matching boards ,incandescent bulbs and clean plastics and ramps.So I’m in the club for the time being.Just want to beat the piss out of it for a while and then decide what to do with it.Im putting some leds in as it seems to be a no brainer.Any thoughts on further mods or bullet proofing would be appreciated.[quoted image][quoted image][quoted image][quoted image][quoted image][quoted image]

Looks pretty good, congrats!

#3188 1 year ago

Great colors! Mine is faded from years in a barcade before I saved it. Congrats on a nice find and welcome to the club.

1 week later
#3189 1 year ago

Does anyone feel like measuring the height of the topper? I'm tired of searching. I have a short basement ceiling and hope it'll fit.
Thanks!

#3190 1 year ago
Quoted from KenM:

Does anyone feel like measuring the height of the topper? I'm tired of searching. I have a short basement ceiling and hope it'll fit.
Thanks!

8 inch.

#3191 1 year ago

I've been working on the nuclear tower mod and thought I'd try something slightly different. I'm not sure if I've seen anyone do this so there might be a better way. No decals added yet.

If anyone wants to see the details, I have some pictures I can post. Not much point in putting up the same stuff that's been done a few times before.

#3192 1 year ago
Quoted from dzorbas:

I've been working on the nuclear tower mod and thought I'd try something slightly different. I'm not sure if I've seen anyone do this so there might be a better way. No decals added yet.

If anyone wants to see the details, I have some pictures I can post. Not much point in putting up the same stuff that's been done a few times before.

Those are pretty cool, but if I was able to choose, I would want the ones like you did originally. The grey towers with the green lights just looks so cool. Still awesome either way, but just stating my preference. I like the look of original towers. I've never seen any the glow (thank God! Lol)

#3193 1 year ago

Is there some kind of software limitation that keeps the replay at 396m? Mine had a replay in the 100 millions when I first got it and it crept up until it hit 396m. It has been stuck at 396m for several months--probably over a thousand games. I am wondering if I messed something up in the settings or if it just doesn't go any higher. I have the L-6 ROM.

#3194 1 year ago
Quoted from HowardHurtz:

Is there some kind of software limitation that keeps the replay at 396m? Mine had a replay in the 100 millions when I first got it and it crept up until it hit 396m. It has been stuck at 396m for several months--probably over a thousand games. I am wondering if I messed something up in the settings or if it just doesn't go any higher. I have the L-6 ROM.

Not that I'm aware of...
pasted_image (resized).png

#3195 1 year ago
Quoted from mbwalker:

Not that I'm aware of...
[quoted image]

So you have run the replay above 396m?

#3196 1 year ago
Quoted from HowardHurtz:

So you have run the replay above 396m?

I'll check shortly. I do recall installing the latest rom code that allowed an extended ball save. But I didn't adjust the replay.

I actually misread your post and was thinking it was about something else!

#3197 1 year ago

I don't have the manual on hand, but I believe there is an 'auto' option that may apply to replay.

#3198 1 year ago
Quoted from HowardHurtz:

So you have run the replay above 396m?

Just checked. I have the L7 ROM and Replay was set to Auto. Changed it to fixed and I could set it above 396M (not sure if that answered your question).

The one thing I didn't check for: Would it have indicated what the value was in Auto? When I changed from Auto to Fixed, then checked the value - it was at 150M (default).

Charlesd might have hit the nail on the head - maybe the Auto option? Looking at my SnipIt below, looks like you should be able to set it in the A.1 07 Adjustment. I can adjust and save above 396M.

Do you currently have it set to Auto or Fixed?

pasted_image (resized).png
#3199 1 year ago

I have the replay set to auto, it just won't go above 396m. I'm guessing there might be some bug or software limitation of the L6 ROM keeping it there. It's really not an issue since it's just on free play in my living room, but I was curious if anyone else observed the same.

I imagine most here have either gone with the Deadworld ROM or have upgraded to the most current L7 ROM. I have been thinking about upgrading to L7 but the revision notes don't make it seem worth the hassle unless there are a bunch of bug fixes that aren't listed in the rev notes.

#3200 1 year ago
Quoted from HowardHurtz:

I have the replay set to auto, it just won't go above 396m. I'm guessing there might be some bug or software limitation of the L6 ROM keeping it there. It's really not an issue since it's just on free play in my living room, but I was curious if anyone else observed the same.
I imagine most here have either gone with the Deadworld ROM or have upgraded to the most current L7 ROM. I have been thinking about upgrading to L7 but the revision notes don't make it seem worth the hassle unless there are a bunch of bug fixes that aren't listed in the rev notes.

I got the L7 version primarily for the longer ball save.

If you decide to go the L7 route, I think I got it from Matt's Basement Arcade. https://mattsbasementarcade.com/ Reasonable cost (I think around $15ish) and great, fast service. Bought a few times from him and completely satisfied each time.

Promoted items from the Pinside Marketplace
2,950
Sale Pending!
Pittsburgh, PA
$ 35.00
Cabinet - Other
Arcade Upkeep
$ 9.99
Eproms
Matt's Basement Arcade
From: $ 19.99
Eproms
Matt's Basement Arcade
$ 19.95
Playfield - Toys/Add-ons
ULEKstore
There are 3770 posts in this topic. You are on page 64 of 76.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside