(Topic ID: 212361)

Dracula driver board issues


By busa32927

2 years ago



Topic Stats

  • 12 posts
  • 4 Pinsiders participating
  • Latest reply 2 years ago by busa32927
  • Topic is favorited by 1 Pinsider

You

Linked Games

#1 2 years ago

The power driver board test point for the 50 volts test results is 75 volts. I assume there is something wrong but i have no idea on where to look.

Thanks

#2 2 years ago

That's normal.

#3 2 years ago
Quoted from terryb:

That's normal.

As terryb said, it is normal. It's not under load when you test it.

LTG : )

#4 2 years ago

thanks guys. just trying to trace down probable causes for some switch issues. more post to come.

#5 2 years ago
Quoted from busa32927:

just trying to trace down probable causes for some switch issues.

Describe the switch issues you are having.

#6 2 years ago

at first it was a weird row 1 and row 2 error. I tested the main board and everything was good there. I narrowed it down to the 10 switch opto board. i pulled the cap and saw that it was leaking. Cap juice was also under the lm339. replaced both of those. row switch issues are gone. now i have 2 switch errors. Switch 51 and 71. I replaced the optos because i had them on hand. checked the voltages on the optos and they are correct and respond when an object is in its path. so i have no clue as to why the game isnt seeing those 2 switches as being closed. i am taking the 10 switch opto board to test on a friends dracula to see if its the board or if its something else in the game.

i already looked over the board for cold solder joints on header pins and other places.

#7 2 years ago

Sounds like you're taking the correct steps. What are the switch errors?

#8 2 years ago

switch 51 amd 71. i tried the 10 switch opto board in another dracula and it works perfectly. i have tested the cpu board with the row and column touching with the lead. all rows and columns light up as i touch them. i am at a total loss now.

#9 2 years ago

Does your BSD have a -1 Power/Driver Board with the flipper power relay?

Chris Hibler - CARGPB #31
http://ChrisHiblerPinball.com/contact/
http://www.PinWiki.com - The new place for pinball repair info

#10 2 years ago

it has a rotten dog board

#11 2 years ago
Quoted from busa32927:

now i have 2 switch errors. Switch 51 and 71.

Are you getting error messages or they just don't work?

If you're getting an error message then do a factory reset. If they just don't work you've got a break in the row 1 chain. Check continuity from another switch on row 1 to the opto board.

#12 2 years ago

yep there was a bad hack job wire repair by previous owner. pulled out the repair and resoldered it and works now.

Promoted items from the Pinside Marketplace
4,000
Machine - For Sale
Lakeville, MN
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
$ 79.00
Lighting - Under Cabinet
Arcade Upkeep
4,750 (OBO)
Machine - For Sale
Philadelphia, PA

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside