(Topic ID: 142889)

Dr. Who Mini Playfield Errors


By wxforecaster

3 years ago



Topic Stats

  • 6 posts
  • 3 Pinsiders participating
  • Latest reply 3 years ago by pinball_faz
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

There have been 2 images uploaded to this topic. (View topic image gallery).

1029151523a.jpg
20151029_101733.jpg

#1 3 years ago

After nearly 2 years in storage, it's time to put DW back together. When I left her, I had just replaced a stripped motor and reassembled the MPF, leaving it untested in the machine.

So, I hooked up the two connectors required for the MPF motor to function -- the 2 wires connector for the motor, and the 4 connector molex for the opto sensors.

I put DW into test mode and I'll still getting errors despite a freely moving assembly and motor, and a properly sensing opto.

I took the picture below of what doesn't make sense to me. At it's lowest point, you'll see the main housing as a upside U shaped arch to allow the optos to see each other. However, at this lowest point, the wheel is blocking the sensor, as pictured.

Now I could have sworn this thing only went back together one way, so I'm confused as to why my MPF wheel isn't showing the "window at the same point the main assembly is at its lowest point.

20151029_101733.jpg

#2 3 years ago

It should turn a little farther so that the notch in the round metal part stops in the U shaped part. See my crappy cell phone pic.

1029151523a.jpg

#3 3 years ago

Is your picture showing the MPF all the way down or all the way open?

I don't think it's possible to reverse it as the wheel only goes on one way given the "knob" that the washer/E-clip go onto.

Like I said, I've got free movement and properly triggering optos. Does anyone know *what* trips an error in the MPF test mode?

#5 3 years ago

Forget it I'm an idiot. w/o the playfield glass switch depressed, the MPF won't run in attract mode, throwing the no movement errors. However, once I held the switch down with my finger and let it run through, the tests showed the direction reversed. I wish the diagnostic test 14 said the same thing instead of "faults".

Anyways, sure enough, I wired the fricken motor backwards.

#6 3 years ago

Glad you figured it out. Sorry, I could not jump in with pictures.... working in Vegas all week.
faz

Promoted items from the Pinside Marketplace
$ 28.00
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
From: $ 9.99
Eproms
Matt's Basement Arcade
$ 20.00
Electronics
Yorktown Parts and Equip
€ 4.99
Flipper Parts
Multigame
$ 109.99

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside