New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 188398)

Dr Who - cold boot leads to weak coils


By BENETNATH

3 years ago



Topic Stats

  • 3 posts
  • 2 Pinsiders participating
  • Latest reply 3 years ago by BENETNATH
  • Topic is favorited by 1 Pinsider

You

Linked Games

#1 3 years ago

Hello, i've got a Dr Who in good shape, but since i move it in my basement, i created some issues.
First, i had reboots, which where fixed by fixing better the driver boards which was unscrewed.
Now the game is running perfectly and stable as long as you are not launching a game directly after cold boot.

If you do so, the plunger and the vertical eject coils are totally weak, the launcher doesn't even manage to throw the ball to the end of the alley.

If i boot the machine and wait some minutes, the game starts perfectly well without a glitch.

Any idea ?

Thanks to all

#2 3 years ago

It still sounds like a bit of a connection issue especially earth related. It might well be worth going through the earth straps and connections to those wherever they occur across the backbone and playfield.

Best of luck.

#3 3 years ago

Thanks Muppet, but grounding may explain the cold boot effect? i will dig around that

Promoted items from the Pinside Marketplace
$ 25.00
Lighting - Led
Pinshakers
$ 35.00
Cabinet - Other
Arcade Upkeep
$ 49.95
Lighting - Led
Pin Stadium Pinball Mods
3,600
Machine - For Sale
San Diego, CA
$ 349.95
Lighting - Led
Pin Stadium Pinball Mods
5,200
Machine - For Sale
Colorado Springs, CO

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside