New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 76377)

Doctor Who Owners Club.....Time Lords Welcome!


By HoakyPoaky

6 years ago



Topic Stats

  • 4,473 posts
  • 339 Pinsiders participating
  • Latest reply 1 day ago by Rdoyle1978
  • Topic is favorited by 154 Pinsiders

You

Linked Games

Topic Gallery

There have been 1,129 images uploaded to this topic. (View topic image gallery).

miniupper (resized).png
uppernut (resized).jpg
82D52F6B-0889-420D-8DCA-1521FA78B3C7 (resized).jpeg
22C6546A-595C-4A31-A92D-84B987495689 (resized).jpeg
9F18D9CE-BFD4-482C-A633-D03F0C7EF740 (resized).jpeg
5E44A78B-2BEA-42FD-9304-126497777C30 (resized).jpeg
73513D06-FFD8-41CB-B66A-E0CE3EBE67FF (resized).jpeg
E1D10F5A-1207-4013-A299-3BFF7F89C799 (resized).jpeg
IMG_5541 (resized).jpg
IMG_6138 (resized).jpg
IMG_6118 (resized).jpg
IMG_6135 (resized).jpg
18548EC0-4850-42CA-B477-07271C92AA16 (resized).jpeg
IMG_20200829_105057 (resized).jpg
IMG_20200829_105033 (resized).jpg
IMG_20200829_105025 (resized).jpg

Topic index (key posts)

4 key posts have been marked in this topic (Show topic index)

There are 4473 posts in this topic. You are on page 33 of 90.
#1601 3 years ago
Quoted from pinballjah:

Are these still available anywhere? Thanks.

I ordered mine from there not too long ago. Just email them, you can probsvly still get one

#1602 3 years ago

Quick update - my game has the PinSound board installed. When I got back home from a long trip I fired up the game and all of a sudden it's resetting! I have not replaced the caps on the power driver board, but The game worked fine 2 weeks ago.

I rewired one of the power wires that feed the miniplayfield, thinking that might be it. Nope.
Tried a couple other things, then disconnected the PinSound. No resets. So I'm now at the threshold where that board is drawing just barely too much power with my other mods (I have colordmd LED in there too). I tried turning down the sound on the PinSound board, and reducing the bass output. Then I raised the volume on the coin door back to (roughly) where the volume was.

Works perfectly now.

#1603 3 years ago
Quoted from Rdoyle1978:

Quick update - my game has the PinSound board installed. When I got back home from a long trip I fired up the game and all of a sudden it's resetting! I have not replaced the caps on the power driver board, but The game worked fine 2 weeks ago.
I rewired one of the power wires that feed the miniplayfield, thinking that might be it. Nope.
Tried a couple other things, then disconnected the PinSound. No resets. So I'm now at the threshold where that board is drawing just barely too much power with my other mods (I have colordmd LED in there too). I tried turning down the sound on the PinSound board, and reducing the bass output. Then I raised the volume on the coin door back to (roughly) where the volume was.
Works perfectly now.

I would go through the reset section for wpc games on pinwiki.

#1604 3 years ago
Quoted from dsuperbee:

I would go through the reset section for wpc games on pinwiki.

I need to replace the caps - had to order some from PBL. But the point I was trying to make was that somehow something failed -just- enough in that 2 week period that suddenly the exact same settings didn't work any more. And solved it (albeit temporarily) by turning down the volume

#1605 3 years ago
Quoted from Rdoyle1978:

I ordered mine from there not too long ago. Just email them, you can probsvly still get one

Thanks, waiting to hear back from them. Hoping it helps with the balls flying off the top ramp. Probably happens 90% of the time.

#1606 3 years ago
Quoted from pinballjah:

Thanks, waiting to hear back from them. Hoping it helps with the balls flying off the top ramp. Probably happens 90% of the time.

I remember finding a regular version of that cover without the etching for sale somewhere else... Marco maybe? The original game didn't have the logo on that plastix

#1607 3 years ago
Quoted from Rdoyle1978:

Works perfectly now.

Just because it's working with the volume down does not mean that this is a voltage issue. It may be vibration.

Before you pull the caps.... pull the board and inspect the solder joints of the caps. Look for any cold solder joints. Those caps are huge and sitting 90 degrees to the board puts a lot of tension on them. So, gravity may be helping contact during a normal operation...until it starts bouncing around.

As dsuperbee said... follow the mantra of PinWiki reset. IF you get to the point of replacing the caps, try simply reflowing the solder first.

If you pull out the caps, you're more than likely going to pull the through-hole-plates as well. Then, you need to add a stitch and even more work.

Best of luck,
faz

#1608 3 years ago
Quoted from pinball_faz:

Just because it's working with the volume down does not mean that this is a voltage issue. It may be vibration.
Before you pull the caps.... pull the board and inspect the solder joints of the caps. Look for any cold solder joints. Those caps are huge and sitting 90 degrees to the board puts a lot of tension on them. So, gravity may be helping contact during a normal operation...until it starts bouncing around.
As dsuperbee said... follow the mantra of PinWiki reset. IF you get to the point of replacing the caps, try simply reflowing the solder first.
If you pull out the caps, you're more than likely going to pull the through-hole-plates as well. Then, you need to add a stitch and even more work.
Best of luck,
faz

WIll do. Thanks for the advice - I am also now getting the "no CCW Movement" error, which I do not understand why that's suddenly happening.

#1609 3 years ago

I have $1 on the table saying that it's the 25 year old connectors to the MPF.

Check the connector to the motor and the optos.

Look at the solder joints on the optos too.
faz

#1610 3 years ago
Quoted from pinball_faz:

I have $1 on the table saying that it's the 25 year old connectors to the MPF.
Check the connector to the motor and the optos.
Look at the solder joints on the optos too.
faz

Funny how they would just 'go bad' after sitting for 2 weeks. I have not taken anything apart since we got the MPF tuned up perfectly.
I'll do a deeper dive in the morning.

#1611 3 years ago
Quoted from pinballjah:

Are these still available anywhere? Thanks.

Contact him. He can probably make them to order.

Good people!

#1612 3 years ago

I noticed last night that some of the little 'mushroom' buttons on the Time Expander aren't registering shots. I've only owned this game a shirt time and am still learning about it as I play. Should 1 hit always register something? And if there is problem, will I need to pull that entire center playfield assembly out to get at what I'll need to?

Thanks in advance for any help!

#1613 3 years ago
Quoted from Minneapolispin:

I noticed last night that some of the little 'mushroom' buttons on the Time Expander aren't registering shots. I've only owned this game a shirt time and am still learning about it as I play. Should 1 hit always register something? And if there is problem, will I need to pull that entire center playfield assembly out to get at what I'll need to?
Thanks in advance for any help!

Yes and unfortunately yes.

You can raise the mini pf in test mode, and then individually test the switches to see which ones register/dont. It can't hurt to double check the connection as well.

#1614 3 years ago
Quoted from Slim64:

Yes and unfortunately yes.
You can raise the mini pf in test mode, and then individually test the switches to see which ones register/dont. It can't hurt to double check the connection as well.

This has happened to me before - check the big molex connector that goes to the Optos that read the mushroom targets. Re-seat it a couple of times. Then you'll have to try the flashlight test. You may find the opto emitter(s) have burned out. But hopefully not!

#1615 3 years ago
Quoted from Minneapolispin:

I noticed last night that some of the little 'mushroom' buttons on the Time Expander aren't registering shots. I've only owned this game a shirt time and am still learning about it as I play. Should 1 hit always register something? And if there is problem, will I need to pull that entire center playfield assembly out to get at what I'll need to?
Thanks in advance for any help!

If you do pull the mini-playfield, I recommend lightproofing the optobank with secure tape. Be on the lookout for any broken wire connection to the opto board, as the wires are thin and can break off easily. Last time I pulled my Time Expander, two wires easily broke off of the board.

#1616 3 years ago
Quoted from Rdoyle1978:

I ordered mine from there not too long ago. Just email them, you can probsvly still get one

Just curious, do you have original or reproduction ramps? I recently installed the thicker reproduction ramps and had a heck of a time fitting them together with the plain reproduction ramp covers. They eventually fit together, but it was much more cramped than with the original ramps and covers. I want the stenciled versions but am nervous they will be even more difficult to fit together.

#1617 3 years ago
Quoted from timelord_warner:

Just curious, do you have original or reproduction ramps? I recently installed the thicker reproduction ramps and had a heck of a time fitting them together with the plain reproduction ramp covers. They eventually fit together, but it was much more cramped than with the original ramps and covers. I want the stenciled versions but am nervous they will be even more difficult to fit together.

Thicker ramps mean less space. I've always had to do a little trimming on all my repro ramps

#1618 3 years ago
Quoted from timelord_warner:

Just curious, do you have original or reproduction ramps? I recently installed the thicker reproduction ramps and had a heck of a time fitting them together with the plain reproduction ramp covers. They eventually fit together, but it was much more cramped than with the original ramps and covers. I want the stenciled versions but am nervous they will be even more difficult to fit together.

Mine are original, but I don't know if the hardware is. I seem to remember having to try a couple of things to get it all to fit. I can't remember exqcrly but I did fill in the holes with plastic filler and re-drill to make them more stable

#1619 3 years ago
Quoted from Rdoyle1978:

Funny how they would just 'go bad' after sitting for 2 weeks. I have not taken anything apart since we got the MPF tuned up perfectly.
I'll do a deeper dive in the morning.

Update. Pretty sure it's the alignment of the brackets. You have got to be kidding me...

#1620 3 years ago
Quoted from Rdoyle1978:

Update. Pretty sure it's the alignment of the brackets. You have got to be kidding me...

I just fought a long battle to get the MPF moving just right. I squared the brackets and still could not get a consistent action (it worked one day and not the next). I replaced the metal washers with nylon washers and tightened the set screws on the cam. When I inspected the metal washers, I found 2 were bent and obviously worn. Not sure if the rest of the community supports the use of nylon washers, but I am quite happy thus far *knock on wood*. I recognize that the nylon washers will wear faster than metal. I'm OK with replacing them in a few years if it means a smooth action and no further grooving in the MPF support brackets.

#1621 3 years ago
Quoted from timelord_warner:

Not sure if the rest of the community supports the use of nylon washers

All good or even UHMW Tape on the brackets to take up slack has been successful.

Just be sure to back away slowly from the grease can
faz

#1622 3 years ago

I have had some MPF things pop up here and there and every time it has been one of the two wires at the very bottom of the unit coming loose so I've had to re-soder them. Pretty easy job and an obvious fix when there are wires hanging wildly.

#1623 3 years ago

Thanks for the opto advice! I'm truly in love with this game. So happy I lucked out and found one.

#1624 3 years ago

I've been working on a co-worker's Doctor Who and I was down to the five "Dalek Bumps". One wouldn't work some of the time. I found a wire off of the board and soldered it back. It worked and then it stopped. I had other problems with lights on the time expander that was due to bad previous repairs. I fixed them (even had to replace a shorted wire) and then the same bump (R1) stopped working consistently again. I took it apart again and added solder to every solder point on the opto boards. I was not the first person to be in there. This fixed it. The weird part is, I know the history of this game and he bought it in 1997. It had some pretty bad repairs in the short time he didn't own it. I found wires taped with electrical tape into connectors but not crimped or soldered. Operators really didn't care as long as it worked to some degree. I fixed everything back to factory. He's getting it back tomorrow!

2 weeks later
#1625 3 years ago

I've got a Dr. Who that needs some TLC for $2,500 firm or trade if you want to join this club. PM for details.

#1626 3 years ago

Quick update: figured out ALL of my issues were related to the flasher not being plugged in. Wtf! The plug had somehow gotten pulled out and was causing a lot of weird power issues

#1627 3 years ago

I found this Tardis Wall Light at FYE. ThinkGeek also sells it. Mounts to the wall with two screws and is battery powered. Top light blinks and it is lit inside.

20170924_155607 (resized).jpg

#1628 3 years ago
Quoted from Backyardace:

I found this Tardis Wall Light at FYE. ThinkGeek also sells it. Mounts to the wall with two screws and is battery powered. Top light blinks and it is lit inside.

Very cool! I like the way it lights the windows as well

#1629 3 years ago

Just added a mod I've been working on for a while:

#1630 3 years ago
Quoted from Rdoyle1978:

Just added a mod I've been working on for a while:

NICE! Love K9!

How'd you tie it in?
faz

#1631 3 years ago
Quoted from pinball_faz:

NICE! Love K9!
How'd you tie it in?
faz

I really didn't like having two of the Whomobiles on the playfield, since that thing was really only used during one season for the 3rd doctor, so I started thinking. I pulled out the guts from the K-9 toy and hollowed it out enough to sit over the switch and replace the ugly Whomobile.

Then I was just going to put a small LED in there and tie it to an insert or something, but the only thing that lights up when you hit that ramp is a flasher - the left and right red dots to either side of the MPF. So... I stuck a (way too big, honestly) flasher in there and blocked some of the light so it's not *quite* as bright. When the right hand circle flashes, so does K-9. If I have time, I may open him back up and put a smaller LED in there, but I didn't have the right resistor at the time, so I just disassembled a 4-led flasher.

Since I have a PinSound, I found the sound effect that plays when you hit the Sonic Boom ramp, and just replaced that with a sample of K-9's voice. I want to find some other samples of him talking, but "affirmative master" was the most obvious choice. I still have some tweaking to do, but it works really well.

the Sonic Screwdriver is just tied into the light under the right sling. And I ended up replacing the light under the new Tardis with a coin door socket and a #47. For some reason, it pulses (ghosting?) which ends up looking really cool in that toy.

#1632 3 years ago
Quoted from Rdoyle1978:

I pulled out the guts from the K-9 toy and hollowed it out enough to sit over the switch and replace the ugly Whomobile

I really like this idea, where could I find that toy?

Cheers
//Micael

#1633 3 years ago
Quoted from mima:

I really like this idea, where could I find that toy?
Cheers
//Micael

I think I found it on Amazon; i don't recall it being terribly hard to find -

here you go:
amazon.com link »

#1634 3 years ago

I'm shopping out a Dr Who for my buddy and it has a pinsound board installed. Only problem is that I can't find any good mixes available for download. The one I'm specifically looking for are pinballshark mixes, even more specifically, the Modern mix, but wouldn't mind getting the other mixes he's made up either. Is anyone able to host the download, since it's not available from the Pinsound website?

1 week later
#1635 3 years ago

I had the mixes removed a while back because of all the tech support requests I kept getting. But, now I get requests wondering where they are, lol. Anyway, I asked for them to be put back up on pinsound-community.org as I'd like to update them as well. Just waiting for a response from them at this point.

These are all the Pinsound mixes I made for DW. There's about 50 hours invested in making them.

Modern

Disco

Doctorin' the Tardis

Doctor Who Meets Metal

#1636 3 years ago

Man I need to upload my draft version of the pinballshark Modern mix, love it!

#1637 3 years ago

The modern mix is awesome! I would love to change it out with the others too! Can't wait until they're back up on Pinsound. Thanks pinballshark!

#1638 3 years ago
Quoted from pinballshark:

I had the mixes removed a while back because of all the tech support requests I kept getting. But, now I get requests wondering where they are, lol. Anyway, I asked for them to be put back up on pinsound-community.org as I'd like to update them as well. Just waiting for a response from them at this point.
These are all the Pinsound mixes I made for DW. There's about 50 hours invested in making them.
Modern
» YouTube video
Disco
» YouTube video
Doctorin' the Tardis
» YouTube video
Doctor Who Meets Metal
» YouTube video

Your mixes are awesome! Makes me want to buy a Pinsound board for my machine. That and the led version of the ColorDMD.

Robert

#1639 3 years ago

Joined the club recently. Got my Doctor Who from a guy in Daphne, Al for $1500.

Pics below are of how I got it.

I had to rebuild the Dmd controller, repair/rebuild some of the Driver board, re-pin several connectors. New rubbers, new led's throughout, clean/repair the mini playfield assembly. Put on mirror blades and a new Tardis. New pop bumper bodies, aprons, and caps.

New artwork will go on in the next 2 weeks. And Cliffy Protectors should be coming soon.

Here's a quick vid of how it currently looks:

https://drive.google.com/file/d/0BwYm1Q282Qt8SjJ1VnBKRk1tVU0/view?usp=sharing

20170922_104755 (resized).jpg
20170922_104745 (resized).jpg
20170922_104949 (resized).jpg
20170922_104722 (resized).jpg

#1640 3 years ago

Great buy! $1500 is a steal

#1641 3 years ago

Ok folks, quick question- not really specific to DW but here goes. I noticed the other day that i have the Doctor (1) insert, as well as the left drain "extra ball" and a couple of the 5x3 inserts are ghosting. But the Doctor (1) stays on ALL the time basically- and the left drain pretty much as well.

I have the LEDOCD installed, which I thought would help - but so far no. These lights are not all in the same row / column of the lamp
Matrix., and I don't believe it is a transistor issue.

I realize this is a complex question but I've checked everything I know to check. LEDOCD is supposed to handle ghosting issues, and I know it is working, but definitely
Something seems off. Any ideas?

#1642 3 years ago

Any chance either of you sitting on a spare original translite?

#1643 3 years ago
Quoted from mima:

Any chance either of you sitting on a spare original translite?

Original Bally or original Williams?

#1644 3 years ago
Quoted from Rdoyle1978:

Original Bally or original Williams?

Either I assume. I didn't even know that there where two different "originals". where can I see a picture of both?

#1645 3 years ago
Quoted from mima:

Either I assume. I didn't even know that there where two different "originals". where can I see a picture of both?

I wasn't trying to be coy - but the game was designed with a Bally style backbox first, then quickly retrofit with a Williams box right before manufacturing - you are looking for the shipped translite then. I have one but I want to keep it in case I ever need to sell, sorry!

Is your game missing one?

#1646 3 years ago

Here's a question for all DW owners.

When the game is over and I get a high score and input my initials, the game immediately starts another game. Do they all do that?

How do I turn this behavior off?

#1647 3 years ago
Quoted from pinballshark:

Here's a question for all DW owners.
When the game is over and I get a high score and input my initials, the game immediately starts another game. Do they all do that?
How do I turn this behavior off?

Are you sure you're not just hitting the start button twice on that last letter? Maybe the switch is a little too sensitive?

#1648 3 years ago
Quoted from Rdoyle1978:

I wasn't trying to be coy - but the game was designed with a Bally style backbox first, then quickly retrofit with a Williams box right before manufacturing - you are looking for the shipped translite then. I have one but I want to keep it in case I ever need to sell, sorry!
Is your game missing one?

Here's the original translite:
http://www.pfutz.us/UnofficialDoctorWhoPinballHistory/DrWhoConcept1.jpg

#1649 3 years ago
Quoted from Rdoyle1978:

Are you sure you're not just hitting the start button twice on that last letter? Maybe the switch is a little too sensitive?

No, I'm not hitting the switch twice. The start button works fine.

#1650 3 years ago
Quoted from pinballshark:

Here's a question for all DW owners.
When the game is over and I get a high score and input my initials, the game immediately starts another game. Do they all do that?
How do I turn this behavior off?

Mine does that as well. I just figured that it was a side effect of the game being set for 'free play'.

Is a touch annoying tho I will grant you.

Promoted items from the Pinside Marketplace
$ 109.99
£ 99.00
There are 4473 posts in this topic. You are on page 33 of 90.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside