(Topic ID: 236361)

Doctor Who Mini Playfield No Switches Working - UPDATE!


By pinlink

5 months ago



Topic Stats

  • 33 posts
  • 5 Pinsiders participating
  • Latest reply 4 months ago by pinball_faz
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

There have been 3 images uploaded to this topic. (View topic image gallery).

Capture (resized).PNG
TZ (resized).PNG
DW (resized).PNG

You're currently viewing posts by Pinsider eyeamred2u.
Click here to go back to viewing the entire thread.

#18 5 months ago
Quoted from pinlink:

Also on this, yes the CPU had some battery leakage and was effecting the game (ground shorts on multiple rows).
However, I have since replaced the CPU with a known working (and very clean) CPU. With this new CPU I had the game completely working other than the one opto sw75. Now here we are after I tried to fix the one bad opto. If only I had a time machine...

Corrosion on the female connectors? repin the connectors. Did this on mine, similar errors and I put in new MPU, had errors until I fixed connectors. Hope you can solve this problem.

#25 5 months ago
Quoted from pinlink:

UPDATE!
First, thanks to everyone that has posted in this thread and provided help with this problem.
And a huge THANK YOU to Faz. Faz has gone above and beyond to help me with this problem, including talking to me on the phone and face timing with me to help resolve this issue. Faz, you are a great person and I hope to meet you face to face some day.
I believe we have isolated the problem. I think it is actually a CPU problem, not the Mini Playfield. Here is the timeline of events best I can recall:
-I bought this game and it had a row of switches out (row 7) and switch 75 was not working as well.
-Open up the game to see that there is battery damage on the CPU
-Replaced the CPU with a known working one from my TZ, and now row 7 switches work, but still switch 75 is out.
-Take out the Mini Playfield to find that the LED is broken off at Switch 75.
-Replaced the LED and turned the game on only to find that I had put the LED in backwards which caused errors.
-Replaced the LED and put it in correctly this time, and turned the game back on
-Now All optos and switches on the Mini Playfield do not work (Column 7).
-After going over everything with Faz, I was stumped and decided to put the CPU back into TZ to see if anything had changed. And it did.
-Now the CPU in TZ is throwing errors. And the switches that are not working on TZ are all optos! And it is the same Column of switches in the matrix that is
not working!
-This makes me think that when I replaced the LED incorrectly and turned the game on, something happened to the CPU...?? (is that possible?)
I am hoping that by replacing the CPU with a new one, it will fix the issues I am having with the Mini Playfield. Of course now I have two bad CPU's. I ordered a new rottendog CPU and plan to first put it in the TZ, and if it fixes the TZ errors, I will try it in the DW and pray that all of my problems go away.
Also, does anyone know what specifically would be wrong with the CPU to cause the same Column of switches to be out in both games?
My thought was that is was U19 causing ROW 7 to be out initially, because there was damage there. The working CPU from TZ fixed that row of switches.
Is it possible that now the problem is at U20 since it is now COLUMN 7 that is not working? Would installing a backwards LED cause issues with U20, which would effect Column 7?
Thanks again for everyone's help. I will keep you all posted once I receive the new CPU.
[quoted image]
[quoted image]
Doctor Who switch matrix
[quoted image]

That is good news. I have the WPC shematics for Doctor Who and if you need assistance, let me know. Faz, you are awesome for helping. I am going to look at them when I return home and trace out your issue on the MPU.

Ken

Promoted items from the Pinside Marketplace
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
Trade
Machine - For Trade
Cincinnati, OH
$ 9.99
Eproms
Matt's Basement Arcade
$ 50.00
$ 129.00
Lighting - Led
LED OCD

You're currently viewing posts by Pinsider eyeamred2u.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside