(Topic ID: 52019)

Do You Want To Know More? SST Owners club; Past, Present and Future.


By tamoore

6 years ago



Topic Stats

  • 585 posts
  • 103 Pinsiders participating
  • Latest reply 4 months ago by broher
  • Topic is favorited by 35 Pinsiders

You

Linked Games

Topic Gallery

There have been 135 images uploaded to this topic. (View topic image gallery).

WhatsApp Image 2019-03-05 at 17.41.35 (resized).jpeg
20181209_174520 (resized).jpg
20181209_174550 (resized).jpg
20181209_174325 (resized).jpg
20181209_174529 (resized).jpg
20181107_183433 (resized).jpg
20181107_182341 (resized).jpg
20181017_141308 (resized).jpg
20181017_141252 (resized).jpg
20180813_011653 (resized).jpg
SST Color DMD (resized).jpg
SSTDriver (resized).jpg
images-1 (resized).jpeg
Backbox1 (resized).jpg
Backbox2 (resized).jpg
Backbox3 (resized).jpg

There are 585 posts in this topic. You are on page 12 of 12.
#551 1 year ago
Quoted from Scorch:

I'll be joining the club tomorrow.
Just went and saw a pristine SST that must be HUO. Even has the unopened bag of goodies... couldn't find a single scratch or scuff on the cabinet. Needs LED's, probably some new rubber, and a clean and wax. Also, in the test, the red flashers weren't working... hope it's just the bulbs, but if not I may be asking for some help troubleshooting.
Picking it up for $2000 which I think is a pretty good deal these days. Current owner had no idea you could go in and change the settings, didn't know how to remove the glass or even that the backbox opened. He had it in his gameroom for the last 11 years and is downsizing.
Can't wait to get this baby home... I love the movie... Love how cheesy it is and the special effects set a new standard when the movie first came out.

Yeah, jump on that for $2k - nice find! I have had this game for years and still play it almost every day. I just had a monster game a couple nights ago where I got recon level 6 twice. Love this game. Welcome to the club (hopefully)!

#552 1 year ago

I'm in!

Picked it up this afternoon.

batteries were dead, but fine. Also noticed that the cabinet woofer was torn (didn't notice that until I had the cabinet up on it's back), so looks like I'm going to have to replace the speakers.

Red flashers are also not working, and while I don't have any 906 bulbs yet, I think the circuit is out. any suggestions on where to start with diagnosing this?

Also.... how difficult is it to replace the GI with LEDs? looks like I'll have to do a full tear down?

#553 1 year ago
Quoted from Scorch:

I'm in!
Picked it up this afternoon.
batteries were dead, but fine. Also noticed that the cabinet woofer was torn (didn't notice that until I had the cabinet up on it's back), so looks like I'm going to have to replace the speakers.
Red flashers are also not working, and while I don't have any 906 bulbs yet, I think the circuit is out. any suggestions on where to start with diagnosing this?
Also.... how difficult is it to replace the GI with LEDs? looks like I'll have to do a full tear down?

Congrats on your new pin!!

I will help where I can, I am still very green and learning as I go.

Everything on the game can be switched to LEDs with no problems at all. In case you don't already know if you switch flashers bulbs to LED the polarity does matter. So if you put a LED flasher in and it doesn't work just pull it and turn it 180 and put it back in.

As for your red flashers most likely a bad transistor. Q25 is the transistor for RED.

Do you have a manual? If not shoot me your email in a PM and I can send you a PDF of it. The paper manual is better some of the text on the PDF is blurry.

Here is a pic of the location of Q25. The transistor model is TIP102
SSTDriver (resized).jpg

#554 1 year ago

I would not do led flashers as it's blinding in this game.
As far as led cool or warm white in the gi and any inserts will need non-ghosting leds

#555 1 year ago
Quoted from Mitch:

I would not do led flashers as it's blinding in this game.
As far as led cool or warm white in the gi and any inserts will need non-ghosting leds

Or do led flashers cause they look bold colorful and awesome. Just pick a different bulb that's not as bright.

#556 1 year ago

ya... I figured it was a bad transistor (one is out on another of my pins).

I think I'm going to need a lesson in soldering circuit boards. I'll have to find some old ones to practice on and then take the plunge (how hard can it be right?)

#557 1 year ago

Also I've got a load of white LED's coming from AliExpress (both GI and inserts). They should be here in 10 days or so.

Probably won't change out the flashers for LED as I think they're pretty good right now.

#558 1 year ago
Quoted from Scorch:

ya... I figured it was a bad transistor (one is out on another of my pins).
I think I'm going to need a lesson in soldering circuit boards. I'll have to find some old ones to practice on and then take the plunge (how hard can it be right?)

It's actually not that hard to solder. But not a bad idea to practice a little. As with everything YouTube has a lot of tutorials on how to solder. But a quality soldering iron will help and everyone has something they like to use others might not. Personally I like to use desoldering briad or wick they call it instead of a solder sucking pump. I never could use one the right way. And I use a solder flux cleaning pen. That's about it in a nut shell. I usually clean the board I am working on after I finish soldering.

Must be something with the red flashers on SST. As you can see in my pic Q25 is new. lol As for flashers I have bulbs in all mine with the exception of the multiball bug flashers and the brain bug flashers.

#559 1 year ago

Thanks...

I did watch some youtube and it doesn't look too difficult.... slow and steady

#560 1 year ago

got the new speakers in. definitely an improvement. Can understand everything they are saying now... also even though the two backbox are full range, the screeches are definitely less piercing than before.

1 week later
#561 11 months ago
Quoted from Lithonion:

As for your red flashers most likely a bad transistor. Q25 is the transistor for RED.

Did my first soldering job on a board, and it turned out pretty damn good!

Fixed the problem of the red flashers... but now the bank of 4 flashers on the right side of the pin are only working intermittently (the problem started before I did the repair). I read somewhere that this is sometimes caused by not enough voltage getting to that last bank. I'm waiting on some LED bulbs to go in that bank, so hopefully that will help. I already re-seated all the lamp connections, and that didn't help at all, and all the connectors looked fine.

#562 11 months ago

LED flashers in SST is INSANE! Seriously, try it out but I can't imagine you'd keep them in there for long, so make sure you have regular flasher bulbs on hand for when the time comes.

#563 11 months ago
Quoted from Scorch:

Did my first soldering job on a board, and it turned out pretty damn good!
Fixed the problem of the red flashers... but now the bank of 4 flashers on the right side of the pin are only working intermittently (the problem started before I did the repair). I read somewhere that this is sometimes caused by not enough voltage getting to that last bank. I'm waiting on some LED bulbs to go in that bank, so hopefully that will help. I already re-seated all the lamp connections, and that didn't help at all, and all the connectors looked fine.

Just to complete.... I replaced the flashers with LEDs and the right bank flashers now work. And yes.... it is insane with led flashers. I wonder if I can cover some of the SMDs ... maybe a little electrical tape?

#564 11 months ago
Quoted from Scorch:

Just to complete.... I replaced the flashers with LEDs and the right bank flashers now work. And yes.... it is insane with led flashers. I wonder if I can cover some of the SMDs ... maybe a little electrical tape?

I have fully swapped LEDs on mine all except the flashers. Now I'm wondering if I shouldn't. What about using just standard frosted LEDs instead of LED flashers? Is that wrong to do?

#565 11 months ago
Quoted from brianmcculloh:

I have fully swapped LEDs on mine all except the flashers. Now I'm wondering if I shouldn't. What about using just standard frosted LEDs instead of LED flashers? Is that wrong to do?

You could if you can find 12v frosted LEDs. All the LEDs on the playfield and inserts are 6.3V
I left bulbs in all my flashers with the exception of the Brain Bug under the playfield and the bug multi-ball.

#566 11 months ago
Quoted from brianmcculloh:

I have fully swapped LEDs on mine all except the flashers. Now I'm wondering if I shouldn't. What about using just standard frosted LEDs instead of LED flashers? Is that wrong to do?

I put LED flashers in mine and it's great! The LED colors are so much richer than an incandescent bulb. The lightshow is one of the awesome things about SST and I love the lightshow enhancement with LEDs. Don't use really bright ones (it's still super bright), just something basic to let you color match to the domes.

#567 11 months ago
Quoted from brianmcculloh:

I have fully swapped LEDs on mine all except the flashers. Now I'm wondering if I shouldn't. What about using just standard frosted LEDs instead of LED flashers? Is that wrong to do?

Try it out and see if you like it...

Here are some cheap 12v flasher bulbs on amazon that I used which work very well

amazon.com link » only $0.35/bulb.

You do not need colored LED's in my opinion if you use a cool white bulb... only difference you will probably see is that when they flash, you do see some white light below the flasher that leaks on to the playfield. They also offer some smaller frosted bulbs that look like they have 2 smd's for about $0.80 each,

amazon.com link »

I haven't tested them so no idea how good they are, however, they look identical to the ones Comet sells for $2.29 each (http://www.cometpinball.com/product-p/opmax12v.htm)

Note.... brain bug and other flashers are 6V, so these are only good for the 4 banks of colored beacons.

#568 11 months ago

Picked up an unshopped SST....THis will be my 3rd What are the rubber posts on the bottom of alot of the posts in the game. Several are rotted down to nothing? Example is the top post of the right sling.

So most go with warm white leds and not much color?

#569 11 months ago
Quoted from billsfanmd:

Picked up an unshopped SST....THis will be my 3rd What are the rubber posts on the bottom of alot of the posts in the game. Several are rotted down to nothing? Example is the top post of the right sling.
So most go with warm white leds and not much color?

Personally I hate warm white, so I don't use those anywhere for GI, except in games where I want a yellowish hue (something like Indiana Jones). That aside, I used some purples because it's a space theme, but more so because there is lots of UV reactive colors in the playfield, namely the orange. Looks cool to get a little glow from those areas.

#570 11 months ago
Quoted from Cheeks:

Personally I hate warm white, so I don't use those anywhere for GI, except in games where I want a yellowish hue (something like Indiana Jones). That aside, I used some purples because it's a space theme, but more so because there is lots of UV reactive colors in the playfield, namely the orange. Looks cool to get a little glow from those areas.

agree. space theme i like cool white, blue and purple

#571 11 months ago

Loving the color DMD! It fits better then the factory DMD.

SST Color DMD (resized).jpg
1 week later
#572 11 months ago

Just picked up SST as my first pin.
The Brain Bug isn't secure on it's platform and moves when hit with the pinball.
Then jams the whole thing when it drops down with it's legs.
Can't tell from the manual diagram if there are any screws that should be in there or if it is secured in another way.
What can I do to keep the lil guy from wiggling his way out?

20180813_011653 (resized).jpg

#573 11 months ago
Quoted from DrkUno:

Just picked up SST as my first pin.
The Brain Bug isn't secure on it's platform and moves when hit with the pinball.
Then jams the whole thing when it drops down with it's legs.
Can't tell from the manual diagram if there are any screws that should be in there or if it is secured in another way.
What can I do to keep the lil guy from wiggling his way out?
[quoted image]

If I get some free time this weekend I will look at mine. I am pretty sure it is screwed to the slide plate. The manual really doesn't show the assembly very well.

#574 11 months ago

IIRC, the bug is attached to the plate below it, which slides back and forth to register hits.

#575 11 months ago

Thanks!

I pulled up the playing field and it looks like I have only 1 very lose screw holding the Brain Bug in place. I tightened it up for now, but going to have to find some replacement screws for the other 3 holes. I am guessing that they are the item 36 in the manual #6-32 X 1/2 PPH MS?

#576 11 months ago
Quoted from DrkUno:

Thanks!
I pulled up the playing field and it looks like I have only 1 very lose screw holding the Brain Bug in place. I tightened it up for now, but going to have to find some replacement screws for the other 3 holes. I am guessing that they are the item 36 in the manual #6-32 X 1/2 PPH MS?

Bring your remaining screw to Home Depot/Lowe’s and ask someone... They’ll get you the right screws.

1 week later
#577 10 months ago

I was playing mine this evening and the sound out of my pinsound + started to get a little choppy and I lost sound out of my subwoofer. Anyone have any suggestions on what to check other than reflashing the latest firmware and plugging and unplugging the cables in the Pinsound + and the CPU board?

#578 10 months ago
Quoted from ElCid95:

I was playing mine this evening and the sound out of my pinsound + started to get a little choppy and I lost sound out of my subwoofer. Anyone have any suggestions on what to check other than reflashing the latest firmware and plugging and unplugging the cables in the Pinsound + and the CPU board?

Check connections to/from PinSound board. Check connections to sub as well. Those can be flaky and come off during shipment.

I wouldn’t reflash anything until you troubleshoot the easy stuff first.

#579 10 months ago

Thanks. I tried it twice and no change...

#580 10 months ago

Anyone have a colorDMD in their SST and have the following problem? I've noticed with the latest firmware that when I advance to Zegema Beach, the DMD will freeze and shows only half the trooper's head and show the words "Today" I unfroze a couple of times, once being when I advanced to Danatana.

#581 10 months ago
Quoted from ElCid95:

Anyone have a colorDMD in their SST and have the following problem? I've noticed with the latest firmware that when I advance to Zegema Beach, the DMD will freeze and shows only half the trooper's head and show the words "Today" I unfroze a couple of times, once being when I advanced to Danatana.

Mine has been working fine.

1 month later
#582 9 months ago

Back in the club after a 4+ year hiatus (or Yatus if you watch Big Brother). Have completed the cabinet cleaning and underneath insert cleaning. Still need to remove and clean the subway. All LEDs in the inserts now, although I only had a 25 pack of non-ghosting bulbs, so only the lower playfield got those. The upper insert LEDs will need to be replaced upon my next order since non-ghosting LEDs flicker on this game.

The only LED GI is in the slings, outlanes and the two spotlights. Both upper corners and almost the entire upper right side GI are out. I have another project ahead of this, so now that I've got it playing 100% I swapped in my Pinstadium kit. Shortcut to stripping the entire playfield to replace all the GI bulbs for now.
20181017_141252 (resized).jpg20181017_141308 (resized).jpg

3 weeks later
#583 8 months ago

Lots of paint worn away from around the flipper buttons on this cabinet. I had a set of metal button covers and drilled a 1 1/4" hole for the 2nd flipper button.

No more wear visible around the buttons.

20181107_182341 (resized).jpg20181107_183433 (resized).jpg
1 month later
#584 7 months ago

DIY stadium style white LEDs with a remote that can cycle between warm-daylight-cool-white. Temporarily mounted with Velcro because I was out of magnetic tape, hence the gap between the rails and the cabinet sides.

20181209_174325 (resized).jpg20181209_174520 (resized).jpg20181209_174529 (resized).jpg20181209_174550 (resized).jpg

2 months later
#585 4 months ago
WhatsApp Image 2019-03-05 at 17.41.35 (resized).jpeg
Promoted items from the Pinside Marketplace
From: $ 16.95
3,000
Machine - For Sale
Bossier City, LA
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 40.00
Lighting - Other
Rock Custom Pinball
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
3,100
Machine - For Sale
Lake Elsinore, CA
$ 279.95
$ 279.95
$ 50.00
Lighting - Other
PinGraffix Pinside Shop
From: $ 18.99
$ 20.00
Electronics
Yorktown Parts and Equip
From: $ 220.00
Playfield - Toys/Add-ons
CzTV Mods
From: $ 19.99
Playfield - Protection
Little Shop Of Games
$ 142.00
Playfield - Toys/Add-ons
The MOD Couple
$ 90.00
There are 585 posts in this topic. You are on page 12 of 12.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside