(Topic ID: 278292)

Dmd issue - wwf royal rumble data east - help

By Holtamania

1 year ago



Topic Stats

  • 6 posts
  • 3 Pinsiders participating
  • Latest reply 1 year ago by RobDutch
  • No one calls this topic a favorite

You

Linked Games

No games have been linked to this topic.

    Topic Gallery

    View topic image gallery

    WhatsApp Image 2020-07-10 at 20.50.21 (5) (resized).jpeg
    AB74A960-CF9E-478F-9113-DF0E25ED0D44 (resized).jpeg

    #1 1 year ago

    Hi all,

    I have recently purchased a wwf royal rumble pinball machine and I am having issues getting the dmd to display a picture.

    I have switched out the dmd with another and still no picture. The dmd rom board seems to be heating up quite significantly also (when I touch it, it almost burns my finger).

    I have checked ribbons and this hasn’t made any difference.

    Does this seem to be a rom issue? Could it be related to earthing or something similar? When I did press down on the rom board I have got some pixels to display which I believe could indicate the dmd is ok?

    Any help would be appreciated.

    Nick

    #2 1 year ago

    Sometimes the dot matrix controller board goes bad causing "no picture" symptoms. Some versions of those boards have surface mount components which makes repair impractical for the average person. In that case, purchasing a replacement board would be the way to go.

    Also, have you checked the simple things first like measuring the power supply voltages for the display? All it takes is just one of the voltages to be bad for there to be no picture. Check to make sure the ribbon cable is plugged in and plugged in correctly.

    #3 1 year ago

    Thanks mate. I did all those things and found the dmd rom was around the wrong way. The rom was also heating up quite a lot. Not it’s fine.

    I am using my other good Led screen to test against and this is what is now coming up...

    Could it be a cooked dmd rom? Or I guess the cooked dmd rom board? :-/

    Any help is greatly appreciated

    AB74A960-CF9E-478F-9113-DF0E25ED0D44 (resized).jpeg
    #4 1 year ago

    If the rom chip was plugged in backwards, then it is destroyed now. You will need to obtain a new display rom chip.

    #5 1 year ago

    Got the new rom and ribbons. I some how managed to get a open door message on my led screen. But now not.. there is 4.96 volts going to the matrix board.. that seems fine?? Surprised as to why it’s not showing a display pic....

    How would I test that the dmd matrix board has issues?

    #6 1 year ago

    I once worked on a Data East Jurassic Park with a similar problem, it didn't boot and the display looked like that.
    Turned out sometimes the game didn't get its 5 volts because a capacitor was eating away the board.
    1 of the capacitors on the power supply board was leaking, I believe C1 or C2.
    Might want to check that.

    But could as well be something different like a rom issue haha.
    Good luck!

    WhatsApp Image 2020-07-10 at 20.50.21 (5) (resized).jpeg

    Hey there! Got a moment?

    Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside