(Topic ID: 203942)

Display acting up on bride of pinbot


By sbjmg

1 year ago



Topic Stats

  • 13 posts
  • 3 Pinsiders participating
  • Latest reply 1 year ago by sbjmg
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

There have been 4 images uploaded to this topic. (View topic image gallery).

20171130_181720_resized (resized).jpg
20171130_080739_resized (resized).jpg
20171130_080805_resized (resized).jpg
20171129_182857_Burst01 (resized).jpg

#1 1 year ago

The top line is displaying weird hieroglyphics all of a sudden. Tried restarting and unplugging and re plugging the ribbons. See picture thanks

20171129_182857_Burst01 (resized).jpg

#2 1 year ago

Did you try reseating the ribbon cable at the MPU?

#3 1 year ago

Yes

#4 1 year ago

Can you post a picture of the MPU board?

#5 1 year ago

Thanks, there was acid damage before. When I get home I will try flipping the cables instead of just re seating them. If I knew which resistors would have an effect on this I would shotgun it and replace all. Thanks for you help. I also attached a picture of the display board.

20171130_080805_resized (resized).jpg

20171130_080739_resized (resized).jpg

#6 1 year ago

Not sure where to go from here, I am assuming the problem is the MPU board but not sure what to replace. I pulled the board out completely and put it back in to no change. Hoping someone can tell me which components on the board could be the culprit.

Thanks

#7 1 year ago

That MPU needs a lot of work to get rid of that alkaline damage. Most of that corrosion is going to affect your switch matrix before too long if not taken care of soon.

Have any other MPU boards to put into the game to narrow down the problem? Also need to see the top half of this MPU board.

#8 1 year ago

Thanks, I have attached the full picture. I do have access to another MPU board, but was unsure on how to take out the main CPU (square shaped chip). I have a general IC puller for the roms but not one for the square shaped piece. Was hoping I could just replace a couple resistors and clean up that area as a quick easy fix but not sure if that is the case...

20171130_181720_resized (resized).jpg

#9 1 year ago

I believe the issue is most likely on your display board not the MPU.

#10 1 year ago

Where would I start there?

#11 1 year ago

OK, i swapped in a semi working MPU board from a Ster Trek Next Gen, and the display works but it says ball missing even though all three ball are in there. Not sure if I need to swap any settings or jumpers to make this thing work properly.

1. I know the issue is with the MPU Board, so what parts need to be swapped (after cleaning the board).
2. If I want to use the spare MPU board what needs to be changed to make it work (ball missing error).

Thanks

#12 1 year ago

Did you swap the game ROM? That is the only thing that needs to change.

I would get a quote on getting that BOP MPU repaired. It needs a lot repaired and the battery corrosion needs to be neutralized properly.

1 week later
#13 1 year ago

Just to close the loop, I swapped MPU boards and it worked, still not sure what happened to board but I sent it out.

Promoted items from the Pinside Marketplace
$ 369.00
Cabinet - Decals
Mircoplayfields
2,960 (Firm)
Wanted
Machine - Wanted
Colorado Springs, CO
$ 40.00
Playfield - Decals
Metal-Mods

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside