(Topic ID: 134304)

Dirty Harry - bunch of weird problems


By miker_70

4 years ago



Topic Stats

  • 75 posts
  • 14 Pinsiders participating
  • Latest reply 4 years ago by miker_70
  • Topic is favorited by 2 Pinsiders

You

Linked Games

Topic Gallery

One image has been uploaded to this topic. (View topic image gallery).

Ball_trough.jpg

There are 75 posts in this topic. You are on page 2 of 2.
#51 4 years ago
Quoted from miker_70:

It's gotta be the magnet thing...it just has to!

you said you already replaced the balls with new ones? I don't understand how the new ones could become magnetized already (unless you pulled them from another game with magnets?). still thinking its the trough, have you pulled it out and cleaned it and smoothed down the 'ball guide'/bottom of it? if they are getting 'hung up' its the trough.

#52 4 years ago

I agree. It does seem pretty quick for the balls to become magnetized. I've ordered one of these sleeves and I'll try it out and see. The old balls are pitted - from what I understand, one way to demagnetize something is to hit it with a hammer. The old balls certainly look beat up. So potentially the previous owner had a similar issue and took a hammer to them

I haven't dismissed the trough, but I'm going to wait and see.

#53 4 years ago
Quoted from miker_70:

Success!!! I've been playing (and fiddling) for like 3 hours and the DMD issue is gonzo! The ribbon replacement did the trick.
The ball thing. Yeah, insert eh? I'll try that. I studied that stupid trough for the better of an hour...just letting the machine empty the trough / refill. They typically get stuck when there is 3 or less...weight i guess...and they get stuck about 1/3rd of the way from the end. I've seen the magnetize theory tossed around - I'll definitely try an insert, but the thing is when I first tried this they were completely new balls. I can't imagine they would get magnetized that fast. Even now, I've really only used them for a dozen games or so. Also, why wouldn't the other balls get magnetized? Weird.
Did you make this insert or buy it?
Thanks everyone..I seriously doubt I would even own a pin if I didn't have access to this community. You guys are great!
Mike

I was going to say, I don't think your dealing with magnetized balls, It sound like trough divots. The plastic trough insert is meant for that mostly. Marco has it and Pinbits has it also. Its about $7 US, $87 Canadian... Kidding.
You can test the switch with a multimeter. I think you put one lead to the middle lug and the other to the back lug and set it to ohms and then press the switch. SHould get a reading.

Ball_trough.jpg

#54 4 years ago

Also, if the old balls are really beat up, I wouldn't use them at all. All pinballs ruin the playfield. They become like sandpaper. No good.

#55 4 years ago
Quoted from RampShot11:

Also, if the old balls are really beat up, I wouldn't use them at all. All pinballs ruin the playfield. They become like sandpaper. No good.

Totally, but I want to play! ..haha...but I ordered a sleeve, and will be installing it as soon as it arrives.

..yeah, with US/CDN conversion, tax tax with a bit of tax, and shipping, $87 is a good estimate

#56 4 years ago
Quoted from miker_70:

Totally, but I want to play! ..haha...but I ordered a sleeve, and will be installing it as soon as it arrives.
..yeah, with US/CDN conversion, tax tax with a bit of tax, and shipping, $87 is a good estimate

Question , do you have the machine nice and level, also is the trough angled enough? It should be on an decline towards the right lane shooter. Is it secured to the under side of the playfield good?

#57 4 years ago
Quoted from RampShot11:

Question , do you have the machine nice and level, also is the trough angled enough? It should be on an decline towards the right lane shooter. Is it secured to the under side of the playfield good?

Yes, the trough seems secured fine. The game is level, but I'll check again later just in case

#58 4 years ago
Quoted from miker_70:

Yes, the trough seems secured fine. The game is level, but I'll check again later just in case

Here's another sort of dumb question but.... are the "new balls" 1 1/16 in size? If they are smaller or larger that might be the issue too. That's my last annoying question. I promise.

#59 4 years ago

Haha..yeah, they are standard size. Do they make a different size? Like, is there a game out there that requires some weird ball size?

#60 4 years ago
Quoted from miker_70:

Haha..yeah, they are standard size. Do they make a different size? Like, is there a game out there that requires some weird ball size?

Yes, there are a bunch of different sizes believe it or not. I wouldn't be surprised if the new balls are slightly to small or larger than 1 1/16.
Do you have a micrometer to measure them?

#61 4 years ago

Huh. I didn't realize there were different balls for different games. Why would a pin require something other than the standard 1 1/6? Seems like that would be death for an operator.

At any rate, the balls are standard - brand new - just checked the package 1 1/16"

#62 4 years ago

I think most pins use the same size ball but you have pitch and bats that use a different size and strikes and spares uses a different size too if I remember correctly.
But if you checked them then they are good. Are they the mirror finish balls or standard finish?

#63 4 years ago

They're just a standard finish - Silverjets.

Although, I'm thinking now I should get some of these high gloss beauties! http://www.pinballlife.com/index.php?p=product&id=1325&parent=49

#64 4 years ago

The trough sleeve will be arriving next week, so hopefully that will cure that issue. I've also ordered both the transmitter and receiver for that opto switch on the right ramp so that issue will be resolved.

aaaaand I have one more!

The gun...the gun works great..75% of the time. Often though, on load the ball just limps out of the gun. It doesn't seem to grab it from time to time. Is that wear or a sensor not working? Anyone have any ideas?

#65 4 years ago
Quoted from miker_70:

The gun...the gun works great..75% of the time. Often though, on load the ball just limps out of the gun. It doesn't seem to grab it from time to time. Is that wear or a sensor not working? Anyone have any ideas?

The coil in the gun might be loose. Check the coil bracket and make sure its ok. Same thing happened to my JD ball shooter bracket. It ended up getting really loose. I tightened it back down and never had that problem again.

#66 4 years ago
Quoted from miker_70:

Often though, on load the ball just limps out of the gun. It doesn't seem to grab it from time to time

yah, this is always an issue it seems, especially when the ball loads all the way down the ball wire guide. you can adjust the ball guide return left to right down where the mounting post is secured on the PF below the ball scoop that feeds the gun. this determines whether the ball is dropped 'left', 'centered', or more 'right' into the gun chamber. this, as well as rampshot coil suggestions should help out.

#67 4 years ago

Hey...

Thanks for the info on the gun I'll give it a try.

I got my new opto transmitter tonight. I checked again on the one that was in there and didn't see any light with my cell phone. I checked the other opto to see what I'm looking for and it was indeed glowing purple.

I replaced it with the new one and tested. Nothing. I checked with the phone, still no glow. I check the continuity on the trace on the board and it seems fine. I'm not sure what else to try.

I'm going to try to solder again but this time cut the wires back a bit as the ends seem pretty cruddy but if anyone has any other suggestions...I'm listening

(I rechecked all the connections with my photos from the originals just in case I crossed the wires or something stupid...the're fine)

Thanks

#68 4 years ago

Got it. I soldered and just held the wires on...as I suspected one of the wires is cut

#69 4 years ago

*unsoldered

#70 4 years ago

Guh.

So, I got it all back together again. I kept checking my phone - as the second time around, the wire came loose but didn't realize it until it was screwed back to the ramp. At any rate, got it back on and checked the phone to make sure it was still glowing (btw, apparently iphones don't register the LED with the front facing camera..the "selfie" side works fine but the other side doesn't..

So anyway, it doesn't work. When I cross through the beam it doesn't register. What the hell?? The other thing is I'm not getting an error anymore...but that might mean it's stuck "on" now as I was switching it on and off a few times..

- The transmitter is new and tested - it's working
- The receiver is not new, but does register when I pass a light in front of it
- In switch test, it doesn't register
- I used to get an error "switch error right ramp make", now I don't

On a related note, in gameplay does anyone know when that registers? I mean, I don't think it's every time you hit the helicopter ramp

The other thing is the balls. I got the trough sleeve tonight and installed it...I replaced the balls back to the new ones, and although it was wwwaay better it's still acting funny. It threw out 2 balls a couple of times, and one time a ball was stuck in the troughs similar to previous issue

1 month later
#71 4 years ago

How did you make out? Everything working ok now?

2 weeks later
#72 4 years ago

Hey! the follow up...

I had a local tech come by and help me out. We both were scratching our heads after about 40 minutes of him trying to figure out the problem with the helicopter ramp opto. Until finally, after a lot of testing and diagnosing, he said "maybe..." and proceeded to desolder the receiver opto again and re-solder it back on, but reversed the wires. It worked. The pads on the opto board itself were backwards. He said it happens from time to time..I'm glad I got him to have a look - I don't think I would have ever thought of that.

The gun: I tried taking the rubber from an old coil stop and sticking it in the fencing above the gun. It works 100% now (and has for a couple of months)

The trough: As mentioned above, this is still a bit wonky. It often only spits out 2 balls on multi, or gets "stuck" and nothing happens. If I shake the machine, it works. I'm going to try some other tests on this once I finish putting my Monopoly back together (pf swap).

#73 4 years ago

I had the same problem with my trough on DH.
I removed the trough and lightly grinded out the groves (caused by the balls) with a dremmel and 4 years later still no problems...

#74 4 years ago

Glad to hear you got mostly everything fixed. I would have never thought of the swapped wires either on the opto. Good lesson learned for that issue.
Btw, my buddy has a monopoly and I love it! Such a fun game. I couldn't get enough of it last time I was at his house. I really like the four player team feature 2 on 2 made for some very competitive pinball. Gl with the pf swap.

#75 4 years ago
Quoted from RampShot11:

Glad to hear you got mostly everything fixed. I would have never thought of the swapped wires either on the opto. Good lesson learned for that issue.
Btw, my buddy has a Monopoly and I love it! Such a fun game. I couldn't get enough of it last time I was at his house. I really like the four player team feature 2 on 2 made for some very competitive pinball. Gl with the pf swap.

Yeah, Monopoly gets a bad rep...I think it's a great game. Tons of stuff to do, and some pretty sweet shots (orbit). The pf swap is coming along, just finished the tear down / clean up..starting to rebuild..

Quoted from Sammy31:I had the same problem with my trough on DH.

I removed the trough and lightly grinded out the groves (caused by the balls) with a dremmel and 4 years later still no problems...

Grind the trough...interesting. Although, I have a trough sleeve - so I don't think this is the issue. I think there is a problem with the opto board

Promoted items from the Pinside Marketplace
From: $ 129.10
Cabinet - Sound/Speakers
PinWoofer
$ 11.00
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 40.00
Lighting - Other
Rock Custom Pinball
$ 49.95
Lighting - Led
Pin Stadium Pinball LEDs
There are 75 posts in this topic. You are on page 2 of 2.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside