(Topic ID: 242305)

Did Williams System 9 use commas in displays?


By uncivil_engineer

11 months ago



Topic Stats

  • 4 posts
  • 3 Pinsiders participating
  • Latest reply 11 months ago by uncivil_engineer
  • Topic is favorited by 2 Pinsiders

You

Linked Games

#1 11 months ago

Ok, on the surface this may appear to be a dumb question....

Did System 9 machines use commas in their displays?
I am working on a Sorcerer board, and I am trying to chase down what I think is a bad PIA problem (the game appears to boot, but immediately locks up). I am using Leon's test chip to check the PIAs. While going through U5, I noticed the output for PA2 was not strobing, and appear to be floating. According to the schematics, there is supposed to be a connection for PA2 to plug 1j3-11. However, I cannot for the life of me find this trace. When I to do a continuity check back to 1J3-11 from PA2 at U5, I get no connection. Looking at the board, I can't see that any thing that looks like at trace from U5 over to 1J3-11... Did williams not put the traces on the board to have the commas working in System 9?

For the record, I think U15 may be bad, but I am not sure yet. The outputs that are supposed to drive the opto section are barely moving. The problem is this part of the board was never used (it connects to 1J9).

#2 11 months ago
Quoted from uncivil_engineer:

Ok, on the surface this may appear to be a dumb question....
Did System 9 machines use commas in their displays?
I am working on a Sorcerer board, and I am trying to chase down what I think is a bad PIA problem (the game appears to boot, but immediately locks up). I am using Leon's test chip to check the PIAs. While going through U5, I noticed the output for PA2 was not strobing, and appear to be floating. According to the schematics, there is supposed to be a connection for PA2 to plug 1j3-11. However, I cannot for the life of me find this trace. When I to do a continuity check back to 1J3-11 from PA2 at U5, I get no connection. Looking at the board, I can't see that any thing that looks like at trace from U5 over to 1J3-11... Did williams not put the traces on the board to have the commas working in System 9?
For the record, I think U15 may be bad, but I am not sure yet. The outputs that are supposed to drive the opto section are barely moving. The problem is this part of the board was never used (it connects to 1J9).

Space Shuttle has commas.
Comet has commas.
Sorcerer has commas.

#3 11 months ago

Can verify Space Shuttle has commas.
-Mike

#4 11 months ago

Thanks Guys... well it looks like at least one output on U5 is bad.

Promoted items from the Pinside Marketplace
$ 689.00
Flipper Parts
Mircoplayfields
From: $ 18.00
Apparel - Men
Pinside Shop
$ 21.00
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
1,999
Machine - For Sale
Steele, ND
$ 79.99
Cabinet - Shooter Rods
Lighted Pinball Mods
2,650 (Firm)
Machine - For Sale
Colts Neck , NJ
$ 17.00
$ 15.00
Playfield - Decals
Metal-Mods
$ 99.99
Lighting - Other
Lighted Pinball Mods
$ 7,499.00
Pinball Machine
Nitro Pinball USA
$ 159.99
Lighting - Other
Lighted Pinball Mods

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside