(Topic ID: 248231)

Diamond Lady Sound Issues


By jjoravec

11 months ago



Topic Stats

  • 2 posts
  • 2 Pinsiders participating
  • Latest reply 18 days ago by pb456
  • No one calls this topic a favorite

You

Linked Games

#1 11 months ago

I have a Diamond Lady that i put all new boards in including sound board, but I am getting no sound only a hum from the speakers. I even replaced the speakers with new ones.

Any idea what could be wrong or where to start tracking down the problem

10 months later
#2 18 days ago

Ground mod done? In addition to the tie-in ground mod, I've also had to put in direct ground wires from all boards in the backbox to ground.

https://www.flippers.com/gottlieb_ground_cures.html

Promoted items from the Pinside Marketplace
$ 10.00
Cabinet Parts
Ramp-O-Matic
From: $ 18.00
Apparel - Men
Pinside Shop
$ 299.00
Displays
Boston Pinball Company
€ 8.40
From: $ 18.00
Playfield - Plastics
Ramp-O-Matic
$ 65.00
Playfield - Plastics
Ramp-O-Matic
$ 6.00
Electronics
Yorktown Arcade Supply
From: $ 19.99
Eproms
Matt's Basement Arcade
From: $ 99.99
Cabinet - Other
Lighted Pinball Mods
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
$ 95.00
Playfield - Toys/Add-ons
M&M Mods
$ 23.00
$ 9.99
Eproms
Matt's Basement Arcade
$ 35.00
Cabinet - Decals
Pinball Haus
$ 7.95

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside