(Topic ID: 263051)

Desperate plea: don't let Grand Prix defeat me!


By spclwhenlit

5 months ago



Topic Stats

  • 7 posts
  • 4 Pinsiders participating
  • Latest reply 5 months ago by spclwhenlit
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

There have been 2 images uploaded to this topic. (View topic image gallery).

gpsu (resized).jpg
pasted_image (resized).png

#1 5 months ago

I like a good challenge, but my Grand Prix has just about got me whipped. I’ve been working on it off and on for six months, and it’s about 90 percent functional. That’s the good news, because when I started it was totally dead.

The bad news is it still exhibits crazy, intermittent issues. Sometimes it won’t fire the ball release coil at the beginning of a game or between balls. The top eject hole sometimes steps up the right bonus ladder more than the expected two steps. The right eject hole doesn’t always kick out the ball. The most aggravating issue is the unreliable way it steps up the ball in play. Sometimes it steps up correctly, sometimes 2 balls, sometimes not at all.

I have read all the Grand Prix and stepper related posts I could find on pinside and the old RGP newsgroup. I’ve pulled the playfield and bottom panel multiple times. I’ve examined every relay and score motor switch, only cleaning and adjusting when obviously necessary. I have disassembled and rebuilt both bonus steppers, the coin unit, and the ball count unit. I’ve poured over the schematic and feel like I have checked and tried to adjust anything that might relate to any of the odd behaviors.

Because the issues are inconsistent, I figured there was something intermittent going on, like a shorted switch or wire, or a mis-adjusted switch. But I’m at the point where I’m about ready to throw in the towel and start on another project. I hate to admit defeat – even temporarily - but I am at a loss as to what to try next. I also know Grand Prix is a complicated EM and prone to issues, but my experience with EMs tells me once they’re adjusted and set up right, they’re pretty reliable.

So I guess this is my final plea – is there anybody out there with a creative suggestion that doesn’t involve a sledgehammer? Thanks in advance for your help!

#2 5 months ago

Check if your ball count unit stepper spring is wound too tight or too loosely. An over wound spring can make it jump two positions. Also make sure the little catch mechanism on the steppers is working clean and smoothly, that is the other thing that can make those jump forward. Make sure the contacts on the wiper fingers are aligned and stepper board are clean and making good contact. I would think the Ball count/player counter units are going to be the problem based on the issues your having. I also know on ours if your not careful the playfield can whack the top of the stepper when your take it in and out.

#3 5 months ago

Use your finger to step through the ball count step up unit. Do it multiple times and see if it ever skips more than one position or if it sometimes doesn't step up at all. Do it many times. It should step once for every push. If it works manually, it's not a physical problem with the ball step up. Then you have to look at what makes the ball step up fire (or misfire).

See schematic for switches involved in firing the Ball Count Step Up. Notice that it also goes through the player unit. It uses the player unit to determine when the ball unit needs to step up (after the last player). If the fingers on the Player Unit aren't lining up in the center of the rivets, all the way around, it could affect the ball count.

Don't give up. Tackle one problem at a time. Little victories.

#4 5 months ago

A good way to diagnose intermittent issues is with a Bulb tester. Do you see how to use it to diagnose how far power is getting on its way to the Ball Release coil?

https://pinside.com/pinball/forum/topic/reading-gottlieb-schematics#post-2634425
https://pinside.com/pinball/forum/topic/em-pinball-circuits-basics-to-not-so-basic/page/2#post-3184715

pasted_image (resized).png
#5 5 months ago

Funky-I tried decreasing the spring tension on the ball count unit by unwinding one turn; it had no effect. The finger contacts and rivets on both bonus steppers look to be making good contact; I had cleaned both and lightly lubed the rivets with Super Lube. Here’s the one thing that I have noticed with the bonus steppers that is odd: usually the 5k lamp on the right bonus ladder is lit at the start of each ball, the left is not. Which is correct? I have also noticed that on the left bonus stepper, I can manually cause the gear to step up another half turn after it has been counted down to zero; in other words, the switches on the left bonus unit have already been activated and I can still manually get the gear to move slightly by depressing the reset plunger. On the right bonus stepper, it seems to be prevented from moving by the thick metal pin on the gear that butts up against the stepper bracket when it has been reset. I didn’t consider this an issue – in my mind the stepper should stop decrementing when that switch stack is “activated”.

eded-like you are thinking, I had previously checked that the ball count unit stepped up properly when I manually activated the coil plunger, and it was. In fact, I couldn’t get it to step up more than one ball at a time manually. And I’ve been careful to only play a single player game, and verified that the player stepper is not moving during game play.

Howard-I haven’t used a bulb tester, but have examined motor switch 4A and the m/b switch on the outhole relay (multiple times). I’ve actually checked all the score motor switches, and all the relay switches on the bottom panel multiple times, with the panel removed.

#6 5 months ago

Concentrating on your ball count problem, here is a section of schematic leading to your ball count step up. Missed steps could be any of these switches open. Double hits probably originate from the score motor or step units. This is the path that energizes your coil. The problem has to be with one of these circled switches or the Player Unit or Coin Unit.

It might be two problems. Jumper switches to try to eliminate the 'No step" then you'll just be down to finding what makes it double step.

gpsu (resized).jpg
#7 5 months ago

So maybe this is another clue… I mentioned earlier that it seems strange that on game start up, when the ball release coil doesn’t fire, the 5k lamp on the right bonus ladder is lit and no lamps on the left ladder are lit. If I manually step down the rt bonus ladder so that no lamps are lit, then manually activate the outhole switch, the ball release coil fires and the ball count steps up one. For balls 2 thru 5, points must be scored before that works (which I would expect to prevent zero score balls). I’m now assuming that at the beginning of each ball both bonus ladders should be at zero, NOT 5k?? If that’s true, then I guess the problem originates with whatever is stepping up the right 5k bonus. I had already checked for closed playfield switches, so something else must be stepping that right bonus up?

Promoted items from the Pinside Marketplace
From: $ 18.00
Apparel - Men
Pinside Shop
900
Machine - For Sale
Sparta, MI
$ 40.00
Gameroom - Decorations
Arcade Arts
From: $ 20.00
Apparel - Unisex
Pinball Wheezer
$ 79.95
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 4.49
Electronics
Yorktown Arcade Supply
$ 9.00
From: € 15.00
Lighting - Interactive
TheDudeMods
From: $ 19.99
$ 71.99
Lighting - Interactive
Lee's Parts
$ 48.00
Cabinet - Other
ModFather Pinball Mods
$ 52.00
$ 7.00
$ 9.99
Cabinet - Other
Bent Mods
$ 39.95
Playfield - Protection
Little Shop Of Games
$ 265.00
From: € 80.00
Playfield - Toys/Add-ons
Creo Pinball
$ 99.95
Playfield - Toys/Add-ons
Hookedonpinball.com
$ 65.00
Playfield - Toys/Add-ons
G-Money Mods
$ 4.49
Electronics
Yorktown Arcade Supply
$ 79.95
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 42.00
Playfield - Toys/Add-ons
The MOD Couple

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside