(Topic ID: 189554)

Demolition Man Player-ation


By zacaj

2 years ago



Topic Stats

  • 37 posts
  • 14 Pinsiders participating
  • Latest reply 1 year ago by zacaj
  • Topic is favorited by 9 Pinsiders

You

Linked Games

Topic Gallery

There have been 65 images uploaded to this topic. (View topic image gallery).

FB_IMG_1511673206245 (resized).jpg
FB_IMG_1511673195398 (resized).jpg
IMG_20171125_235619 (resized).jpg
IMG_20171125_235606 (resized).jpg
IMG_20171125_235624 (resized).jpg
IMG_20171125_235614 (resized).jpg
IMG_20171123_210319 (resized).jpg
IMG_20171021_221623 (resized).jpg
IMG_20171021_221627 (resized).jpg
IMG_20171021_221631 (resized).jpg
15086049862661831697175 (resized).jpg
IMG_20170816_155413 (resized).jpg
15028447859631573973645 (resized).jpg
IMG_20170815_204910 (resized).jpg
IMG_20170815_204924 (resized).jpg
IMG_20170815_204918 (resized).jpg

#1 2 years ago

Can't call it a restoration, not worth that much money, so I'm going to make it into a players demo man...

When bought, seller said it was missing the fliptronics board, translite, speaker panel, playfield glass, and transformer.

Found a used fliptronics board, and a transformer for an IJ which should be compatible with a bit of wiring (supposedly the line-in connector is reversed?)

Did a quick test of the boards it came with in my Black Rose. Mpu boots, dmd board works, driver board at least produced correct voltage (didn't bother fully connecting it since they're a pain).

#2 2 years ago

Glad it got a good home.

LTG : )

#3 2 years ago

Finally unfolded the game today to start some work. Put the boards in, and surveyed the playfield.

IMG_20170521_134627.jpg
Found most of the ribbon cables in the bottom along with the normal pile of junk. Had already ordered new ones, so at least I'll have some spares now.
IMG_20170521_133524.jpg

Also found a foreign coin. Single slot coin door also suggests this was a re-import.

IMG_20170521_133650.jpg
Realized the game is also missing the 8-driver board, but luckily it's just flashers, nothing important.

Playfield looks clean at first,
IMG_20170521_133539.jpg

But it looks like the ramps have never been removed for cleaning...
IMG_20170521_133553.jpgIMG_20170521_133556.jpg

Ramps look to be in good condition, hopefully they will clean well
IMG_20170521_133548.jpg

Plastics will probably need to be replaced
IMG_20170521_133543.jpg

On the underside, flippers will of course need a rebuild and maybe new coils.
IMG_20170521_122803.jpg

Subway seems be broken. Don't really want to take off the tape and find out exactly how...
IMG_20170521_123108.jpg

Everything else seems to be okay at first glance, but something is missing in the lower left corner
IMG_20170521_123306.jpg

A few connectors with no where to go, and two sets of empty screw holes. Not sure what they should go to.

Made my first repair. Noted the right rail had separated from. The playfield at the front, so removed the screws, clamped it, and reinstalled. Wood seems to still be good, rails are firm on the playfield, no need to fill in the holes and redrillIMG_20170521_140029.jpg

Shooter coil is loose, but it seems the screws have just come loose. Will tighten and maybe add lock nuts on the back to hold

#4 2 years ago

Installed the transformer using some handy bolts that were wedged under the wood. Three output connectors match up color-wise, hopefully they're fine. Also found two more large connectors that seem to just go in line with one of the transformer to enable the coin door switch?

Input connector of course doesn't match
IMG_20170521_123903.jpg

Originally I thought I could just make a little adapter cable to go in the middle, but that doesn't seem to be the case. The power box doesn't match the wpc schematics I have for dcs games, instead it looks more like one from a wpc 95. Not sure if demo man switched, someone installed the wrong one, or it's an export thing.

Instead of the 120v wires coming out of the box to the jumper connector, this box has a second twelve pin connector:
IMG_20170521_133059.jpg

I took off the box and examined the wiring on the inside, and it does match the wiring from the wpc 95 Schematic. It seems like they had the transformer plug directly into the 9 pin connector, and then put the jumpers (and wiring to the dbv) in the 12 pin? Either way, it looks like I can just wire the transformer input directly into the 12 pin connector and it'll work... Will stop at the electronics store tomorrow to pick up the right housing.

IMG_20170521_133106.jpg

#5 2 years ago
Quoted from zacaj:

Everything else seems to be okay at first glance, but something is missing in the lower left corner

A few connectors with no where to go, and two sets of empty screw holes. Not sure what they should go to.

Pretty sure that's where the opto board goes

#6 2 years ago
Quoted from redundor:

Pretty sure that's where the opto board goes

That would make sense... Never had a game with optos before

#7 2 years ago

Removed all the ramps, per instructions in the manual. Not nearly as hard as people have warned me (and especially no 'taking them all off in one piece and then untangling them'). Only problem is that there is no possible way you're taking off the left ramp before the side ramp. Pretty sure they got the order of those two mixed up.

IMG_20170521_203849.jpg
IMG_20170521_203903.jpg

Playfield is pretty dirty,
IMG_20170521_204157.jpg

But test spot cleaned up okay:
IMG_20170521_212341.jpg

Ramps also look like they can be made presentable
IMG_20170521_212355.jpg
As always, the amount of dirt s machine can accumulate is amazing. The coat of black dust on the underside of the ramps is almost as thick as that on top

Someone seems to have stuffed some newspaper in when a rubber broke:
IMG_20170521_204209.jpg

#8 2 years ago

Looking good.

I just want to follow along.

#9 2 years ago
Quoted from zacaj:

Removed all the ramps, per instructions in the manual. Not nearly as hard as people have warned me (and especially no 'taking them all off in one piece and then untangling them'). Only problem is that there is no possible way you're taking off the left ramp before the side ramp. Pretty sure they got the order of those two mixed up.

Just put one of these back together. Taking the ramps off is easy...putting them back in (without having to take one out again to fit another in) is a much different story. The ramps on that game are crazy!

#10 2 years ago

Went to the electronics store today, but they didn't have the right type of connectors... Will have to add to next Digikey order.

In the meantime, decided to plug it in and make sure I was at least getting 120VAC out of the power box. Went to plug it in, and:
IMG_20170522_175655.jpg

Darn. Luckily I have a spare plug, so swapped it out, plugged it in, got voltage.

Nest step, I did a test wiring without the housings.

Since I already have to make an adapter to connect the transformer, I didn't see any reason to make a second for the voltage jumpers, so just wired the 120v straight from the 12 pin jumper connector to the transformer and put the other jumpers right in the original transformer plug. IMG_20170522_175659.jpg

Fired it up again, and heard the nice hum from the transformer. Tested voltages coming out, all seem good except I'm only getting 13v out of pins 3/6/9 on the main output connector. Remembered that that's the difference for DCS (18 vs 12), but a bit confused as all my wpc schematics (wpc, dcs, '95) all say 18... Maybe just a misprint?

Now to start tracking down how the wiring all goes together... The main questions:
1. I've got a 9 pin, yellow wired gi connector coming out of the transformer, and a compatible 9 pin connector with some other random colors that looks like it should go together. Didn't think anything of it till I dropped by a friend's house today and took some pictures of their DM.
IMG_20170522_132124 (resized).jpg
They have a second all yellow wire connecting to the transformer and the connector I have is just lying there! No other all-yellow connector anywhere to be found in mine...

2. I have one bad connector in the head, and a few stray burnt wires, but too many to fit in it?
IMG_20170521_134024 (resized).jpg
I assumed it was gi when I bought it, but will need to find the exact wiring in the manual when I replace it

#11 2 years ago

Oof, this is giving me flashbacks of the filthy DM I picked up. Lots of elbow grease later it cleaned up very nice. Good work!

#12 2 years ago

Identified and labeled all connectors, replaced burnt gi connector.
IMG_20170522_232641 (resized).jpg

Found out that one of the switch matrix connectors was apparently just ripped off the wires, all green wires hanging loose :/
IMG_20170522_232645 (resized).jpg

With connectors labeled, checked ac voltage at all locations it enters the board, everything seemed right (besides the 18/13v thing which is apparently a misprint according to a few sites I've found), so plugged the driver board in and flipped the game on. No explosion, all leds on. Checked test points, all seemed good except my 5V is 4.94 and my 12V is 11.84. Can't seem to find acceptable ranges for these online, but they're not high, so should be safe to plug in mpu tomorrow. I assume it'll still boot with 4.94, reset issues can wait till later.

#13 2 years ago

Hooked up the mpu, booted fine, so I hooked in the dmd board and a speaker panel from my T2. Got some weird garbage on the screen, took me a little while to realize that the logic voltage for the dmd driver comes from a different plug on the driver board. Plugged that one in, and got it displaying the "testing..." screen, but then got a new problem
IMG_20170523_150047 (resized).jpg

At first i assumed this was caused by another plug not being in, which was correct, but sadly not just a simple driver board plug. Once I confirmed this message was actually 'can't read switch matrix', I was reminded of the obvious problem that one of my switch matrix connectors is missing. Was a bit surprised I couldn't skip this error screen with the coin door buttons until I remembered that I hadn't installed the coin door interface board. Mounted it in the cab and then quickly realized that it wasn't the right board! Apparently there are two different interface boards, and the seller gave me the wrong type. Worse, they don't seem to be available online anywhere I can find. Will have to ask around and try to find one, but not having the board will still put a significant slowdown in the project. Might just wire the connectors together for now to test, as the interface board is pretty much nothing but some wires and diodes.

With that on hold, I returned to tearing down the playfield. Surprisingly few problems turned up, the main thing being that the trough is of course falling apart. The packing tape masked even more problems:
IMG_20170523_152354 (resized).jpg

Dropped it off at the local welder to get put back together.

With that out of the way, was able to strip the top side down flat, and start cleaning.
IMG_20170523_161021 (resized).jpg

#14 2 years ago

Even with the Switch wires connected again in the head, you may still get the fuse error until you get the opto board installed and working.
That's a lot of work in just a couple days, impressive.

#15 2 years ago

Best of luck with the restore. I love mine. It sure looks pretty when lit up. Looking forward to watching this thread and the progress you make on it.

IMG_3428 (resized).JPG

#16 2 years ago
Quoted from DNO:

you may still get the fuse error until you get the opto board installed and working.

I think I'll get a different error. Not sure if either of these errors are skippable/acknowledgable, but since the 'always closed' diode is on the interface board, I'm still stuck until I get that.

#17 2 years ago

Great job. DM deserves the love your giving it.

#18 2 years ago

Got most of the dirt out with novus #2, mostly by hand with a bit of buffing. #1 next, then some waxing...

IMG_20170523_161021.jpgIMG_20170524_120330.jpgIMG_20170524_114211.jpgIMG_20170524_120320.jpg

Cleaned up pretty well, still some random flecks and faint ball trails in high traffic areas that i couldn't get out. Some slight insert wear near the flippers. Couldn't get the mylar quite as nice as the rest for some reason

#19 2 years ago

I'll be following this thread. Just got a DM and haven't tore it down yet. If you forget where something goes or need specific pics down the road feel free to ask.

#20 2 years ago

Very nice job! I bought my DM in very similar condition several years ago. The great thing is that they usually clean up nicely. Yeah, a few of the metal mechs that I had also had to be tack welded back together, but nothing was beyond salvation. The ramps should also clean up nicely and you'll have a great example on your hands!

#21 2 years ago

Its look like this pin was in Serbia in some part of his life.
So be prepare to find lot of "modification" inside. I deal with that most time.
Because of sanctions from 1990-2000 it was imposible to find parts.
And all box are in bad shape but pf are almost perfeckt.

Very nice job and, and it will be grait pin when its finish.

d444862c2e1b6855dc65d4928abaea1320881258 (resized).jpg

#22 2 years ago

Waxed the playfield with a buffer, was not too impressed with it so I waxed it again by hand. Not to familiar with using power tools for that sort of stuff. (or having games new enough to use them on!)

Got the subway back from the welder, still need to figure out a way to fix the hole where the plastic subway connects to the metal. IMG_20170526_213301 (resized).jpg

Started cleaning ramps and polishing metal. Tried a buffing wheel on a drill but it didn't turn out any better than hand polishing... IMG_20170526_134623 (resized).jpgIMG_20170526_213155 (resized).jpgIMG_20170526_152704 (resized).jpg

Cleaned the underside of all the inserts with novus #1
IMG_20170526_140955 (resized).jpg

Rebuilt the flippers. Found this fun coil stop
IMG_20170526_205446 (resized).jpg
For some reason on of the cranks doesn't have any lever to move the eos switch. Forgot to order return springs. Also found out one of the flipper coils (only labeled in some foreign language) is not the correct coil, so will have to order another blue flipper coil as well.

Began reassembling some of the playfield, but can't go too far as my order of lights for the gi got delayed and won't be in till next week. While reassembling ran into my first major problem:IMG_20170526_213217 (resized).jpg
Originally when I looked at the elevator mech it looked fine, but on closer inspection, the motor is gone, although the gearbox is still there. I thought the motor was inside the box until I couldn't find any wires coming out, then checked some pictures. Will be tough to find, especially without the gearbox. Marco has them for $112, but I'm not paying that. The motor should be $15 or less judging from similar ones I've bought in the past. Might have to just find a similar motor and try to match the teething of the gear and make a mounting bracket.

#23 2 years ago

Finished cleaning all the metals and ramps, started reassembling what I can before my lamp shipment comes in.
IMG_20170527_215727 (resized).jpg

Noticed the middle ramp's wireform was missing, so made a new one. Hopefully it doesn't get bent up too much.
IMG_20170527_215658 (resized).jpg

#24 2 years ago

I've had more than one person ask what I used on the sides of mine. Here is a cheap way to make the sides pop. I did this on my T2 also and both games look amazing:

ebay.com link » Diamond Plate Vinyl Wrap Graphics Decal Sticker Sheet Film Roll Cut Cut 24

2 weeks later
#25 2 years ago

Slow progress, blocked by various things.

Brought most of the plastic sets to a friend's to get them riveted, but they didn't realize there was a protective costing on them, so they'll need to be down again

Received a translite from a helpful pinsider, but still no luck on the speaker panel.

Finally got my mini proto boards which I'll populate and that will hopefully get the thing booting.

14979114895032054998407 (resized).jpg

2 weeks later
#26 2 years ago

Populated the coin door board, and was able to get the machine to boot.


Sadly i got my mounting hole spacing wrong.
..

IMG_20170708_143050 (resized).jpg

The testing... Screen seems to last a very long time, not sure why. Hopefully it'll go away once I update my ROM.

With it booting, i was able to go into the tests. All installed switches and coils worked, but I only got about ten lights in the lamp test. I'd already reflowed the lamp board connectors, so I got a bit worried about a driver board issue, but then occams razor was suggested. Turns out, the other 50+ bulbs were just all burnt out. Now i need to order more bulbs...

Went to start rebuilding the playfield, when I discovered my new plastic set is defective D:

IMG_20170706_121101.jpgIMG_20170706_121055 (resized).jpg

Sent an email to the seller, so we'll see how that goes.

At pintastic this weekend I was rifling through the junk parts boxes in the (sadly deserted) outdoor flea market for fun. Grabbed some Gottlieb flipper plates and random circuit boards, and then spied a random little motor in one of the boxes. No markings on it, no way to know what it was from, but for $5, any motor is worth a shot. Maybe i could make an adapter plate and get a new gear for it? This morning, dug out my elevator mech (with the missing motor on the gearbox) and found that the existing mounting holes were a perfect match! Screwed it in, and the elevator lives again.


(it doesn't actually sound nearly that bad in person...)
Disassembled it and gave it a good cleaning as it kept getting stuck. Motor is a bit loud, and I have no idea if the teeth are meshing properly or not, but it seems to work good enough. Will make a new connector for it and install it and the claw tonight. Hopefully the claw works. Still haven't found a cover for it.

On recommendation from a friend, I played with the shooter to make sure it could make it as around to the upper flipper *before* installing the ramps. Using the empty balls test, I discovered that a) my trough optos work, which is nice, b) I need to order more pinballs as DM needs 5!, and c) the shooter lane switch was stuck. Not a problem with the slot or wireform, the microswitch itself doesn't like to return to its rest position without some convincing. Taking out the sticky switch also made my shooter nice and reliable going around the upper arch, so hopefully when I install a new switch it'll have little enough force to stay working.

1 month later
#27 2 years ago

Finally got a chance to work on this more. Installed the flippers, pop bumpers, and most of the power level of posts, plastics. Sadly, found out that some of the replacement plastics I got sent were still bad, so will need to contact them and get them replaced again A few I also apparently riveted on backwards, so will need to re-rivet them. Once that's sorted out, I should be set to install the ramps, etc.

IMG_20170815_204918 (resized).jpg

IMG_20170815_204924 (resized).jpg

IMG_20170815_204910 (resized).jpg

15028447859631573973645 (resized).jpg

#28 2 years ago

Another new set of plastics on the way, so I took a look at some of the cabinet buttons. Replaced the flipper and shooter buttons, and investigated the handles. Both top buttons were stuck in. Disassembled them, and there was some corrosion on the insides, so I drilled it out again, now all buttons are free.

Need to investigate flipper optos, not registering for some reason.

IMG_20170816_155413 (resized).jpg

2 months later
#29 1 year ago

Still haven't figured out the flipper issues, but in the meantime I started reassembling the playfield as the new plastics arrived and were okay.

While this was going on i also got my custom opto board working, and then went through and got all the optos working. 15086049862661831697175 (resized).jpg

Testing the optos revealed that one of the claw optos was bad, which was lucky since I hadn't installed the plastics on that part of the playfield yet and coils still access them.

After fixing that, however, I discovered that the claw wasn't working. No matter what I did it was out of range, even though the optos tested fine. I checked the motor board on the bench, and everything checked out. Eventually I resorted to grounding the transistor tabs to move it back into range in the hope of finding something, and I realized that the claw was going backwards! After some wire tracing I found that the connector between the motor board and the motor was pinned backwards. Can't understand how that's possible, but I reversed it and then the claw worked fine.

#30 1 year ago

Subscribed

#31 1 year ago

Did some more assembly today. Installed all the new plastics and was hoping to get the ramps on, but when I went to install the pop bumper caps I realized the screw holes were cracked, so now I have to order new caps before assembly can go any further.

Once I get those, everything on the playfield should be good to go, so my to do list boils down to:
- Fix the flipper buttons (only the right trigger works)
- get glass for the playfield and translite
- build a speaker panel
The panel will be the tough one. I don't have any other games to compare to, so I'll have to build it from scratch. I got a scan of the plastic from a friend's game, so will need to clean that up (somehow) and then get it printed, and cut wood to fit it. Luckily all the hardware is available

IMG_20171021_221631 (resized).jpg

IMG_20171021_221627 (resized).jpg

IMG_20171021_221623 (resized).jpg

1 month later
#32 1 year ago

Haven't had time (or the knowledge) to clean up my scan of the speaker panel to get a decal printed, but using measurements from it I decided to cut a wood panel, since I was tired of having the dmd just propped there. Sadly I somehow put on the speakers off center, so that's a bust. Works well enough till I get the plastic though.

With that at least built I was able to wire up the speakers and plug the sound board in, which luckily seems to work just fine.

With the new bumper caps installed, I gave the playfield a final cleaning and then wrestled the ramps back into place. Of course, this again is not the order specified in the manual, and also wasn't the order I recorded taking them off in in the first place
FB_IMG_1511673206245 (resized).jpg
After the second try I got them all installed, and then rebuilt the pop bumpers (the last mechs to do, as one of the brackets had snapped apart so I needed another one of those too). Lastly I had to install the plastic subway. It was broken at one end and the previous owner's packaging tape patch hadn't held up, so I made something a bit better out of plexiglass:IMG_20171123_210319 (resized).jpg

Although I still hadn't managed to get the flipper optos working I discovered that, as long as you have both boards installed, the triggers would work, and since that's the best way to play demo man anyway, it wasn't a big deal

With that done, all the parts had been seen to and finally I was ready to actually try a game! Except it kept complaining the coin door was open even when it was closed and the interlock was taped shut. I'd never had a Williams game with an interlock before so I was a bit stumped, but eventually I tracked down two bare wire ends with colors on the switch matrix coming out of the harness near the door and looked them up in the switch matrix. The coin door closed switch was missing! No bracket or anything, so I'll have to track one of those down, but for now I just clipped them together to get it to start a game.

Everything worked great for two balls, and then the center ramp stopped working. A bit of investigation revealed that the diode had snapped off the solder at one end D:

FB_IMG_1511673195398 (resized).jpg

Was I going to have to take all the ramps off already? Screw that! So I stuck my soldering iron in that tiny gap and fed solder in through the front threaded between the super pops habitrail and soldered it back on.

IMG_20171125_235614 (resized).jpg

IMG_20171125_235624 (resized).jpg

IMG_20171125_235606 (resized).jpg

IMG_20171125_235619 (resized).jpg

#34 1 year ago

A few games later of course, I started having claw problems.

First, the game wouldn't register the ball being in the elevator even though the opto worked in switch test. I think I've traced this down to a flaky connector somehow causing it, as the problem doesn't occur for about ten games after I reseat it, so hopefully a new connector will fix it.

Then, the game would sometimes pick up the ball and then just stop. Eventually the magnet would turn off and the ball would fall, and a few ball searches later it would pick it up and bring it over like normal. If I rebooted the game in this state, it wouldn't let me start a new game till I fiddled around in test mode for a while.
Eventually, I figured out that this only occurred when the claw was at the far right. If I moved it to the left at all it would resolve the problem. I figured maybe the left claw opto was occasionally being flaky, which would then make it think the claw was out of range if it happened while the claw was at the far right (can't be on both sides), and then maybe the code would just break down? So I took out the claw opto board, and noticed that the right opto was new (I had replaced it earlier) but the left one was old (I'd skipped it as it worked fine in test). So I replaced it.
Then weird stuff started happening. I confirmed that the new opto worked with a piece of paper, and reinstalled it only to find that now the claw test would never move the claw either direction more than a millimeter. Every time you tried to move it the left opto would pulse and it would go out of range. Then I realized the elevator motor would also pulse the left claw opto. In fact every coil on the playfield would!

So I took out the board again, double checked all the traces, reflowed the solder... And it got worse! Now sometimes you could just sit there and the opto would start flaking out. I went nuclear and replaced the opto again (with my last new spare) and also replaced the diode and resistor for good measure. No dice. Finally I swapped the left and right optos, and the problem moved to the right side. So both my new optos were bad?!

This reminded me of another weird problem I had getting it running, when I was trying to get the flipper opto boards working. None of them registered, but voltage was good and continuity checked out, so as a last resort I figured maybe all the optos were bad somehow, and replaced one as a test. Still didn't work, so I gave up and ignored it.

Then, when I was running the machine through its tests before my first game, the right flipper (the one whose opto I had replaced) started flipping during the all lamp test. I eventually figured out it was something with the opto board, so I just clipped it off and forgot about it.

But there definitely seems to be something wrong with my entire order of optos.... Grrrrr

#35 1 year ago

I'm not sure I can justify 100 bucks for a new speaker panel with the condition the cabinet is in I'd been hoping to save some money and learn some stuff about scanning backglasses and plastics, though who knows how well that will go...

Already tracked down a translite, just haven't made it to the glass shop to get a piece cut.

#36 1 year ago

You're doing an awesome job on this game. I'll be following along through the end of the project.

3 weeks later
#37 1 year ago

Got some new optos from a friend and replaced every single U opto in the game, which got the flipper buttons working, and now I've played about 20 games without any claw issues...

So unless those pop up gain, the game is now fully functional and playing great. All that's left is lots of aesthetic stuff.

Promoted items from the Pinside Marketplace
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
$ 20.00
Electronics
Yorktown Parts and Equip
$ 28.00
$ 18.95
$ 229.99
Lighting - Other
Lighted Pinball Mods

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside