(Topic ID: 31302)

Demolition Man Owners Club.... Members Only!

By Rascal_H

9 years ago


Topic Heartbeat

Topic Stats

  • 2,147 posts
  • 359 Pinsiders participating
  • Latest reply 2 days ago by WhiskeyTango
  • Topic is favorited by 121 Pinsiders

You

Linked Games

Topic Gallery

View topic image gallery

C0C9F173-A0F3-4BBD-B771-6B84D5BCE6C4 (resized).jpeg
AE002A67-D2A0-479A-BAEA-13719CCD31E1 (resized).jpeg
FF5E084B-A334-4419-9F07-2FDF1EF80793 (resized).jpeg
20211005_095616 (resized).jpg
Screenshot_20211004-215355_Gallery (resized).jpg
20211004_200954_1_1 (resized).png
06B34A25-ABCE-4FA6-BDA6-57D5C4444CC2 (resized).jpeg
F6F3C5F4-BEDF-43B8-8517-493DA5195EDE (resized).jpeg
B7488D6C-DE2C-4C88-98FF-C679FA419236 (resized).jpeg
6ACF39C4-B87A-4EED-B520-131DBBEE531C (resized).jpeg
E4FEDE17-4E36-4043-A8ED-45DD287B0F58 (resized).jpeg
7FE439B2-BE6B-41D3-ADA0-1E292417B7C1 (resized).jpeg
IMG_20210822_190402 (resized).jpg
IMG_20210822_185332 (resized).jpg
IMG_20210822_185321 (resized).jpg
DSC_0291 (resized).JPG

There are 2,147 posts in this topic. You are on page 43 of 43.
#2101 55 days ago
Quoted from Gorgar666:

Are the profanity Roms worth it?

Not in my opinion.

#2102 55 days ago
Quoted from Gorgar666:

Are the profanity Roms worth it?

Very Very Very much so

#2103 55 days ago

I prefer it without the profanity roms. They seem more like a joke. Funny for five minutes or to show your friends, but

#2104 55 days ago
Quoted from zacaj:

I prefer it without the profanity roms. They seem more like a joke. Funny for five minutes or to show your friends, but

Another owner that feels the same way ... its too novelty esp when the rest of the sound package is kinda meh to make it worth while.

#2105 55 days ago

Having actual Wesley Snipes tell you to go fuck yourself when you get a tilt warning is pretty funny...

But yeah, other than that, more of a novelty that loses it's pizazz after a few minutes.

#2106 55 days ago

Well., looks likes it quickly reversible.

So taking other peoples’ word for it, where I can’t vouch for the accuracy, basically the only difference between H5 and H6 is the profanity….

H5 is just the upgraded audio sample quality without profanity

H6 is the upgraded audio with profanity.

They use the same sound roms to perform the “audio upgrade”, but instead of it being a selectable thing in the options, H5 just never calls the profanity.

So if you decided down the road to remove the profanity, you could buy just the H5 CPU and not have to buy the huge set again next time.

Quoted from a fairly reliable source that wishes to be anonymous in case this is bullshit. LOL

#2107 54 days ago

Finally put a pin2dmd in mine,

I brought this machine back and did the restore as my first dmd. Hv section was out and i put in a 5v red stern display for a couple years and it developed a couple lines for a yr or so after that.. been wanting to go pin2dmd for a while and just got it installed tonight.
20211004_200954_1_1 (resized).pngScreenshot_20211004-215355_Gallery (resized).jpg

Dots are a bit more interesting to look at now lol

#2108 54 days ago
Quoted from trueno92:

Finally put a pin2dmd in mine,
I brought this machine back and did the restore as my first dmd. Hv section was out and i put in a 5v red stern display for a couple years and it developed a couple lines for a yr or so after that.. been wanting to go pin2dmd for a while and just got it installed tonight.
[quoted image][quoted image]
Dots are a bit more interesting to look at now lol

Look good.

#2109 54 days ago
Quoted from Gorgar666:

Well., looks likes it quickly reversible.
So taking other peoples’ word for it, where I can’t vouch for the accuracy, basically the only difference between H5 and H6 is the profanity….
H5 is just the upgraded audio sample quality without profanity
H6 is the upgraded audio with profanity.
They use the same sound roms to perform the “audio upgrade”, but instead of it being a selectable thing in the options, H5 just never calls the profanity.
So if you decided down the road to remove the profanity, you could buy just the H5 CPU and not have to buy the huge set again next time.
Quoted from a fairly reliable source that wishes to be anonymous in case this is bullshit. LOL

There is an option to turn it off in the menu....there is also the "FUCK YOU" on the display, which I guess is built into the game rom...I like it...but its pricey if you don't have a burner... I think 9 roms altogether when you're done...

#2110 54 days ago

Yah if its going all 9 roms, id want more background music as well and more call outs.

Blows me away they actually flew out to meet sly and snipes and record this stuff in person, feels like less than 10 call outs made it into the game and they cribbed everything else from the movie....

#2111 54 days ago
Quoted from trueno92:

Yah if its going all 9 roms, id want more background music as well and more call outs.
Blows me away they actually flew out to meet sly and snipes and record this stuff in person, feels like less than 10 call outs made it into the game and they cribbed everything else from the movie....

Someone needs to do a Pinsound mix for this machine....right now not worth it for the stock sounds...

Btw...anyone know how many machines were given away by William's to the producers?...I picked this one up last year from a pinsider

20211005_095616 (resized).jpg
#2112 54 days ago
Quoted from monkfe:

Someone needs to do a Pinsound mix for this machine....right now not worth it for the stock sounds...
Btw...anyone know how many machines were given away by William's to the producers?...I picked this one up last year from a pinsider[quoted image]

Saundra Bullock is still waiting to get hers lol

#2113 54 days ago
Quoted from Ceckitti:

Saundra Bullock is still waiting to get hers lol

Yeah I saw that video clip...too funny

#2114 51 days ago

Hey, I just joined the Demolition Man Pin club.

I’m expect you to laugh. I was highest bidder at the Museum of Pinball auction. I spent the last two weeks cleaning up the game, and fixing small problems. Took a picture of it set up today.

I loved this game since college. Every day in between classes I would be on the game trying to get a guy name Ben off the top score list and of course he would try to remove mine. I believe by the end we were up near 200 Billion. We also played 2 player when we had the same off period.

I’m not as good as I used to be. My best score in the last 2 weeks is only 5 billion.

I still have one issue. The dmd keeps freezing up on me. Any ideas where to look?

FF5E084B-A334-4419-9F07-2FDF1EF80793 (resized).jpeg
#2115 51 days ago
Quoted from westcoastbrian:

Hey, I just joined the Demolition Man Pin club.
I’m expect you to laugh. I was highest bidder at the Museum of Pinball auction. I spent the last two weeks cleaning up the game, and fixing small problems. Took a picture of it set up today.
I loved this game since college. Every day in between classes I would be on the game trying to get a guy name Ben off the top score list and of course he would try to remove mine. I believe by the end we were up near 200 Billion. We also played 2 player when we had the same off period.
I’m not as good as I used to be. My best score in the last 2 weeks is only 5 billion.
I still have one issue. The dmd keeps freezing up on me. Any ideas where to look?[quoted image]

Not gonna laugh at you. I will say, get connected with some local collectors and you will find some deals. I have had many issues that I worked through but I am not qualified to help out. If no one chimes in with some help go here and read through the sections that pertain to your issue. This site has helped me many times.

https://techniek.flipperwinkel.nl/wpc/index3.htm

#2116 51 days ago

Handles look good.. and hey - you bought it for the right reasons/memories.

2 weeks later
#2117 32 days ago

Joined this fine establishment over the weekend and I am STOKED! Game is filthy (just the way I like em'!) had a ground row short (found the source), ultimately needed a new U20 (thankfully socketed), multiple broken connections and well - the usual. I've taken care of all the operational issues except one...

The cryoclaw *was* working fine initially, then developed a magnet broken error. Basically everything checks out in test, except the magnet fails both at start up and in test. I suspect another continuity fault but want to better understand how to troubleshoot this.

I'm getting what looks to be no power at the coil lugs when in test - something like .431 vdc. From what I can tell the magnet is driven off the Fliptronics II board so my next step is to look for any connection breaks between the board and the magnet. Voltages seem to be correct coming off the fliptronics II as I get 60.2 vdc @ J907-6.

I disconnected the terminals from the coil magnet and buzzed the resistance and it checked out at 92 ohms; 20+ years I have yet to run across a bad magnet so that streak continues..

Question, because I don't have the Cryo assy apart and can't really tell: Is there a stop between the Fliptronics board and the magnet?

Any of you run ever run into this? westcoastbrian are you in the Seattle area?

Sorry in advance if I am missing the obvious, really appreciate any insights or at least if I am on the right track.

Pete Hoerber - Seattle

#2118 30 days ago
Quoted from Phoerber:

Joined this fine establishment over the weekend and I am STOKED! Game is filthy (just the way I like em'!) had a ground row short (found the source), ultimately needed a new U20 (thankfully socketed), multiple broken connections and well - the usual. I've taken care of all the operational issues except one...
The cryoclaw *was* working fine initially, then developed a magnet broken error. Basically everything checks out in test, except the magnet fails both at start up and in test. I suspect another continuity fault but want to better understand how to troubleshoot this.
I'm getting what looks to be no power at the coil lugs when in test - something like .431 vdc. From what I can tell the magnet is driven off the Fliptronics II board so my next step is to look for any connection breaks between the board and the magnet. Voltages seem to be correct coming off the fliptronics II as I get 60.2 vdc @ J907-6.
I disconnected the terminals from the coil magnet and buzzed the resistance and it checked out at 92 ohms; 20+ years I have yet to run across a bad magnet so that streak continues..
Question, because I don't have the Cryo assy apart and can't really tell: Is there a stop between the Fliptronics board and the magnet?
Any of you run ever run into this? westcoastbrian are you in the Seattle area?
Sorry in advance if I am missing the obvious, really appreciate any insights or at least if I am on the right track.
Pete Hoerber - Seattle

welcome

#2119 30 days ago
Quoted from Phoerber:

Joined this fine establishment over the weekend and I am STOKED! Game is filthy (just the way I like em'!) had a ground row short (found the source), ultimately needed a new U20 (thankfully socketed), multiple broken connections and well - the usual. I've taken care of all the operational issues except one...
The cryoclaw *was* working fine initially, then developed a magnet broken error. Basically everything checks out in test, except the magnet fails both at start up and in test. I suspect another continuity fault but want to better understand how to troubleshoot this.
I'm getting what looks to be no power at the coil lugs when in test - something like .431 vdc. From what I can tell the magnet is driven off the Fliptronics II board so my next step is to look for any connection breaks between the board and the magnet. Voltages seem to be correct coming off the fliptronics II as I get 60.2 vdc @ J907-6.
I disconnected the terminals from the coil magnet and buzzed the resistance and it checked out at 92 ohms; 20+ years I have yet to run across a bad magnet so that streak continues..
Question, because I don't have the Cryo assy apart and can't really tell: Is there a stop between the Fliptronics board and the magnet?
Any of you run ever run into this? westcoastbrian are you in the Seattle area?
Sorry in advance if I am missing the obvious, really appreciate any insights or at least if I am on the right track.
Pete Hoerber - Seattle

UPDATE: So the after checking continuity being good from the board to the magnet, for gits and shiggles I decided to throw a ball in the elevator cradle and fire the game back up. On the second pass, the magnet picked the ball up and dropped it at the completion of the left arm swing. The claw kept going though and after 6 passes, called it quits and threw the magnet broken dot. So, obviously whatever indicates the magnet is good isn't registering. I'll update more as I eliminate possibilities. Any advice on taking the Cryo assy off the PF or has anyone had this issue?

#2120 30 days ago
Quoted from Phoerber:

UPDATE: So the after checking continuity being good from the board to the magnet, for gits and shiggles I decided to throw a ball in the elevator cradle and fire the game back up. On the second pass, the magnet picked the ball up and dropped it at the completion of the left arm swing. The claw kept going though and after 6 passes, called it quits and threw the magnet broken dot. So, obviously whatever indicates the magnet is good isn't registering. I'll update more as I eliminate possibilities. Any advice on taking the Cryo assy off the PF or has anyone had this issue?

Take alot of pictures.

#2121 30 days ago
Quoted from Phoerber:

UPDATE: So the after checking continuity being good from the board to the magnet, for gits and shiggles I decided to throw a ball in the elevator cradle and fire the game back up. On the second pass, the magnet picked the ball up and dropped it at the completion of the left arm swing. The claw kept going though and after 6 passes, called it quits and threw the magnet broken dot. So, obviously whatever indicates the magnet is good isn't registering. I'll update more as I eliminate possibilities. Any advice on taking the Cryo assy off the PF or has anyone had this issue?

UPDATE 2 AND SOLUTION:

Ok, the ultimate culprit was the Elevator Hold opto pair. I did take the elevator assy off (piece of cake/4 screws), with the hardest thing being getting the opto pair connector back through the playfield. What made this quite bizarre was that particular switch was error'ing intermittently, and not knowing the logic of how this mech worked made it less obvious than someone who owned the game previously. Bottom line, if you have a bad opto at SW. 74 (ELEVATOR HOLD) the game will throw a Magnet Broken error. Bottom line the magnet was fine, and now everything works as it should. I also highly recommend reflowing all the connections on the board at the bottom of the Elevator assembly. And while your at it, get rid of the Z connector.

#2122 28 days ago

Got mine in yesterday. Did some cleaning, some LED upgrades and small fixes and it's 95% ok now.
Have 43 pages of post to read to get all possible LED setups and mods.

Got Fortress multiball but I didn't get extra balls (stayed at 1), next I got museum multiball and got 4 balls.

Any ideas why no extra 3 balls at Fortress ?

#2123 28 days ago
Quoted from rvermeire:

Got mine in yesterday. Did some cleaning, some LED upgrades and small fixes and it's 95% ok now.
Have 43 pages of post to read to get all possible LED setups and mods.
Got Fortress multiball but I didn't get extra balls (stayed at 1), next I got museum multiball and got 4 balls.
Any ideas why no extra 3 balls at Fortress ?

Multi-ball depends on how many balls you have frozen (the inserts in the playfield)

#2124 28 days ago

Yup. Depending how many times u hit the right inlane and left ramp combo, will determine how many ball freeze you get.

The game is punishing in multiball. I can juggle in nascar until the cows come home, but with dm, its like 4 ball mb and then 1 ball pretty quick.

Never mind demotime...

#2125 27 days ago
Quoted from ChrisPINk25:

Multi-ball depends on how many balls you have frozen (the inserts in the playfield)

Fortress multi-ball needs at least one freeze just to qualify it. So definately a problem there.

#2126 27 days ago
Quoted from ChrisPINk25:

Multi-ball depends on how many balls you have frozen (the inserts in the playfield)

Thx, will read manual as well... might be usefull...

#2127 25 days ago

Hello fellow Demolition men and women,

Wondering if anyone can confirm if this machine should have a MOV (metal oxide varistor) anywhere?

I did not see one in the power box, I noted that the line filter is located at the rear of the machine, but did not see anything resembling a MOV... but now I'm wondering if I missed it somewhere?

Anyway, just wondering if anyone can confirm. Thank you-

#2128 25 days ago
Quoted from Gorgar666:

Are the profanity Roms worth it?

Makes you snicker every time.. SO ya...

#2129 25 days ago

Gets old fast, as with most call outs... and u gotta replace a lot of roms...

#2130 25 days ago
Quoted from trueno92:

Gets old fast, as with most call outs... and u gotta replace a lot of roms...

If it starts getting old I’ll move to another.

AE002A67-D2A0-479A-BAEA-13719CCD31E1 (resized).jpeg
#2131 24 days ago

When I got my DM it had 4 balls installed, sticker with number of balls was gone.

I noticed in the manual it should have 5... So i put in a fifth one but it now launches 2 balls at every new ball .

Already added a WPC ball through protection plastic.

Suggestions?

#2132 24 days ago
Quoted from rvermeire:

When I got my DM it had 4 balls installed, sticker with number of balls was gone.
I noticed in the manual it should have 5... So i put in a fifth one but it now launches 2 balls at every new ball .
Already added a WPC ball through protection plastic.
Suggestions?

Check the ball through opto and its connectors, that's where such problems often stem from.

#2133 24 days ago
Quoted from Gorgar666:

If it starts getting old I’ll move to another.
[quoted image]

You wont be disappointed. The callouts are fun for sure. And there is a setting that you can easily switch back to normal.

#2134 24 days ago
Quoted from Ceckitti:

You wont be disappointed. The callouts are fun for sure. And there is a setting that you can easily switch back to normal.

Woohoo!

#2135 24 days ago
Quoted from Zigzagzag:

Check the ball through opto and its connectors, that's where such problems often stem from.

Cleaned optos, in test : switch edges all through optos are closed when balls are in and all are open when they are out of the game.
Did a reseat of the connectors. All cables are tightly connected...

anything else I could check ?

#2136 24 days ago
Quoted from rvermeire:

Cleaned optos, in test : switch edges all though optos are closed when balls are in and all are open when they are out of the game.
Did a reseat of the connectors. All cables are tightly connected...
anything else I could check ?

Check that each opto turns off correctly while you eject balls one at a time

#2137 23 days ago
Quoted from rvermeire:

Cleaned optos, in test : switch edges all through optos are closed when balls are in and all are open when they are out of the game.
Did a reseat of the connectors. All cables are tightly connected...
anything else I could check ?

Reseat any associated connectors.

#2138 23 days ago

As far as I can see there are only 2 connectors which I reseated : no effect

Also checked the optos :

We start at : all optos open 5 balls loaded in game

Ball 1 lifted (not shot out) : through 5 closed
Through jam closed ???
Ball 1 out : Through 5 closed
Ball 2 out : Through 4 closed
Ball 3 out : Through 3 closed
Ball 4 out : Through 2 closed
Ball 5 out : Through 1 closed

All balls back in

Through jam closed ??

What is this 'through jam' and what should be the status?

#2139 23 days ago
Quoted from rvermeire:

What is this 'through jam' and what should be the status?

Trough jam really is "trough kickout". It supposed to only register when a ball is kicked up to the shooter lane. Sounds like where you problem is. With power off, unscrew the transmitter opto board and let it hang and turn the game back on. See if the transmitter opto is lit up when the game is on through your camera phone or any other digital camera should work. If it is out, replace it.

#2140 23 days ago
Quoted from Phoerber:

westcoastbrian are you in the Seattle area?

Pete Hoerber - Seattle

No I am in Los Angeles, but I grew up in Seattle. I haven't lived there in 15 years.

#2141 19 days ago

I’m getting my skills back at this game.

The below score comes from 3 balls, 6 earned extra ball, 1 paid extra ball, over 50 combos, 5 multi balls and 2 demolition time.

C0C9F173-A0F3-4BBD-B771-6B84D5BCE6C4 (resized).jpeg
#2142 19 days ago

DM was one of those he first BW pins I got last year. Now I have about 28 or so and DM is criminally under rated.

Quoted from rvermeire:

As far as I can see there are only 2 connectors which I reseated : no effect
Also checked the optos :
We start at : all optos open 5 balls loaded in game
Ball 1 lifted (not shot out) : through 5 closed
Through jam closed ???
Ball 1 out : Through 5 closed
Ball 2 out : Through 4 closed
Ball 3 out : Through 3 closed
Ball 4 out : Through 2 closed
Ball 5 out : Through 1 closed
All balls back in
Through jam closed ??
What is this 'through jam' and what should be the status?

Trough jam opto is slightly above opto #1 on your trough boards.

Eject one hall and then gently drop it back in to the trough from the shooter lane so that it sits on top of the ball in position one. The jam opto should register

#2143 19 days ago
Quoted from PinballManiac40:

Trough jam really is "trough kickout". It supposed to only register when a ball is kicked up to the shooter lane. Sounds like where you problem is. With power off, unscrew the transmitter opto board and let it hang and turn the game back on. See if the transmitter opto is lit up when the game is on through your camera phone or any other digital camera should work. If it is out, replace it.

Many newer phones have IR filters so it won’t work

#2144 17 days ago
Quoted from The_Pump_House:

Many newer phones have IR filters so it won’t work

On iphones, the forward facing view would be the one to use, at least on the older ones. This is also why I mentioned digital cameras. I don't know of any new Androids having that issue. Android for me.

#2145 14 days ago
Quoted from The_Pump_House:

DM was one of those he first BW pins I got last year. Now I have about 28 or so and DM is criminally under rated.

Trough jam opto is slightly above opto #1 on your trough boards.
Eject one hall and then gently drop it back in to the trough from the shooter lane so that it sits on top of the ball in position one. The jam opto should register

Removed the transmitter board, more optos than expected ! (7) Cleaned it up and everything works now ! thx

1 week later
#2146 4 days ago

Looking for a NOS Playfield if anyone has or knows of one.

Parts - Wanted
Wanted! “If you have one I would be very interested thank you!”
4 days ago
Walnut Creek, CA
Wanted

#2147 2 days ago
Quoted from Soulrider911:

Looking for a NOS Playfield if anyone has or knows of one.

Same.. I've been looking for a while myself.

There are 2,147 posts in this topic. You are on page 43 of 43.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside