Demolition Man Owners Club.... Members Only!

(Topic ID: 31302)

Demolition Man Owners Club.... Members Only!


By Rascal_H

6 years ago



Topic Stats

  • 1,304 posts
  • 264 Pinsiders participating
  • Latest reply 1 day ago by GreenMachine19
  • Topic is favorited by 86 Pinsiders

You

Linked Games

Topic Gallery

There have been 840 images uploaded to this topic. (View topic image gallery).

A56DF928-8193-45FE-93DF-C92718AE7ABA (resized).jpeg
EF7D16A5-3225-4ABC-B9F6-3400CF44070C (resized).jpeg
745737DE-F298-4873-9434-34FA6238935D (resized).jpeg
1C79C5F9-E200-4BEE-AFDA-A4BB63CDFE27 (resized).jpeg
7F829664-AF68-4FCC-BED0-7E168ACF7A2F (resized).jpeg
35320A6C-2ED5-4BED-A814-E1513E31FDEF (resized).jpeg
CC90C917-4FA2-4C27-B20A-80D836B1717E.gif
745AF929-781C-4DE1-8AE0-A038747721FC.gif
image (resized).jpg
image (resized).jpg
image (resized).jpg
image (resized).jpg
image (resized).jpg
image (resized).jpg
IMG_20190217_145049 (resized).jpg
image (resized).jpg

There are 1304 posts in this topic. You are on page 23 of 27.
#1101 4 months ago

I push one normal pressure, no issues. Something going on.

#1102 4 months ago

On mine thus far a regular press releases the ball from the magnet except when over super jets. After I press it it takes a while before dropping. When over the others it drops right away. Doesn't make sense but that's what I'm getting.

Also a multiball question. When starting fortress multiball sometimes after hitting the top lock I get 1 kicked out and other times 2 kick out to give me 3 ball. Is there a way to add a ball or is this an error. I had a trough opto issue and all 4 left in the trough would kick out but since I corrected that it's kicking out 1 but sometimes 2. The game should know there's one in the top lock since that's what starts multiball and it is kicked back into play after the animation. I've tried the museum multiball a couple times and it was correct with 3 total but I haven't tried them all as I'm just trying to work through bugs as I find them.

I've had it less than a week so I don't have a reference of it working differently before or if it's been this way for sometime.

#1103 4 months ago

The number of balls is based on the number frozen (lights on playfield)

#1104 4 months ago
Quoted from Walamab:

I tried my hand at this with blue crescent inserts

Thanks for the info, walamab . I haven't heard from anyone else that needs triggers, and given the setup cost to do this right (>$200) I'm likely not going to take the project on. My triggers are fine but I'd use them to create the molds if there were at least 10 people willing to pay around $20 for a set of triggers so I could hopefully come close to breaking even!

#1105 4 months ago

My claw always drops the ball instantly when you hit either button, regardless of position

#1106 4 months ago
Quoted from SunMonkeyAZ:

On mine thus far a regular press releases the ball from the magnet except when over super jets. After I press it it takes a while before dropping. When over the others it drops right away. Doesn't make sense but that's what I'm getting.
Also a multiball question. When starting fortress multiball sometimes after hitting the top lock I get 1 kicked out and other times 2 kick out to give me 3 ball. Is there a way to add a ball or is this an error. I had a trough opto issue and all 4 left in the trough would kick out but since I corrected that it's kicking out 1 but sometimes 2. The game should know there's one in the top lock since that's what starts multiball and it is kicked back into play after the animation. I've tried the museum multiball a couple times and it was correct with 3 total but I haven't tried them all as I'm just trying to work through bugs as I find them.
I've had it less than a week so I don't have a reference of it working differently before or if it's been this way for sometime.

Mine acts up on the superjets, but it is when the wireform is not seated right and the ball is actually released, but it does not fall because it is resting on the wires and the claw.

#1107 4 months ago
Quoted from ChrisPINk25:

The number of balls is based on the number frozen (lights on playfield)

Does that mean I can freeze more than the required amount? Fortress has one freeze light lit meaning it requires one. If I freeze two or three before locking to start multiball I'll get that many extras?

Quoted from Tomass:

Mine acts up on the superjets, but it is when the wireform is not seated right and the ball is actually released, but it does not fall because it is resting on the wires and the claw.

I'll check later to see if it is being released but just sitting there until the claw moves. Maybe it's close enough that it's not really dropping but the magnet is off.

#1108 4 months ago
Quoted from SunMonkeyAZ:

Does that mean I can freeze more than the required amount? Fortress has one freeze light lit meaning it requires one. If I freeze two or three before locking to start multiball I'll get that many extras?

.

Yes

#1109 4 months ago

Both buttons work when getting the jackpots when the muntilball starts. Up until the last week I could push the right button and it would drop instantly. Now I put the crane over the drop i want and wait for the time to run out.

#1110 4 months ago

Do the buttons register during switch test?

#1111 4 months ago
Quoted from zacaj:

I thought Marco had them?

Marco doesn't have the swear roms either, any other options?

#1112 4 months ago

I got mine from pinsider ASTILL.

#1113 4 months ago
Quoted from allsportdvd:

Marco doesn't have the swear roms either, any other options?

I'd be happy to burn you a set of swear ROMs, but it would be cost prohibitive to ship them to Australia. I'm sure someone more local to you can get them. Have you tried any of the Aussie forums?

#1114 4 months ago

Spyderturbo007 yes both buttons register in the test.

#1115 4 months ago
Quoted from smoothbore19:

Both buttons work when getting the jackpots when the muntilball starts. Up until the last week I could push the right button and it would drop instantly. Now I put the crane over the drop i want and wait for the time to run out.

Yea I'm kind of in the same boat on this too. But it works good enough

#1116 4 months ago

I’m still getting 2 balls kicked out on fortress instead of one. Even manually throwing the ball to make sure I hit nothing else. Start game, activate crane, hit crane, drop into freeze, hit multiball shot. 2 balls kick out and really quick. Right when first ball is launched second one is ejected into lane. I’ve notice on museum when there should be 2 balls kicked out there is a little delay between them but not here so something’s up.
Secondly I’ve had some issues I haven’t found in researching. A few times I’ve got a divertor stuck open error which points to switches according to manual. I’ve got magnet broken error here and there and during gameplay crane will start going back and forth and elevator goes up and down. They’ll keep doing it until I shoot a ball up there and then the crane gives the ball back and they stop. I’m guessing from all these things the game is losing track of balls or some switch errors. Everything goes ok in test though. Based on these symptoms is there particular switches to look at?
I’m really enjoying playing the game but the weirdness gets annoying and I can’t get through a whole game without one of these happening.

#1117 3 months ago
Quoted from SunMonkeyAZ:

I’m still getting 2 balls kicked out on fortress instead of one. Even manually throwing the ball to make sure I hit nothing else. Start game, activate crane, hit crane, drop into freeze, hit multiball shot. 2 balls kick out and really quick. Right when first ball is launched second one is ejected into lane. I’ve notice on museum when there should be 2 balls kicked out there is a little delay between them but not here so something’s up.
Secondly I’ve had some issues I haven’t found in researching. A few times I’ve got a divertor stuck open error which points to switches according to manual. I’ve got magnet broken error here and there and during gameplay crane will start going back and forth and elevator goes up and down. They’ll keep doing it until I shoot a ball up there and then the crane gives the ball back and they stop. I’m guessing from all these things the game is losing track of balls or some switch errors. Everything goes ok in test though. Based on these symptoms is there particular switches to look at?
I’m really enjoying playing the game but the weirdness gets annoying and I can’t get through a whole game without one of these happening.

Sounds like you have some opto issues... Something in the trough and probably the one at the top of the elevator. I'd just replace that one to start.

#1118 3 months ago

In the backbox Reseat the right side connectors going to the boards on the right. Id prob go over the pins, check for board damage, or burnt pins on any of the molex connectors.

#1119 3 months ago
Quoted from zacaj:

Sounds like you have some opto issues... Something in the trough and probably the one at the top of the elevator. I'd just replace that one to start.

Yep, thats what mine did when the elevator opto would fail. Mine would do that after warmup. Also the frame holding the board on the claw can be easily bent down a touch and the optos don't see the claw. Found that out after replacing an opto to no avail. That claw can be iffy.

#1120 3 months ago
Quoted from Tomass:

Yep, thats what mine did when the elevator opto would fail. Mine would do that after warmup. Also the frame holding the board on the claw can be easily bent down a touch and the optos don't see the claw. Found that out after replacing an opto to no avail. That claw can be iffy.

Yeah when having issues with it the best thing I think is to just replace all the claw/elevator optos and repin their connectors. That's what it took to finally iron mine out

#1121 3 months ago
Quoted from zacaj:

Yeah when having issues with it the best thing I think is to just replace all the claw/elevator optos and repin their connectors. That's what it took to finally iron mine out

Mine actually started acting up last night. I am gonna reflow pins and repin connectors.

#1122 3 months ago

I had funky problems with ball counts in mine and traced it to the trough optos. While poking around the boards I discovered how HOT the big 2 watt resistors on the transmitter optos get. Like, REALLY HOT! This combined with ball bangs(!) and vibration have to be bad for solder joints over the long run. Since I had to do work on the boards I went looking for modern replacements and found them by Great Lakes Modular. These use surface mount components, are much more efficient, and don't get hot. They're only $60 for a set of TX/RX. Once replaced my weird problems were cured. Highly recommended! Edit: They also make replacement Claw Opto boards.

http://www.greatlakesmodular.com/products/pinball/dcs_tr.html
http://www.greatlakesmodular.com/products/pinball/dcs_tt.html
http://www.greatlakesmodular.com/products/pinball/dmcob.html

#1123 3 months ago

Is GLM fuffiling orders even?

1 week later
#1124 3 months ago

Doing a full tear down resto. I had to get my subway weldment repaired due to it becoming separated. A nuclear qualified welder hooked me up at work. Should never come apart again.

4A9CAB53-B914-44E6-BEFE-CC445A17F022 (resized).jpeg72BA9CB3-4822-4A24-AC38-3F6BC0F7FAEC (resized).jpegDA451FE5-7B4A-46A4-B20A-19B719160380 (resized).jpegE58F71BC-F121-475F-9A80-4B37CADEC6AF (resized).jpegFA3606C0-4118-4914-8249-70947F9CE169 (resized).jpeg
#1125 3 months ago
Quoted from GreenMachine19:

Doing a full tear down resto. I had to get my subway weldment repaired due to it becoming separated. A nuclear qualified welder hooked me up at work. Should never come apart again.

Yeah, that weldment takes quite a beating. Mine had to be repaired as well.

1 week later
#1126 3 months ago

My demo man has black handles and not the chrome ones I normally see. Did they ever sell aftermarket handles that were not chrome?

#1127 3 months ago
Quoted from Lemank:

My demo man has black handles and not the chrome ones I normally see. Did they ever sell aftermarket handles that were not chrome?

That's the Wesley Snipes edition. Limited run.

#1128 3 months ago
Quoted from djreddog:

That's the Wesley Snipes edition. Limited run.

Really? Can I see a pic?

#1129 3 months ago

Joined the club again but this time its the nicest one I have ever seen.Its the one fom Allentown that looked brand new.Clearcoat,new decals,color display new coin door and legs, all new plastics.It goes on with %100 leds including flashers flipper fidelity speakers and the best is the beautiful chrome package put on this pin.Added a subwoofer to make it really rock..Im glad I had the chace to snag it.
Special thanks to Bob Butch. Great Seller

9592486C-55F1-403A-BD6D-675680ED1F50 (resized).jpegB4048AC1-A988-4FDC-9B85-C45BDD3ED5D1 (resized).jpegF7412185-EA36-492C-B7FF-DB6DE5B3D0D9 (resized).jpeg
#1130 3 months ago
Quoted from allsportdvd:

Really? Can I see a pic?

Here is a pic. I think he was joking about the Wesley snipes version.

13E73522-99E3-4155-AA3C-00D845A6BB87 (resized).jpegBEC17AC6-E9E1-448A-B780-A136F3BB5618 (resized).jpeg
#1131 3 months ago

Picking up a DM in 2 weeks want to order LED's so they get here by the time the pin comes. Anyone have a count on what I need to order? flashers, 555' and bayonets, etc. Really would help.

Thanks Brad

#1132 3 months ago
Quoted from Demoman1:

Picking up a DM in 2 weeks want to order LED's so they get here by the time the pin comes. Anyone have a count on what I need to order? flashers, 555' and bayonets, etc. Really would help.

You can buy a pre-assembled kit that has every LED you will need ...

https://www.cometpinball.com/product-p/demolition-man-led-kit.htm

#1133 3 months ago

Hi Pinside,
First of all I want to give some well deserved credit to the Evan and Mike down at orange county pinballS ! I picked up a demo man recently and brought it straight to them for a good cleaning and a once over. I had some extra moo-la in the budget so I sprang for some powder coating as well. They gave me back one of the smoothest and nicest demo mans I have come across. Of course my POS phone can't take pictures good enough to do the machine justice.
Anyways, one of the things that needed replacing was one of my triggers. everybody knows these are hard to find. So I took one of my good ones to a cnc shop to see what it would take to have these made out of aluminium. They just got back to me with a quote: 50pcs @ 12.50 each 100pcs @ 9.50 each. I did want to make some extra sets and make them available to other owners, but I'm not in a huge rush to drop $625, at least without some of you backing me up. I did ask the shop what is the least amount they will produce and am still waiting on a reply. So I pose the question, would anyone like to commit to buying a set of these for around 25 bucks? Depending on how many are made, and obviously you will pay for shipping as well, I'm not trying to make anything off of this I just think the community needs some of these. Let me know and I will start a list / count,
thanks

20181120_185022 (resized).jpg
#1134 3 months ago

Sorry, I forgot to add this rendering of the trigger I recieved from the cnc shop. Send me a pm if your're interested.
thanks

image004 (resized).jpg
#1135 3 months ago

I've noticed lately that I no longer am getting a ball save when I hit the car crash shot. I have the car crash ball save set to "easy", which is the factory default. I checked, and both optos as well as the red target are registering correctly in switch test. It even shows the "double car crash" award on the screen when I nail the shot solidly. Any theories?

#1136 3 months ago
Quoted from gweempose:

I've noticed lately that I no longer am getting a ball save when I hit the car crash shot. I have the car crash ball save set to "easy", which is the factory default. I checked, and both optos as well as the red target are registering correctly in switch test. It even shows the "double car crash" award on the screen when I nail the shot solidly. Any theories?

I think only the back target triggers it? At least, definitely not the first opto. Mine seems to come and go

#1137 87 days ago

Picked up a Demo Man last night, happy to back in the club. It's has one broken and one missing plastic. Hoping someone might have extras.

DM004 (resized).jpglarge (resized).jpg
#1138 87 days ago
Quoted from waldo34:

Picked up a Demo Man last night, happy to back in the club. It's has one broken and one missing plastic. Hoping someone might have extras.

That big one by the upper flipper is always broken. Hopefully, someone has a new or used one lying around. Good luck!

#1139 87 days ago
Quoted from gweempose:

I'd be happy to burn you a set of swear ROMs, but it would be cost prohibitive to ship them to Australia. I'm sure someone more local to you can get them. Have you tried any of the Aussie forums?

I would be down for the swear roms if you could get me some.
I could PayPal you some cash.

#1140 87 days ago

I’ve been after that big one since I got my machine too, everyone in the normal list is sold out so unlikely we’ll find it unless you buy a whole plastic set

#1143 86 days ago

Thanks, just tried to order. The website is having an issue with USA shipping. Hopefully, I can call them.

This is interesting, it's a remake of the large common broken plastic "mirrored metal Plastic".
https://shop.thepinwitch.com/Game-Specific/Williams-75/Demolition-Man/product-3836.html?language=en

#1144 86 days ago

Pinball Center stopped shipping to the US over a year ago... Keep searching.

#1145 86 days ago

I have a full set of plastics I would be willing to sell. Not interested in breaking up the set at this time.

#1146 86 days ago

Here are pics of the set.

E4E1BFE2-2EFF-4B0F-8264-E2E7DB26183E (resized).jpeg51FF9AA3-ED2A-45F0-9830-6DFC76B03B0D (resized).jpeg94013E0A-C1C5-44F3-A235-5E5A200E6DC6 (resized).jpegE040EC00-AEC0-4F3F-80FA-28300D78482A (resized).jpeg
#1147 86 days ago

Anyone had trough issues? After I start a game the balls continue to cycle.

#1148 86 days ago

Plastics are sold.

#1149 84 days ago

My Cryoclaw is growling lately when it moves the first couple of inches. Is this a motor problem or the gearbox?

#1150 84 days ago
Quoted from waldo34:

Anyone had trough issues? After I start a game the balls continue to cycle.

Game doesn’t stage balls like some of the other widebodies. I’d check your trough optics.

Promoted items from the Pinside Marketplace
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
2,600
Machine - For Sale
Friendswood, TX
$ 18.95
$ 20.00
Electronics
Yorktown Parts and Equip
From: $ 9.99
Eproms
Matt's Basement Arcade
$ 40.00
Lighting - Other
Rock Custom Pinball
$ 10.00
Playfield - Decals
Metal-Mods
$ 9.99
Eproms
Matt's Basement Arcade
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
$ 159.99
Lighting - Other
Lighted Pinball Mods
From: $ 369.95
Boards
PinSound
$ 45.00
Cabinet - Other
Rock Custom Pinball
From: $ 16.95
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
$ 29.99
Cabinet - Sound/Speakers
Lighted Pinball Mods
$ 269.99
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 229.99
Lighting - Other
Lighted Pinball Mods
$ 50.00
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 28.00
$ 47.00
From: $ 29.00
Boards
KAHR.US Circuits
$ 129.00
Lighting - Led
LED OCD
Hey modders!
Your shop name here
There are 1304 posts in this topic. You are on page 23 of 27.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside