(Topic ID: 24568)

Demo Man help

By majorrager

9 years ago



Topic Stats

  • 7 posts
  • 3 Pinsiders participating
  • Latest reply 9 years ago by Celiac502
  • No one calls this topic a favorite

You

Linked Games

#1 9 years ago

I recently had my DM set to tourney mode. After a while, I switched it back and realized while playing that the number of combos to light first extra ball had gone from 12 (factory setting) to 14. Went into the settings menu to check and it was still showing 12. Reset it to make sure and it shows 12 but when game starts it still takes 14. Anyone else encounter this problem? Not sure how it relates to switching back from other mode as it was only taking 12 combos while set in tourney mode. Also, I'm having trouble with the knocker. Since I got the game, the knocker has been sporadic in its noise making. When I ran the menu test on it, it works great. However, during game play it is much softer or doesn't strike at all. I changed the coil sleeve and replaced the plunger with one that had the nylon tip. It would fire but not knock, so I put my original plunger back in and it worked again, but still seems like if anything is happening during game play, it doesn't knock properly like it isn't getting enough current to properly fire the plunger and the knock it muffled. Thanks for any help.

#3 9 years ago

As for the 14 vs 12.. try resetting to factory settings. The knocker is kinda odd thought that it works in test but not in game play... when do you think it should be knocking I guess I should ask first?

Knocker normally only fires when either a match is made or you break the high score and get a free game.

#4 9 years ago

I didn't reset the factory settings but will try it. As for the knocker, with active ball in play when replay is hit, it is very weak or muffled. If I get replay after a ball drains with the bonus or when it matches at end of game, it seems to work fine.

#5 9 years ago

Silly question but how do you really know when it's suppose to knock, my DM only knocks if I break a top number 1 score or I get a match. Both of which is rare because my top is around 4.5 billion and I suck at ponball and I have match turned off because of free play. So I guess when you say it fires fine during test but only sometimes during play I would think that's normal unless there is something different in tourney mode that I don't know of. I don't have enough friends to have tournaments lol.

#6 9 years ago

It should knock for replay regardless of setting (350,000,000 factory I believe), and mine is set to free play also but still runs the match sequence at the end of the game. I don't have a ton of friends who play either, but we're all super competitive and tourney settings help ensure that each game's values and rewards don't carry over from player to player so it gives no one an advantage and it also makes the game a little harder by killing certain features such as ball saves, etc.

#7 9 years ago

I don't know man that sounds like one of those "wtf" problems that does not make any sense. Those are always the best to track because they take the norm out of normal, I'd be happy to provide any pics of mine that you may need.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside