New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 177531)

Dead flipper on Firepower


By Euchrid

3 years ago



Topic Stats

  • 11 posts
  • 6 Pinsiders participating
  • Latest reply 3 years ago by Schwaggs
  • No one calls this topic a favorite

You

Linked Games

#1 3 years ago

Ok, I give up. Got my firepower boards back from Being bulletproofed. Put them in and it boots, some switches need help, some display parts are out and the flippers are weak. I get a rebuild kit, rebuilt the right flipper and it's still somewhat weak. I screw around with it for an hour or so adjusting eos or whatever. I then turn off the game, take off the flipper solenoid to inspect it and make sure I put the coil sleeve in right and then reinstall the solenoid. Turn the game back on and now that flipper is now totally dead - it won't flip at all. I checked all three lugs and am getting ~32 volts at each, the left flipper works so the fuse is fine, checked all the solder joints, checked the flipper button connection - it just worked moments before - I'm stumped. Anyone have any ideas?

#2 3 years ago

Temporarily jump the EOS switch with an alligator clip to test. **Do not hold the flipper up for more than 3 seconds under these conditions.** Just enough to test for a power flip.

#3 3 years ago

Nope, flipper still does nothing when button is pressed.

#5 3 years ago

check the resistance across closed contacts of cabinet switch and eos ,good clean contacts should read .2 to .4 ohms.

#6 3 years ago

Sounds like your EOS switch is not making good contact. Make sure the contact points are pressing together with good pressure when the flipper is not activated. Make sure that when the flipper paul is fully pulled into the coil that the EOS points are separated by 3/16 to 1/8"

#7 3 years ago

I'll check these suggestions out when I get home tonight - thanks!

#8 3 years ago

Ok, it was the eos gap as Schwaggs suggested. It sure looked closed, but I guess it wasn't. Thank you all.

#9 3 years ago
Quoted from Euchrid:

Ok, it was the eos gap as Schwaggs suggested. It sure looked closed, but I guess it wasn't. Thank you all.

You destroyed mission.. lol love my firepower...

#10 3 years ago
Quoted from Euchrid:

Ok, it was the eos gap as Schwaggs suggested. It sure looked closed, but I guess it wasn't. Thank you all.

And yet it still failed with the switch jumped...

#11 3 years ago

Congrats on the fix!

Promoted items from the Pinside Marketplace
$ 12.00
Cabinet - Other
Siegecraft Electronics
$ 349.95
Lighting - Led
Pin Stadium Pinball Mods
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
From: $ 9.00
$ 33.00
Playfield - Decals
Metal-Mods
1,400
Machine - For Sale
Sussex, NJ
$ 499.95
Lighting - Led
Pin Stadium Pinball Mods
From: $ 1.25
Playfield - Other
Rocket City Pinball
2,000
Machine - For Sale
Omaha, NE
$ 11.00
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
From: $ 18.00
Apparel - Men
Pinside Shop
$ 50.00

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside