(Topic ID: 203580)

DE Star Wars pop bumper fires randomly


By martymart

3 years ago



Topic Stats

  • 8 posts
  • 4 Pinsiders participating
  • Latest reply 3 years ago by martymart
  • Topic is favorited by 1 Pinsider

You

Linked Games

#1 3 years ago

I am finally working through a number of issues I have had with this machine. The last one I currently have is on occasion when the top pop bumper fires the middle right bumper also looks to fire. This is very random and does not happen all the time.

I have so far checked the switch gap which has good clearance, checked cables for any shorts (visual around the area). I am not sure what can cause this to happen. Any advice on where to look next would be appreciated as it is one of those things that is driving me mad.

#2 3 years ago

Hi Martymart
Double check all fuses and fuse clips. DE games tend to act randomly when those fuse clips are nearly broken.

#3 3 years ago

id reflow solder on ppb board too. those boards cause all kinds of issues.

#4 3 years ago

Thanks for the feedback. I will check both of these tips out during the week and see if it improves.

#5 3 years ago

I have reflowed the solder on the board and checked the fuse clips although still look to have the same problem. The board looks like it has had some repairs previously. Is there any particular components I should be looking at in case it is an actual component that needs replacing as there shouldn't be any cold joints left on the board. Thanks again for everyone's assistance.

#6 3 years ago

I have had another look at this one and think I need to go back and look at the switches / cables to see if there is any shorts I haven't found. I have replaced every board by taking them out of my other DE machine to see if it is a board issue and on every occasion I still had an issue with the middle right pop bumper firing when the top bumper fires (not every time).

I was thinking could a diode that is on its way out cause this. Not sure where to look next and any advice would be appreciated.

#7 3 years ago

Is it doing it when the ball is in the pop bumper area, like could it be a vibration thing? Spoon switches too close together maybe?

John

#8 3 years ago

I have only noticed it when the ball is in the area hitting the top bumper and then on occasion without the ball hitting it the right bumper fires. I was also thinking vibration may be the cause and I have tried to replicate it in diagnostics and game mode by taping on the playfield but no luck. The gap on the spoon switch looks ok and not to close.

Promoted items from the Pinside Marketplace
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 35.00
Cabinet - Other
Arcade Upkeep
From: $ 1.25
Playfield - Other
Rocket City Pinball
$ 39.50
Playfield - Toys/Add-ons
Pixels Arcade Games
$ 79.99
Playfield - Toys/Add-ons
Lighted Pinball Mods

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside