(Topic ID: 223147)

DE Star Wars - Left Scoop switch triggers left VUK

By bmlors

3 years ago



Topic Stats

  • 6 posts
  • 3 Pinsiders participating
  • Latest reply 2 years ago by Pejizzzy
  • No one calls this topic a favorite

You

Linked Games

You're currently viewing posts by Pinsider bmlors.
Click here to go back to viewing the entire thread.

#1 3 years ago

Have an odd problem with my Data East Star Wars machine that I'm hoping someone may shed some light on. When a ball goes into the "Force" scoop (called the left scoop in the manual), it immediately triggers the left VUK to fire 6 times (quickly -- it's empty) and then the machine comes back and fires the ball up out of the scoop. The switches all appear to be fine (it scores normally and I've run the diagnostics on every switch/coil on the machine...all test good). I've checked all of the fuses and they all test good. The game is playable as-is...but it's very odd. Also...possibly unrelated, but at the same time the Force scoop started behaving weird, I noticed that the left "Taun Taun" light stays lit all the time during game play.

The game used to work fine, btw, until I upgraded the power board (to xPin) and the sound board (Pinsound). At the same time I also swapped out a ball trough switch that was acting flaky. So somewhere in the midst of monkeying with it I appear to have messed with something that I can't figure out.

Any thoughts on what to check out would be appreciated.

#3 3 years ago

I will double check this evening when I'm back at the machine -- I try to be pretty careful about taking a picture before I do any work and then restoring it to the same state, but it's quite possible I missed something. Does anyone have a picture of that area of their machine so I know what "right" looks like?

#5 3 years ago

Thanks for the suggestion — you nailed it. Had the white/green wire into the wrong tab on the switch — re-soldered to the correct spot and all is well again. My limited electronic understanding doesn’t quite get how that causes the odd behavior I was seeing, but I’m very grateful for the advice fix. Thank you!

You're currently viewing posts by Pinsider bmlors.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside