(Topic ID: 207960)

Data East Torpedo Alley sinking: Solenoid, Switch, or PPB issue?


By goingincirclez

1 year ago



Topic Stats

  • 17 posts
  • 3 Pinsiders participating
  • Latest reply 1 year ago by snyper2099
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

One image has been uploaded to this topic. (View topic image gallery).

20180122_204322 (resized).jpg

#1 1 year ago

Out of nowhere my Torpedo Alley has a funky issue: the outhole kicker won't work. Neither does the associated "scope" (sinking ship) flashers.

Unfortunately there is no smoking gun here, so this might be a challenging one. Troubleshooting, symptoms, and leads are as follows:

- When the outhole switch is triggered, the PPB relay just clickclickclickclickcliks. If you release the outhole switch, it stops. Game plays perfectly fine otherwise.
- Solenoid test confirms the coil/flasher - Solenoid 7 - for this does not work.
- Transistors for Solenoid 7 look fine and meter fine
- As it happens, I had some cold solder joints on the PPB circuit for this last April, so that was the first place I looked. But near as I can tell, the PPB components are all OK... despite the evidence of heat on this one specific circuit. But all components are in spec. I replaced the relay diode.

Further testing:

- Is the MPU Solenoid 7 transistor bad despite testing OK? Well, if I disconnect that solenoid's harness from the MPU, the PPB relay still clickclickclicks... so it IS in the PPB somehow?
- Looking at the PPB diagram in the manual, there are several I/O connectors... maybe something else is escaping me. Let's disconnect all the connectors and try to narrow down the fault source. Well, one by one... ultimately disconnecting ALL of them, it still clicks! Well that of course isn't true: I have to connect power to it at CN6, which all goes through the relay. But absent all other signals via the connectors, what the heck is telling it to click the relay at that point?? Because yes, if I release the outhole switch, the clicking stops!
- If I disconnect the both switch matrix connectors from the MPU, the PPB clicking stops. Ah... is it a switch matrix issue....?
- ...testing the matrix, all board components test in spec, including the ones for the outhole. But it occurs to me, since I have to unplug BOTH switch connectors to clear the fault, that it might really not be the switch matrix as much as me essentially disconnecting the switch itself... which is also what would happen if the coil would fire and kick the ball off it... so yes, it's still essentially a coil fault, but not really?
- FWIW the Diode on switch tests fine.

So... what am I missing here? I'm still baffled as to why the PPB clicks only with its power harness connected, when that outhole switch is triggered. Switch tells the game to fire the coil but it can't... so the switch stays triggered... that much makes sense... but I disconnected all coil signals in the PPB so what is the routing I am missing in the schematic? And what could the problem be?

#2 1 year ago

Not worked on one of these, but I'm pretty sure what's clicking is the relay allowing power to the solenoids. It looks like it should be doing this - you push the switch, it allows the power through so the coil can fire. Every time the coil would pulse, it pulses the relay too. My guess is that despite readings, your transistor is bad, or has a bad solder joint. If it were something with the outhole, the flashers would work. The game clearly is trying to fire it, but the voltage isn't getting to ground. Change Q40, and see what happens.

#3 1 year ago

Yeah, That conclusion clarified to me after I typed all that out. So last night I did some more testing, and this is what I found. It's progress, clear as mud:

- I changed the coil diode, and then transistor Q40. No change. This did not surprise me because the original parts looked fine and tested in spec before, and even out of the circuits.
- But as concluded above, the game is clearly click-looping just because it can't fire the coil, so has it lost continuity elsewhere in the wire path? I started testing continuity between connectors, with my meter. Ah-ha, there's nothing between the coil and the MPU connector J11...!
-...so I look at J11 and sure enough, strangely, just that one single pin is oxidized green and burnt looking. The wire breaks right off as I'm looking closer. Ah, that's it right? I fix the wire, reconnect and...
-...the (new) transistor locks on. Which is strange because I don't think it was even attempting that before: during all other previous testing it never got hot (but sure does now)!

So OK, maybe I effed up or got a bad transistor: I could replace it again, BUT why was it never locked/hot before? And that line on the PPB looks toasty... from the pin on its MPU connector all through the PPB traces... which indicates some sort of problem may have been around for a while, right? Which is cause vs. effect?

Can a failed transistor cause other stuff (wiring, PPB) to cook upstream before burning itself to bits? Or is the transistor fine, and the problem hiding elsewhere? Going back to what I had before: If a transistor is in a locked state, will it not get hot if you disconnect its coil/flasher load (via the bad wire from before) and thus suppress current draw?

Like I said, clear as mud. Trying to make sure I understand things before I assume this was a coincidence, replace the transistor again and still have it locked...or burn a hole in my MPU trying to test it further...

#4 1 year ago
Quoted from goingincirclez:

I changed the coil diode, and then transistor Q40

Hmmm. I would guess that you installed the diode the wrong way.

#5 1 year ago
Quoted from snyper2099:

Hmmm. I would guess that you installed the diode the wrong way.

My first thought as well, but I checked and it seems correct compared to other coils.

Also, FWIW when you turn on the game, the flashers associated to Q40 are what lock on first (in fact, that was the first thing I noticed when I turned the game on after fixing the connector wire - those were on solid even before the game fully booted). The coil doesn't fire unless/until the PPB relay switches to the coil side... so I'd presume a backwards coil diode wouldn't have affected the flashers. Is that correct?

#6 1 year ago
Quoted from goingincirclez:

My first thought as well, but I checked and it seems correct compared to other coils.

Well, this doesn't make sense. You can't tell if it's right by "just looking".

You should probably remove one wire and test for DC voltage at the wire(s) to determine which side is power. THAT power wire goes to the white banded diode side and the other wire goes to the non banded side. That way you know for certain that you have it right. For future reference regarding pinball coils in general, it does not matter which way the diode goes on a two lug coil. It ONLY matters that the power wire connects to the banded side.

To test for power, DC volts setting, black multimeter lead on side rail of cabinet, red multimeter lead on each wire. The wire that has power is the wire that goes to the banded side of the DIODE. Should read about 30-34 VDC in attract mode.

#7 1 year ago
Quoted from goingincirclez:

so I'd presume a backwards coil diode wouldn't have affected the flashers. Is that correct?

THAT is correct.

The drive transistor also has a pre drive transistor (much smaller one) that could also be shorted. I also always replace those whenever replacing a TIP102. They are like .20 cents. Test the pre drive trans. compared to the other pre drive transistors on the board.

#8 1 year ago

You're right about the coil / diode arrangement. What I meant by "looking" is, I was 95% sure I noted the band orientation before I removed the old one. To allay that 5% uncertainty, I compared to the wire colors on nearby coils of the same type/purpose. There could of course be a chance I screwed up even then, but it's not like I just glanced and tossed it in there 50/50.

Quoted from snyper2099:

Test the pre drive trans. compared to the other pre drive transistors on the board.

See, this is where confusion comes from here: I do this, and everything matches. Even the previous Tip122. And the new one. As well as all the predrivers. And resistors. And legs on the 7408. I know they can "fail but look good"... I have experienced this... but much more often in my experience when they look good, they in fact are, and the problem is something else I haven't found. It's great when they test bad, boom, done. When they look good like now, but something is obviously wrong, is when things get frustrating.

I'm going to try and check this tonight - confirm the coil diode as you suggest... replace the Q's, suspecting maybe a 7408 or something else. Trouble is I don't want that Q frying my board while I poke around for other signals and symptoms.

Compounding the issue, this game went down while a young guest was playing while I wasn't home. I've no way of knowing if it was a sudden freak thing, or if it slowly burned itself to failure while he was playing. Obviously he had to quit when the outhole wouldn't return balls. But I don't know how the failure originated or progressed (did the Q lock on for a time before the coil quit... Did it burn up that connector or is that a red herring coincidence?). I guess no op would cry for me ha ha.

#9 1 year ago
Quoted from goingincirclez:

suspecting maybe a 7408

Pre drivers are notorious for testing good but being bad. That's why I just replace them without even thinking when it's main transistor fails.

If you replace the pre drive and everything else tests good, I would replace the 7408 next.

#10 1 year ago

Test the resistance of the coil. See if it matches up with what it's supposed to be. It may have locked on, shorted the coil, and burned up the wire. You'll get into a cycle where the coil blows the transistor, and then the blown transistor fries the new coil. Replace both at once. Also, if you have one, use a tip 102. It's more robust.

#11 1 year ago

I just finished checking tonight:

- Coil reads 4.3 ohms, I think that's good. Its diode is (was) installed properly: band on the orange wire side, matching all other coils of that type and PPB section.
- I replaced the 122 and 4401. Symptom (flashers and coil immediately lock, depending on relay activation) persists. They still read fine with a meter, matching others nearby.
- I metered the resistors (discrete and grid), all pass.
- I metered the 7408 at schematic 3J (red probe on pin 7, comp readings on other pins)... it's consistent on all pins

So I'm stumped. Could the LS273 upstream (at "5H") be causing the issue, and how would I test that? Looks like pins 12 and 13 are the I/O for this solenoid, if I read the schematic properly, but I'm not sure how to test that chip, comparing which pins to what, etc. Solenoid in question is #7

20180122_204322 (resized).jpg

#12 1 year ago

Replaced that 7408 since it's the only other thing I have on-hand.... as suspected, no improvement or change.

#13 1 year ago

OK. Turned on the game for some probing in attract mode... flashers on Q40 are locked during this time.

Probing the LS273: input pins blink consistently, output pins are low, across the schematic.

The 7408 I replaced seems to probe OK as well. Actually the first chip I used wouldn't give a signal for Pin8, so I thought I found my problem. The next chip I used, is OK: blanking pins high, others low.

But Q40 stays locked. If I unplug CN11 from the MPU or J1 from the PPB, it of course turns off and cools down.

So.... yeah. Stumped.

#14 1 year ago

Arrrrgh I hate it when this happens! Do pins require a ritual sacrifice? Or a subconscious prayer to the Ghost of Harry Williams?

So I was pretty well dejected after the previous post. Stared at that schematic until my eyes crossed inside out. And the worst of it is, I have plenty of games but it's been weeks since I played a single damn one of them! Too busy and distracted lately......well eff it. Why do I put myself through this if not to play them? I walked over to Old Chicago, turned it on, rolled it, felt better.

Walked back to TA and turned it on: still locked, duh, like anything would change. Probe the 7408 to make sure I didn't need to correct my earlier post, it's still toning out fine. Turn it off, think "well shit if it's not working I should pull that 7408 altogether and see what happens". Ah, all the flashers lock on... well that actually makes sense... good to know for future symptom reference. Which means that the output from the 7408 to Sol7 is truly effed somehow still then...

Put the 7408 back in and get ready to probe once more and... the flashers are off. Say what?! Huh. Start a game and... it works!

I then proceed to play it for 20 minutes without a single issue... YAY but WTF? You'd say "OH you reseated the chip, that means you didn't have it in properly the first time you blockhead" but I say bollocks, I tested all the pins and I *know* they were working, because I found one that wasn't previously. So what on earth changed? Not a damn thing essentially, except I finally tithed on another game then intentionally tried to break this one to show I meant business.

So I'll take it even though I hate "false resolutions"... but man this game is fun to play....

#15 1 year ago

I hate when things break or fix themselves for no obvious reason. My guess is that there's a loose solder joint somewhere. Glad it's working though!

#16 1 year ago
Quoted from CadillacMusic:

My guess is that there's a loose solder joint somewhere.

Ugh, don't say that I hate this Data East board: it's so thin and flimsy feeling, and every time you touch, move, or breathe nearby it, it creaks and pops and cracks like a sparkler. I can't imagine that means anything good for all the pins and traces and chips and whatnot! Just the act of inspecting it seemingly invites creak-crack-popping it worse...

...henceforth I shall endeavor not to touch it at all. If it ain't broke don't fix it! If it IS broke, well... do you feel lucky?

#17 1 year ago

That's good man. Thank you for posting the resolution. It will help someone in the future that has the same problem!

Promoted items from the Pinside Marketplace
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
From: $ 19.99
$ 24.00
1,600 (OBO)
Machine - For Sale
Richland, MI
From: $ 16.95
From: $ 19.50
Apparel - Unisex
ArcadeMade
$ 29.95
Gameroom - Decorations
ULEKstore
From: $ 65.00
Playfield - Toys/Add-ons
RGP Models
From: $ 44.95
Playfield - Toys/Add-ons
PinBoss Mods
$ 26.50
$ 29.95
Gameroom - Decorations
Pinball Photos
$ 36.99
Lighting - Interactive
Lee's Parts
$ 799.00
Flipper Parts
Mircoplayfields
$ 76.95
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 750.00
Flipper Parts
Mircoplayfields
$ 625.00
Flipper Parts
Mircoplayfields
$ 5,799.00
Pinball Machine
Operation Pinball
From: $ 42.00
Cabinet - Shooter Rods
ModFather Pinball Mods
$ 48.00
Cabinet - Other
ModFather Pinball Mods

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside