(Topic ID: 72482)

Data East Star Wars Club...Members & Fans Welcome.


By MustangPaul

5 years ago



Topic Stats

  • 3,229 posts
  • 291 Pinsiders participating
  • Latest reply 2 days ago by oradke
  • Topic is favorited by 138 Pinsiders

You

Linked Games

Topic Gallery

There have been 964 images uploaded to this topic. (View topic image gallery).

IMG_20191006_185623 (resized).jpg
IMG_20191006_185726 (resized).jpg
IMG_5187 (resized).jpeg
?? 2019-09-03 23 37 35 (resized).jpg
20190811_220658 (resized).jpg
20190811_220618 (resized).jpg
20190811_220607 (resized).jpg
20190811_220601 (resized).jpg
20190811_220548 (resized).jpg
20190810_153536 (resized).jpg
20190810_153524 (resized).jpg
20190810_153503 (resized).jpg
20190810_153443 (resized).jpg
20190810_153458 (resized).jpg
20190810_153450 (resized).jpg
20190810_153454 (resized).jpg

You're currently viewing posts by Pinsider cmv040.
Click here to go back to viewing the entire thread.

#3202 41 days ago

Great thread for SW DE. Picked up one myself along with a High speed not too long ago. Stripped the play field, new plastics, LEDs, had the ramp rewelded, fixed a few cooked molex connectors. Overall not in bad shape. Still need a better trans light but not too excited to pay $100. Also needs new coils as I cannot shoot the ramp with the right flipper.

Did run into one problem and I wanted to see if you guys have any thoughts.

Having trouble with the Star Wars letters and 3CPO mouth light. In demo mode the Star Wars letters light appropriately going back and forth but when playing the R always stays lit after I light a letter (see pic). Pulled the PCB were the lights are at, looks great, all the tracts intact, tried new bulbs, new sockets and no luck, even took the old wires out and re did them with new molex connector. Still the mouth won't light and R stays lit. Not sure next step but maybe something with the back box board where they connect? Any advice would be greatly appreciated.

IMG_5187 (resized).jpeg
#3204 41 days ago

The lamp board looks in great shape, tracts etc. I compared the wiring to another thread with pictures and mine looks exactly like that (i.e colored wires match up on the molex). I even refitted the wires in a new connector to see if that would help. Makes me think it is somewhere down the line.

#3206 41 days ago
Quoted from vec-tor:

Did you check the diodes on the lamp pcb?

Have not done this. Will take a look. Would that explain both problems?

#3209 39 days ago
Quoted from jgadzia:

what happens when you go into diagnostics and light each lamp individually?

So in diagnostics the mouth lights up appropriately. The letters switch back and forth appropriately but unfortunately when playing the R is still dimly lit. Interestingly one of the 10 million arrows also is dimly lit. Maybe something to do with the LEDs?

Promoted items from the Pinside Marketplace
$ 30.00
Electronics
Yorktown Parts and Equip
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
$ 9.99
Eproms
Matt's Basement Arcade
From: $ 40.00
Lighting - Interactive
Professor Pinball
5,495
Machine - For Sale
West Chicago, IL
4,500 (OBO)
Sale Pending!
Commack, NY
Wanted
Machine - Wanted
Ballston Spa, NY

You're currently viewing posts by Pinsider cmv040.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside