(Topic ID: 336655)

Data East / Sega MPU - Will not boot *SOLVED

By doompin

1 year ago



Topic Stats

  • 4 posts
  • 3 Pinsiders participating
  • Latest reply 12 months ago by Dan_Halen
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

View topic image gallery

IMG-1009 (resized).jpg
IMG-1007 (resized).PNG
IMG-1008 (resized).jpg
IMG-1011 (resized).jpg
IMG-1010 (resized).jpg
IMG-1002 (resized).jpg
IMG-1003 (resized).jpg
IMG-1004 (resized).jpg
IMG-1005 (resized).jpg
IMG-1006 (resized).jpg
IMG-1012 (resized).jpg
#1 1 year ago

I've poked around a bit on the forum and I know this issue has come up before. I recently acquired a Sega Batman Forever. The MPU had a myriad of issues. So I took the lazy route and ordered a new one as opposed to doing a bunch of board work. I just got the Rottendog MPU-004 I ordered and now I seem to be worse off than where I started.

Prior to any of the work I did today the game would boot but would not start a game. The DMD was flaky, would often come on at first but would be missing colors or just go blank after cycling through the first 3 screens. If I messed around with the ribbon cables, sometimes I could get it to behave as it should. The game would allow me to cycle through the diagnostic menus. Coils 1-8 (CN11) will not fire in test mode. This circuit clearly has issues - Fried resistor, prior TIP work in that same line (7) done, physical hole in the PIA (7408) up the same line.

Here is a run down of what I did and what I am experiencing:

1. Pulled the original board
2. Removed the game ROM from C5 on the original board and installed it in U27 on the new board.
3. Removed the CPU chip from the original board and installed it in CPU 3D on the new board.
*I triple checked that the notch on both chips where aligned with the notch on the socket for both.

4. Reconnected all molex connections.
*Triple checked that they were correct.

5. Cut the jumper at J4 as per the instructions from Rottendog (which are terrible and seem to differ depending on the source). Based on the the game having on ROM in U27 being 512kb. This seems to correspond with the instructions printed on the board and the instructions on the pinball life site (the printed instructions from Rottendog are a bit less clear "The vast majority of Data East / Sega Games came with a single 512k game ROM. This Game ROM is socketed and can be found in location C5on the original board. In this case, just move the Game ROM from the original MPU board to the new MPU0004 board. If you have one of the early Data East / Sega Games you will have two Game ROMs located in position C5 and B5. If this is the case move both game ROMs from the original board to the new MPU004 board. Also just as on the original, the jumper at J5 will need to be removed and the jumper at J4 will need to be installed".) ------ First of all these instructions must be from an older version of this board because the "jumpers" are already on the board in the form of 0 ohm resistors. It also mentions a DIP switch which is not present on this board. - The image of the jumpers that is on the Pinballlife website seemed more clear (image in this post), they also seemed to align with the info on pinwiki about Data East / Sega boards. "There is a simple rule of thumb for J4 and J5 jumper settings. This rule applies to all games which use either the version 2 or version 3 CPU board. If two game PROM chips are used at position 5B and 5C, jumper J4 must be installed and jumper J5 must be removed. This applies to games from Laser War to Batman.
If a single game PROM chip is used at position 5C, jumper J5 must be installed and jumper J4 must be removed. This applies to games from Star Trek 25th Anniversary to Batman Forever."

6. Powered up the machine.
- It has sound. Says the usual " suppose we flip for it" when powered on.
- GI comes on.
- PIA light flickers but does not go out.
- No display (though there is a brief flicker, so it seems there is power to it) - Game has a color DMD installed.
- Game will not boot.

7. Powered cycled, then opened and closed the coin door. No change.

8. I have an extra PPD board so I figured what the heck I'll swap that in and see if it makes a difference. - No change.

9. Pulled and reinstalled both the CPU chip and ROM, quadruple checked that they are installed properly. (Rotten dog instructions mentions "Keep your eye on the orientation of the microprocessor as the writing on the chip itself should be upside down after it is installed) - It is.

10. Powered on. - No change.
11. Powered off.
12. Checked connections again.
13. Removed and reinstalled both CPU and ROM chips.
14. Double checked the specs of the game ROM in the manual. - confirmed that it is a 512k chip.
13. Powered on - No change.
14. Reinstalled the original PPD board and powered on. - No change.
15. Walked away to write this post.

I feel like I'm missing something obvious. Or perhaps I damaged one of the chips while transferring them between boards. Or I just did something really stupid and installed something incorrectly despite being very careful. Did I cut the wrong jumper? Install the chips wrong? I'm at a loss. I've attached some images of both the original and rottendog boards. I'm regretting taking the path of least resistance (and most $) and wishing I would have just tried to fix the original board.

Any feedback is appreciated.

Thanks,
Jason
IMG-1002 (resized).jpgIMG-1002 (resized).jpgIMG-1003 (resized).jpgIMG-1003 (resized).jpgIMG-1004 (resized).jpgIMG-1004 (resized).jpgIMG-1005 (resized).jpgIMG-1005 (resized).jpgIMG-1006 (resized).jpgIMG-1006 (resized).jpgIMG-1007 (resized).PNGIMG-1007 (resized).PNGIMG-1008 (resized).jpgIMG-1008 (resized).jpgIMG-1009 (resized).jpgIMG-1009 (resized).jpgIMG-1010 (resized).jpgIMG-1010 (resized).jpgIMG-1011 (resized).jpgIMG-1011 (resized).jpgIMG-1012 (resized).jpgIMG-1012 (resized).jpg

#2 1 year ago

Well I figured it out. The 6821 PIA for the sound was installed wrong on the board from the factory....! It was upside down / backwords depending on how you look at it. Rottendog QC leaves something to be desired. I popped the chip out, flipped it around, and popped it back in and bingo, problem solved.

#3 1 year ago
Quoted from doompin:

Well I figured it out. The 6821 PIA for the sound was installed wrong on the board from the factory....! It was upside down / backwords depending on how you look at it. Rottendog QC leaves something to be desired. I popped the chip out, flipped it around, and popped it back in and bingo, problem solved.

Wow great eye this doesn't happen very often

2 months later
#4 12 months ago

This thread really saved me. In a client’s house, swapping the MPU on a GNR and hit this exact same thing. The instructions are awful about the jumpers and dip switches. I had a feeling of what to do, but finding this confirmed that the jumper needed to be cut.

Thanks!

Promoted items from Pinside Marketplace and Pinside Shops!
$ 32.00
Electronics
Yorktown Arcade Supply
 
From: $ 115.00
Cabinet - Shooter Rods
Super Skill Shot Shop
 
$ 27.95
Eproms
Pinballrom
 
$ 24.95
Lighting - Led
Mitchell Lighting
 
$ 17.95
Playfield - Toys/Add-ons
ULEKstore
 
$ 50.00
Cabinet - Armor And Blades
arcade-cabinets.com
 
$ 259.00
$ 50.00
Cabinet - Armor And Blades
arcade-cabinets.com
 
$ 17.00
Cabinet - Decals
Nordic Pinball Supply
 
$ 27.95
Eproms
Pinballrom
 
$ 29.95
Playfield - Toys/Add-ons
ULEKstore
 
$ 3.00
Tools
Nezzy's Pinball Prints
 
$ 27.95
$ 7,995.00
Pinball Machine
Pinball Alley
 
From: $ 17.99
Eproms
Matt's Basement Arcade
 
$ 18.95
Eproms
Pinballrom
 
Great pinball charity
Pinball Edu

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, subscribe to Pinside+!


This page was printed from and we tried optimising it for printing. Some page elements may have been deliberately hidden.

Scan the QR code on the left to jump to the URL this document was printed from.