New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 276593)

Data East LW3 blows circuit breaker


By martymart

49 days ago



Topic Stats

  • 3 posts
  • 2 Pinsiders participating
  • Latest reply 49 days ago by martymart
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

One image has been uploaded to this topic. (View topic image gallery).

961FDAB4-E786-43CC-A3C6-6C95A14DED19 (resized).jpeg

#1 49 days ago

I have just picked up a LW3. It had a power supply that was in need of repair and it did not start when I got it home. I replaced the power supply board with a working xpin board I had as spare and replace burnt connectors. When I turned the machine on it tripped the circuit breaker. I reset the circuit breaker and turned the LW3 machine back on and it worked. The next day I went through the same process with the same results.

Is this something to worry about and what should I be looking at. I did notice at times the bottom of the DMD did look a bit strange so not sure if there is something going on with the DMD / high voltage or if that was a seperate issue. I will post a photo of the DMD shortly.

961FDAB4-E786-43CC-A3C6-6C95A14DED19 (resized).jpeg
#2 49 days ago

I wonder if the fuse in your panel is AFCI or GFCI - high inrush of current on cold startup could be the culprit.

I've since replaced AFCI outlets to microwave above stove and refrigerator, problems of the breakers tripping solved for me.

I know these games only use 8amps or so, maybe 10amps on a cold startup - is anything else plugged/wired to the same breaker as the LAH?

#3 49 days ago
Quoted from P1nhead:

I wonder if the fuse in your panel is AFCI or GFCI - high inrush of current on cold startup could be the culprit.
I've since replaced AFCI outlets to microwave above stove and refrigerator, problems of the breakers tripping solved for me.
I know these games only use 8amps or so, maybe 10amps on a cold startup - is anything else plugged/wired to the same breaker as the LAH?

I have just noticed that the breaker is 10amps for that circuit. I will try it on another circuit as they are all 16amps.

Promoted items from the Pinside Marketplace
$ 99.00
Playfield - Other
Arcade Upkeep
2,350 (Firm)
Machine - For Sale
South Bound Brook, NJ
From: $ 369.95
Boards
PinSound
$ 17.50
Playfield - Plastics
Pinball Haus
From: $ 40.00
Lighting - Interactive
Professor Pinball
$ 27.00
Electronics
Yorktown Arcade Supply
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
€ 95.00
Lighting - Led
FlipperLED
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
$ 35.00
Cabinet - Other
Arcade Upkeep
2,200 (OBO)
Machine - For Sale
Charlton, MA
From: $ 99.99
Cabinet - Other
Lighted Pinball Mods
From: $ 18.00
Apparel - Men
Pinside Shop

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside