(Topic ID: 210434)

Cyclone Rottendog display


By schulzfarm

1 year ago



Topic Stats

  • 6 posts
  • 4 Pinsiders participating
  • Latest reply 1 year ago by Oldschool77
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

One image has been uploaded to this topic. (View topic image gallery).

pinball (resized).jpg

#1 1 year ago

I just replaced my old plasma display with a Rottendog LED display and while the display looks great, the upper two displays are illuminating commas where they should not be. I have powered down and reseated the connections with no joy. Anyone else had this issue?
Thanks in advance

pinball (resized).jpg

#2 1 year ago

Just installed the blue rottendog display in Cyclone. It didn’t have the commas

#3 1 year ago

I did noice that when I first installed the display I was having segment issues but it was a bad ribbon cable causing the problem

#4 1 year ago

I got some great support from Jim at Rottendog, he said to check the ribbon for possible corrosion, I cleaned the ribbon plug with some contact cleaner, reseated it a few times and now all is working fine.

#5 1 year ago

Glad you got it figured out. Now go enjoy a few games on the best pre-dmd game ever made

#6 1 year ago

Those ribbon cables are a beotch. I'm to the point that i buy a new one when i shop out system 11s now.

Promoted items from the Pinside Marketplace
$ 50.00
Trade
Machine - For Trade
Evansville, IN
2,300
Machine - For Sale
Rochester, NY
2,500 (Firm)
Machine - For Sale
Los Angeles, CA
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
$ 99.00
Gameroom - Decorations
Pinball Sales
$ 29.99
Cabinet - Sound/Speakers
Lighted Pinball Mods
From: $ 16.95
$ 36.99
Eproms
Matt's Basement Arcade
$ 20.00
Electronics
Yorktown Parts and Equip

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside