(Topic ID: 43642)

CV Neon Troubleshooting EDIT: FIXED IT! :)

By NJGecko

9 years ago


Topic Heartbeat

Topic Stats

  • 57 posts
  • 17 Pinsiders participating
  • Latest reply 1 year ago by Chosen_S
  • Topic is favorited by 5 Pinsiders

You

Linked Games

Topic Gallery

View topic image gallery

2013-03-17_19.01.46.jpg
2013-03-17_08.32.02.jpg
Rocky_&_Bullwinkle.jpg
2013-03-17_08.13.55.jpg

There are 57 posts in this topic. You are on page 2 of 2.
#51 6 years ago

I know this is a really old thread, but can you guys take a look here too?

I need a little help getting my neon going too, and I'm not sure my U3 is the same as the one here

https://pinside.com/pinball/forum/topic/cirqus-voltaire-neon-a-little-help-please#post-2714503

5 years later
#52 1 year ago

My Cirqus also has a neon (led) issue. I have no power at the molex in test mode. Could someone post closeup pix of all their power driver board connections?

I believe my opto's are plugged into j139 and there is a zconnector on my colorDMD which I believe should be feeding 12v to the neon.

But, i can't find connectivity with a resistance meter to any of the yellow/grey wires in the back box from the grey/yellow on the neon connector.

I'm hoping it's just a bad wire but I want to make sure I'm looking at the right wire.

#53 1 year ago
Quoted from The_Pump_House:

My Cirqus also has a neon issue. I have no power at the molex in test mode. Currently there is nothing connected to J139. Could some post closeup pix of all their power driver board connections?

For the neon to work, you need J139 plugged in for the 12V and J110 plugged in for the ground control. Beyond that, common problems that keep the neon from working is no 12V, a bad U3 (ULN2803) or bad neon transformer.

#54 1 year ago

Just as an idea, i have this mod. Its full LED and runs without converter or high voltage. It's from pedretti...works great.

#55 1 year ago
Quoted from schudel5:

For the neon to work, you need J139 plugged in for the 12V and J110 plugged in for the ground control. Beyond that, common problems that keep the neon from working is no 12V, a bad U3 (ULN2803) or bad neon transformer.

Then I have a bad wire

#56 1 year ago
Quoted from The_Pump_House:

Then I have a bad wire

Check J139 pin #2 on the driver board for 12V. If you have 12V there and nothing at the other end where it plugs into the neon transformer, then probably a bad wire.

#57 1 year ago
Quoted from JagDaniels:

Just as an idea, i have this mod. Its full LED and runs without converter or high voltage. It's from pedretti...works great.

I hope that works better than it looks on the video, it almost looks like there’s malfunction going on there. Also looks like a massive flasher !

Promoted items from the Pinside Marketplace
From: $ 12.99
Eproms
Matt's Basement Arcade
$ 45.00
Playfield - Toys/Add-ons
Just 3D Mods
$ 79.99
Cabinet - Shooter Rods
Lighted Pinball Mods
$ 59.99
Cabinet - Shooter Rods
Pinball Shark
$ 69.00
Playfield - Protection
The MOD Couple
From: $ 22.00
Apparel - Men
Pinside Shop
$ 27.50
There are 57 posts in this topic. You are on page 2 of 2.

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, become a Pinside+ member!