(Topic ID: 264892)

Creature troubleshooting help?

By Forester

2 years ago

Topic Heartbeat

Topic Stats

  • 25 posts
  • 6 Pinsiders participating
  • Latest reply 2 years ago by Forester
  • No one calls this topic a favorite


Linked Games

Topic Gallery

View topic image gallery

IMG_4493 (resized).jpg
IMG_4463 (resized).jpg
IMG_4464 (resized).jpg
FDC44E3C-FAE3-4F68-845F-5B47F2F9379B (resized).jpeg
IMG_4403 (resized).jpg
IMG_4402 (resized).jpg
IMG_4308 (resized).jpg
IMG_4264 (resized).jpg
InkedIMG_4242 (1)_LI (resized).jpg

You're currently viewing posts by Pinsider Forester.
Click here to go back to viewing the entire thread.

#1 2 years ago

Hey everyone-

As a public school teacher who now suddenly has extra time on his hands, I've finally jumped in to fixing a few odds and ends on my Creature from the Black Lagoon. The two big (unrelated) issues I'm having right now:

1) The left flipper is not holding. A quick tap of the flipper button and flipper works as usual, but hold the button and flipper flips quickly and stays in the down position. Right flipper performs as usual.

Test results at startup: Check switch 64, check switch 65, F1 R Flipper EOS, F3 L Flipper EOS.

So far I have cleaned the optos on both sides and pulled and checked the fuses on the Fliptronic II board. Fuses were fine, clean optos made no difference (although they were filthy).

What should I look at next? Any way to adjust the EOS on one side? Get a new one?

2) Sadly, my Mike D mod is no longer working. My guess is overheating caused whatever is going on. The monitor is fine - I connected it to another HDMI source and it works. I tried connecting the HDMI out on the Raspberry Pi to another TV and got nothing.

Pulled the flashdrive to check what was on it (never done that before) and it appears to be unformatted. I don't have a micro SD reader, so I haven't checked what's on it yet. What what on the flashdrive originally? Did the micro SD get wiped out? Has anyone else had issues with this mod getting too hot?

There are lights on both the Raspberry Pi board and the custom Mike D board underneath it. After startup, there are lots of different lights that light up on the "fuel gauge" on the side of the Mike D board, so I'm hoping it's not cooked.

Any help troubleshooting would be greatly appreciated!

#4 2 years ago


If you could email the Mike D instructions, that would be amazing! However, the thumb drive plugged into my Raspberry Pi has nothing on it. I'm gonna need help with those files as well. PM me and I can get you my email.

Have you had any issues with this mod overheating or with the power source? In the past, if I left the game on for more than an hour, the Mike D mod would get squirrely - sometimes glitching out, sometimes shifting to only red graphics. Machine has been not plugged in for a year, and now that I've got it in it's new location and I want to play it, the mod doesn't work at all.

Thanks for your offer to help!

#5 2 years ago
Quoted from LTG:

64 & 65, check the switch matrix in your manual. Might need adjusting or the wire color for the "6" might have a broken wire at 63 or 67.
EOS - look your EOS wires over, a broken wire can kill both of them if it came off.
Flipper- check the hold winding for a cold solder joint at the coil lug, broken wire, or a crack or break in the thin wire from the coil winding to the coil lug.
LTG : )

Such an easy fix for the flipper hold issue once I read this message and took the time to look over the left flipper coil. My soldering iron and a bit of solder and the flipper holds again.

One problem solved! Of course as I played it and checked it out after re-attaching the lead, I found other issues I'll need help solving...

InkedIMG_4242 (1)_LI (resized).jpg
#6 2 years ago

My update-

I re-soldered a loose connection on the ramp switch and both the 64 & 65 switch errors went away. Reinstalled the switch, realized it was backwards, re-reinstalled it. Works fine.

I checked the EOS on both side. Re-soldered a janky looking connection, but I am still getting EOS errors in the test report. What's my next troubleshooting step? Should I put in new EOS?

drummermike and That_Pin_Dude have been incredible helpful in getting me what I need to re-create the image on the SD card in the Mike D mod, RPi. I'm working on that now and will see how it goes this evening.

However - here's the next issue I could use help with. This image shows how far the outhole kicker sits in normal play action. When a ball drains, the machine is not recognizing it at first. The outhole kicker arm or end seems like it sits in the way. Eventually the machine will kick the ball over to where it needs to be, but something is not right and it also slows down play. Any suggestions?

IMG_4264 (resized).jpg
#8 2 years ago
Quoted from LTG:

Clean the mechanism. Figure out what it is binding on. Things like that.

No. Fix the problem. New EOS won't do that. From the EOS switches you have a break in wiring from them to the fliptronics board. Run the wires down. If both left and right report errors, then start with a common wire to both, it breaks or comes off, both don't work.
LTG : )

Well LTG - as usual, you were right. I pulled out the outhole kicker, thoroughly cleaned it and it now works. Thank you for the clear, common sense advice. It was binding on pinball gunk. Every once in a while I find a reminder that this machine is over 25 years old.

I've checked the EOS switches and the soldering at both ends is clean, no loose wires. I can't see any breaks in the wires, but I can see the common orange wire. It looks like a solid connection back the the Fliptronics board, but the voltmeter was out in the garage and I was feeling lazy, so checking for continuity is tomorrow's project.

Cleaned kicker pic below...

IMG_4308 (resized).jpg
1 week later
#9 2 years ago

Need some help troubleshooting CFTBL left flipper-

I'm stumped and could use some guidance. My left flipper hold has been acting weird for a while: won't hold, intermittent hold. Orange/blue wire to coil was loose, soldered it back on. Hold was still intermittent, but worked most of the time. Last night it stopped holding at all. Broke out the multimeter and there is no voltage to the lug on the left (in first photo) - the orange/blue wire. Other two lugs (and entire right flipper) has 73V. There is continuity on all wires back to Fliptronic board - but no diodes on the left flipper coil! The right side has diodes, the service manual diagram says there should be diodes on bot, but there are no diodes on left coil (see pics). What gives?

And what should I troubleshoot next to figure out why there is no hold on this side? The optos have been cleaned and appear to work fine. EOS switches are working fine. Fuses on Fliptronic are good. From left to right looking at the back of the left flipper coil, lug 1 (furthest left) =orange/blue for holding, lug 2 (middle) =Blue/grey for regular flipper power, lug 3 (left, towards right flipper coil) = grey/yellow (power from Fliptronic board?).

Suggestions on what to do next?

IMG_4402 (resized).jpgIMG_4403 (resized).jpg
#10 2 years ago

Tested resistance across the coil lugs. Lug 1 to 2 = 4.2 ohms. Lug 1 to 3 = nothing. Seems like a bad coil.

#13 2 years ago
Quoted from pintechev:

And diodes for WPC games are on the boards, not the coils. Doesn't hurt to have them on the coils, but it's not needed.

pintechev Thanks for clearing that up and confirming I need a new flipper coil!

#14 2 years ago

Thanks to That_Pin_Dude snd drummermike - my Mike D mod is back up and running again!

FDC44E3C-FAE3-4F68-845F-5B47F2F9379B (resized).jpeg
#18 2 years ago
Quoted from LTG:

Any three lug coil does. Two lug coils don't, the diode is on the driver board.
LTG : )

LTG Is your guess that this was a sloppy previous coil replacement? Any reason why someone would leave diodes off? And what is the downside to not having them on there - putting the fliptronic board at risk?

New flipper coils (resistance on the right coil was off) and flipper rebuild kit are on the way.

2 weeks later
#21 2 years ago

Could use some more troubleshooting help! I purchased new flipper assemblies from Pinball Life and need some help dialing in the left assembly (so far the only one I have installed). The left flipper is not quite as smooth or loose in action as the right one when moved by hand, but it's not like is sticking against anything. It also doesn't move up to the hold position from the test menu (unless helped by hand). It flips and holds as normal during play, although it sometimes gets stuck in the up position. Turned the game off during one of these times and it's mechanical, although during play when it happens it returns to down position if the other flipper is flipped (my guess is that it's the vibration that does it).

I spaced the bottom of the flipper off of the bushing with a piece of credit card (see 2nd pic) and there is space between the pawl and the bushing underneath (other pic). Flipper is returning to correct end position, EOS is reading correctly (and is new, came with assembly), there is some up/down movement of pawl but it's not wildly loose, I used the new spring included with the assembly, I've already cleaned the opto...what else am I missing?

Clearly this is some rookie mistake I'm making since I've never worked on the flippers before and I'd like to figure out how to set it up correctly before I tackle the right side. Thanks for the help!

IMG_4463 (resized).jpgIMG_4464 (resized).jpg
#24 2 years ago

I put a dial caliper on the new plastic bushing and the old one and they are the same. Not the best pic, but this shows both flippers from the playfield perspective - the one I worked on and the other one that I haven't started on yet seem to sit at a similar height off the playfield.

IMG_4493 (resized).jpg
#25 2 years ago
Quoted from LTG:

Flipper test - that is how the hold part of the test works.
I'd remove the plunger, and be sure it moves freely, no binding or anything. Coil sleeve doesn't have burs or anything ?
Reassemble. When you use your spacer gauge, make sure the whole plunger looks to be moving in a straight line. Not too high or too low.
Then check that the pawl isn't hooking on the end of the EOS leaf blade.
And look over the bracket holding the coil, and coil stop. Straight up and down ? Not misformed and leaning in or out, left or right ?

Looks okay. It's a close up. Look how big the star post is.
LTG : )

As always, great suggestions. During the flipper hold test on the right side (the side I haven't worked on yet), the flipper moves up and then holds in position for a second or so. During the hold test on the left side, I can hear the coil energize, but there is enough friction in the mechanism or the flipper is binding on something so that it will not lift up on it's own. It will go up and stay up during the test mode, but only if I bump it by hand

Since it was a new assembly, I didn't take it all apart and inspect everything. The bracket holding the coil on the left flipper assembly I installed was shipped with enough space that the coil could move back and forth against the brackets. Neither the new right assembly was like this nor was the original left assembly, so I slightly bent the back bracket so that the coil was snug against both brackets. I'l check to make sure that this isn't causing a misalignment.

This is what I'll be checking out on my lunch break...

Promoted items from the Pinside Marketplace
From: $ 18.00
Apparel - Men
Pinside Shop
Machine - For Sale
Norwalk, OH
$ 10.00
Playfield - Toys/Add-ons
UpKick Pinball
$ 29.95
$ 259.99
Cabinet - Toppers
Lighted Pinball Mods
$ 5.00
Playfield - Toys/Add-ons
UpKick Pinball
$ 229.99
Lighting - Other
Lighted Pinball Mods

You're currently viewing posts by Pinsider Forester.
Click here to go back to viewing the entire thread.


Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, become a Pinside+ member!