(Topic ID: 150545)

Creature Optos not working


By yyyyyikes

3 years ago



Topic Stats

  • 11 posts
  • 4 Pinsiders participating
  • Latest reply 2 years ago by MeNaCeFiRe
  • Topic is favorited by 1 Pinsider

You

Linked Games

#1 3 years ago

Hi All,

During a game a few days back the optos on the right-lane and lower-right
kick outs stopped working. They don't work in test mode and therefore the ball
is not getting kicked out back into play.

Is this a common, simple to fix problem?

Thanks in advance.

#2 3 years ago

When my optos were not working the coils kept firing thinking there was a ball blocking. This was from the fuse for the 12 volt supply being blown.

So the optos are all connected to a small board under the playfield and that send the signal to the switch matrix so maybe that's unplugged. Ramp Opto board or something. Follow the wires and reseat and connectors.

J1 on the opto board and on the MPU J206 and J208 where is goes into the switch matrix.

That's a good start. If not the LM339 microchip on the opto board might be blown. Did you do any work under the playfield?

#3 3 years ago

Check the switch matrix in Test mode and look for switches that are closed that shouldn't be. I had some trouble with bad optos this week and it turns out one of my stand ups was stuck on, messing up the switch matrix. I bent it back into place and now everything is working fine.

#4 3 years ago

thanks taxman,

yep - i pretty much thought the same thing as you. i reseated everything i could think of - and yes i had just the day before rebuilt the flippers so have done some work underneath, moving the board next to them - which i think controls the motors for the creature. everything was working though....but....who knows?

there's a board (when raised) bottom left of the playfield which has a led which doesn't light - i haven't yet checked the manual, but is this an opto controller? and should the led be on?

i tried tracing the wires but couldn't find where they were going - i'll have another look tomorrow.
also i'll check the connectors you're talking about tomorrow. need to sleep on it.

#5 3 years ago

well....i repeated what i did originally (i.e. wobbling around the connectors) and guess what?
works now.

cheers all.

#6 3 years ago

You should probably re-flow the solder on the header pins of that board. And also make sure the wires are pressed in tight in the connector.

#7 3 years ago

ok so, cheers taxman...
after a few plays the same thing has happened and no amount of wiggling nor wobbling is helping this time.

do you think it is just the J1 connector? i don't have a spare board from other machines to test with.

#8 3 years ago

Most likely. I think there is an LED on the board that should be lit when it is powered. Did you notice if it was when it was working?

Anyway. The other connectors go off to the optos themselves. So if they are all out I would think the board is not getting power or ground. It is a very easy task to remove. Pop off a few connectors and usually 3 or 4 screws holding to the playfield. 5 minutes.

Hopefully you or someone is comfortable with a soldering iron. As long as it is on the bench re-flow the solder on all of the header pins. Easy task and low risk as long as you don't keep the soldering iron on them so long it lifts the traces. You won't be heating any delicate components.

Take a quick read on soldering tips or watch some youtube videos. It is a good skill to have. One trick with the old solder is to ad a little new solder to help the old stuff melt quicker.

But look at the connector also. The wire can come loose. Take a small flat head jewelers screw driver, like you would use for repairing glasses, and make sure they are seated tight.

Edit: I just took a quick look at the schematics online and I do not see and LED on the board to let you know it is working. If I think about it I can try to check mine when I get home.

#9 3 years ago

yes, you're right - there's no led on the opto board.
i'll have a go at this, i've got a few other boards to solder (bigger, more expensive ones)
which i've been putting off for ages. only done one before and that worked out ok so...

thanks again

1 year later
#10 2 years ago

Did you ever get this fixed? I re-flowed the solder on the board and I am dealing with the same issue. The biggest difference is if I unplug both optos from the board and just plug in one at a time i'll get a "blip" on the switch matrix test menu but it does not stay on. If I plug in both optos nothing happens.

Promoted items from the Pinside Marketplace
$ 135.00
Lighting - Led
LED OCD
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
$ 279.95
Lighting - Led
Pin Stadium Pinball LEDs
$ 109.99
Lighting - Led
Lighted Pinball Mods

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside