(Topic ID: 237376)

Creature from the black lagoon (CFTBL) sound issue


By dwightheinink

11 months ago



Topic Stats

  • 3 posts
  • 2 Pinsiders participating
  • Latest reply 11 months ago by dwightheinink
  • No one calls this topic a favorite

You

Linked Games

#1 11 months ago

Hi everyone, I've replaced capacitor c24 and c25 from the sound board. Unfortunately the sound has died completely. I've checked the polarity, fuses, ribbon cables. Is their someone who could help me out?

Kind regards,

Dwight

#2 11 months ago

Did the through hole plating on the capacitor leads get ripped out when the caps were replaced?

http://www.pinwiki.com/wiki/images/f/fd/DCSCapThroughHoleBungled.jpg

That is unfortunately a common issue and I've had to repair that on many boards.

When that happens you end up just soldering the cap to the bottom of the board but the traces on the component side are open.

To fix you will need to pull the caps back out, solder a small L shaped piece of wire to the top foil and let it drop through the hole.

It could be something else but if the caps were replaced I'd check this first.

#3 11 months ago

Thank you for your reaction robotworkshop. Yes one was ripped out. but I already fixed it with a small wire. Could their be a other possibility that could cause this kind of trouble?

Promoted items from the Pinside Marketplace
From: $ 233.10
From: $ 129.10
Cabinet - Sound/Speakers
PinWoofer

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside