New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 241658)

Controlled Lamps not Working after Replacing Rectifier Board


By Pinslot

1 year ago



Topic Stats

  • 24 posts
  • 6 Pinsiders participating
  • Latest reply 1 year ago by Pinslot
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

There have been 3 images uploaded to this topic. (View topic image gallery).

lady soldering (resized).jpg
996E6700-EE31-4510-9A5B-6A2DB6B11608 (resized).jpeg
IMG_6570 (resized).JPEG

#1 1 year ago

I replaced a very grotty looking rectifier board on my Bally Star Trek because after replacing most molex connectors at J1 - J3, I could not get Playfield GI to work consistently. I took great care to hook all wires up correctly. I'm getting 177 volts at Test Point 2, 12,6 v at TP3, 7,4 AC at TP4 and 43V at TP 5, but ZERO V at TP 1. The fuses are good.

I took the transformer out of the game and checked continuity from all wires I'd soldered [E1 to E12] to the transformer lugs from the front of the board. All tested good.

I stared a game: it boots fine and plays ok. In fact everything works except the controlled lamps on the playfield. (Which worked find before I installed the repro board).

Where should I look?

All hints appreciated.

#2 1 year ago

The 7.8vac comes into the rectifier board from the transformer at E9 and E10.The E9 side of the ac voltage goes through Fuse 1(10 amp) Then rectified at bridge 1 and output is 5.4vdc. Confirm continuity and correct voltages in those components and you should find the problem. There is a schematic on the IPDB website for Star Trek.

#3 1 year ago

Thanks so much. I’ll try that.

#4 1 year ago

First, I cut the zip ties on the wire bundles and really checked that the wires are going to the correct transformer lugs as stated in the schematics. They do.

I have three questions:

1. With ONLY J2 plugged in and game on I tested AC voltage at E9. This was only 4.6v. Is that within reasonable limits?

2. I also tested DV voltage at E10. Here I got 3.3 V. Again this seems to be very low. Too low?

3. I'm testing voltage at the test points with ONLY J2 connected. Do I need to connect J1 or J3 to get a reading at Test Point 1

All hints / advice / help appreciated.

IMG_6570 (resized).JPEG
#5 1 year ago

Did you change the wiring at the transformer when changing the board? Are you set up for 115 volts instead of 230 volts? Your voltages sound low.

#6 1 year ago

I only reconnected wiring to the rectifier board.

Is it conceivable that this board is not compatible with this game?

996E6700-EE31-4510-9A5B-6A2DB6B11608 (resized).jpeg
#7 1 year ago

I’m not sure about compatibility, but it looks like the few solder connections I see are not good solder joints.

#8 1 year ago

I am indeed not an expert at soldering. I have done some Google research and I see I have probably created some cold solder joints.

Should I disconnect wires and then resolder them correctly or heat up each soldered point and add a little more solder?

#9 1 year ago

You should just need to heat and add... please make sure to wear proper eye protection!

lady soldering (resized).jpg
#10 1 year ago
Quoted from Atari_Daze:

You should just need to heat and add... please make sure to wear proper eye protection! [quoted image]

And don't hold the iron by the tip...sheesh!

#11 1 year ago

At least she looked good doing so.

#12 1 year ago
Quoted from Brewchap:

At least she looked good doing so.

High pain tolerance!

#13 1 year ago

If I disconnect the wire at lug 13 and measure from lug 13 to ground, Will that tell me if I’m getting the correct AC voltage from that lug?

#14 1 year ago

I don't think so. You need to read between lug 13 and lug 14 on the transformer. You should read around 7.8 Volts AC. Reading between points E9 & E10 would measure the same thing.

It sounds like you are taking improper readings. Reading E9 to ground, or E10 to ground will not give a good reading. They do not have a connection to ground.

For your 5.4 volt DC reading, you should have only J2 plugged in, then power up, then read TP1 to ground - you should see the 5 volts.

#15 1 year ago

Thanks.

From lug 13 to 14 I get about 8v AC.

From Test Point 1 to ground I get no reading.

Perhaps the new rectifier board is the problem.

What should I test next?

#16 1 year ago

Measure the voltage at the bridge rectifier ac inputs. It should be the 8 VAC. Next, measure the DC volts across the bridge. Should be the five volts.

Is the transformer assembly screwed back in place in the head?

Just a question: is the ground braid from the cabinet connected to the ground braid in the head?

#17 1 year ago

Thanks!

I Put red probe on + leg of BR and black probe on - . Got 6 VDC.

Got 8.2 VAC across the other two legs.

Transformer assembly is not screwed in.

The ground braid on the head is firmly connected to the head.

The mystery is: why no DC at Test Point 1...???

#18 1 year ago

I can’t see the schematic for your replacement board, but since you know the rectifier is good, you will have to physically trace from the rectifier positive output to TP1. You may have a break or TP1 on the new board is not the 5 volt test point.

#19 1 year ago

Thanks.

„you will have to physically trace from the rectifier positive output to TP1.“

This I am trying to do. It‘s very difficult as you can‘t see most of the traces on this board. The circuit isn‘t interrupted from + of the BR to R2. I can‘t work out where it goes from the other end of R2.

#20 1 year ago

Did you verify TP1 on your board is the 5 volt test point? Do you have a copy of the schematic?

#21 1 year ago

TP1 is definitely the 5v test point. I have no schematic, but a fellow pinhead took a good look at a photo of the board on the vendor‘s website. There are also traces going from the + leg of the BR to J1 and Test Point 1 on the front side of the board, so he recommended desoldering and then resoldering that leg, which I will do.

#22 1 year ago

Yay! Problem solved.

A smarter man than I suggested the break in continuity was between the + of BR1 and the traces on the top of the board. I reflowed the solder there (also on the back) and I got 6VDC at TP1. I hooked up J1 and J3 and the playfield lamps work. In fact everything works Many thanks for all the useful hints.

My learnings:

Completely remove the transformer from the cab head to connect a new rectifier board.
Buy a proper board holder.
Label the wires. Some of those shades of green and blue look awfully similar.
Although this generation of pins is very well documented, I have to accept my limitations. I'm not an electrician and sometimes you should ask for help sooner.
Don't rule out an unlikely solution: in this case that a new repro-board had a break in continuity.

And the final learning: as there are no local pin-technicians where I live, I am going to only buy Bally EEs in future in order to build up my own expertise and not get on your nerves so much.

Thanks again

#23 1 year ago

Glad to see you got it going. I would let the manufacturer or the seller know about the break in continuity on this board in case they are having issues with production/QA. There may be others with the same issue and not realize what the problem is.

#24 1 year ago

That‘s a good idea. Will do.

Promoted items from the Pinside Marketplace
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
1,100
Machine - For Sale
Bedford, VA
$ 76.95
Cabinet - Shooter Rods
Super Skill Shot Shop

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside