(Topic ID: 244800)

Control Motor Issue


By tnarv

1 year ago



Topic Stats

  • 2 posts
  • 1 Pinsider participating
  • Latest reply 1 year ago by tnarv
  • No one calls this topic a favorite

You

Linked Games

#1 1 year ago

Hello gentlemen. I acquired a Bally Dixieland Bingo Pinball a while ago and when I power it up the Control Unit Motor gets very hot. It seems like it's trying to run both directions at once. I turned the fan blade to see what parts move and which one's don't when power is applied to it. Was wondering if I have a motor problem or mechanical one. I put credits on the Credit Register, turned it off and back on and all the credits were removed so I assume the control motor has rotated. Was wondering if the Control Unit assembly possibly needs maintenance. I saw from previous posts that the assembly shaft is under heavy spring tension. I'm new to these machines and have little knowledge of their operation. There are times I turn on the game and I hear the Control Motor assembly turning and other times I just hear a loud hum and the Control motor is extremely hot and NOT turning. I really don't want to try to obtain a motor if I'm unsure and really don't know where I can obtain one. Hope I'm not too vague with my description of the problem. Any help would be greatly appreciated.

#2 1 year ago

OK. Made some progress. Control Unit Motor turns out to be OK. I can add credits and sometimes the game will start by itself and deliver balls to the shooter lane normally. Gives me the first ball, sensor at top of shooter lane senses the first ball being shot, then the next etc. At first I could actually play all the balls and the game would end. When the ball entered ANY hole the light for that hole flashes but doesn't stay on(not sure if that's normal or not). Now I start a game and the first ball is deliverd to the shooter lane but the game never ends and it keeps delivering balls, hole lights don't flash anymore and I have an endless game with no scoring. Will have to investigate some switch contacts somewhere but not sure where to start. Any help at this point would help trememdously as, at least I can get the game to show some signs of life. Thanks guys for any help you can give.

Promoted items from the Pinside Marketplace
From: $ 18.00
Apparel - Men
Pinside Shop
$ 109.95
Cabinet - Sound/Speakers
Pinball Pro
$ 5.00
Electronics
Docent Electronics
$ 74.00
Cabinet - Armor And Blades
Id Rather Play Pinball
$ 69.95
Playfield - Toys/Add-ons
pinballmod
$ 69.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 5,599.00
Pinball Machine
Operation Pinball
$ 74.00
Cabinet - Armor And Blades
Id Rather Play Pinball
$ 66.95
Cabinet - Shooter Rods
Super Skill Shot Shop
From: $ 9.99
Eproms
Matt's Basement Arcade
$ 76.95
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 69.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 2.00
Playfield - Decals
Doc's Pinball Shop
From: $ 42.00
Cabinet - Shooter Rods
ModFather Pinball Mods
From: $ 99.99
$ 5.00
$ 48.00
Cabinet - Other
ModFather Pinball Mods
$ 4.49
Electronics
Yorktown Arcade Supply
$ 30.00
$ 15.00
Playfield - Decals
Metal-Mods
$ 14.95
Playfield - Toys/Add-ons
ULEKstore

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside