Common Issues with Red and Ted's Road show?

By dbpbandit

3 years ago


  • 56 posts
  • 31 Pinsiders participating
  • Latest reply 10 months ago by chrisnack
  • Topic is favorited by 9 Pinsiders


Search this topic for posts matching certain words or written by a specific Pinsider. Or both!

Linked Games

Topic Gallery

There have been 5 images uploaded to this topic. (View topic image gallery).


There are 56 posts in topic. You are on page 2 of 2.
#51 1 year ago

OK, so here's the issue I've been having with my RS. Hope you guys can help.

When making the right ramp shot, the ball is (not always but sometimes) supposed to get diverted so that it comes down the left side feeding the mini flipper for the blast zone shot. But what happens with mine is that the ball does not make it all the way around the back rather, it bounces off the center of the plastic at the fork, then rolls back down the wire form to the right flipper.
As a temporary fix and to avoid further damage to the plastic where the ball hits, I've enabled the diverter for all right ramp shots. This works ok, but I'd really like to solve this problem.
My initial thought was that the left flipper coil was not strong enough to send the ball all the way back and around, but I don't think that's the case as it's the correct sized coil and it seems pretty robust. Also, from what I can tell, the ramp is installed correctly--nothing seemingly missing or out of place.
I really don't know what is causing this. Is anyone else experiencing this issue or have any idea why might be causing it?

Thanks in advance.


#52 1 year ago

I know on mine the spring on the diverter being weak caused issues like that, but it was when the diverter was closed to send the ball back up the wireform, the force from the ball cause the gate to open slightly and the ball lost all its momentum and bounced off the fork

#53 1 year ago

That makes sense, but seems it's not quite what's going on with my diverter issue.

8 months later
#54 10 months ago

Great thread all.

Red's eyes aren't centering, otherwise everything else is working. Is that a broken spring or something else? They stay left or right, and don't go back to center. Ted's fully functional.

1 week later
#55 10 months ago

Does anyone have any good theories about why my Road Show might cut in and out with its sound? It's not a volume or distortion issue. The sound will be off entirely for portions of a game and on, sounding perfect, for other portions of a game. Draining one ball and advancing to the next will often trigger the sound to blip back on, as will other solenoids firing to launch the ball back into play. It's got an updated sound ROM in it and the Pinball Pro speakers and sub. I'm stumped... Thanks!

#56 10 months ago

Sounds like something is loose, have you tried shaking the machine when it cuts out?

Promoted items from the Pinside Marketplace
From: $ 14.95
Machine - For Sale
Fairfield, CT
$ 27.99
Lighting - Interactive
Lee's Parts
$ 9.95
From: $ 369.95
$ 85.00
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 35.00
Ewe22 Security PIC Chips
There are 56 posts in topic. You are on page 2 of 2.


Note: This is an old thread. The last post was made to it 304 days ago. Resurrecting old threads is not necessarily a bad thing, if you think the topic is still relevant and/or your post is beneficial to it (e.g. following up on something). In other cases, it might be better to create a new topic.

Wanna join the discussion? Sign up for a Pinside account, or log in if you already have an account.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside