(Topic ID: 210135)

Coils and flashers not working

By Bax1

2 years ago

Topic Stats

  • 34 posts
  • 4 Pinsiders participating
  • Latest reply 1 year ago by Bax1
  • Topic is favorited by 1 Pinsider


#1 2 years ago

I’ve been working on this r&b for a long time on and off. So here is the back story. Bought this with battery damage and had the board cleaned up. Worked just on the tester but then in the game funky stuff happened. When you go into flasher test the lion and playfield vuk fire. No flashers. So found a nice cpu with no damage that wouldn’t boot. Found that it was a broken trace and everything shows working on my buddies tester. So now I’m the game I am getting the same issue. I have replaced the relay on the pbb board and nothing. Made sure all bridge rectifiers are good. Have 38v at the diode above relay on pbb. I have replaced the connectors for the coils that go from cpu to pbb. Made sure there is continuity between connectors. So here is what is not working. Flashers, outhole, trough eject, rocky insert, rhino insert, and knocker.

Advise on what to check is appreciated

#2 2 years ago

A couple suggestions. Check continuity from PPB relay K1 to the non banded side of D22 to J6 pin 9 to CPU CN12 pin 2 Black/Red wire. Q29 on the CPU drives relay K1 or in other words provides the ground that energizes K1. Q29 may be bad or have a bad solder joint. Check continuity with everything associated with Q29 and pre driver Q21. Test Q21 and Q29. I think you can ground Q29 to energize Relay K1 to confirm continuity in the circuit. Check fuse F6 on PPB and continuity with everything associated with F6. F6 connects to J6 pins 4&5 orange wires. That is where flasher power comes from. It seems as if K1 isn't being energized to send power to the flashers and the non working coils. Or it could be energized and not being DE energized when needed. It is a left right relay being turned on and off by the game program to send power to coils and flash lamps when needed.

#3 2 years ago

Mikat11. Thank you very much for the reply. Continuity checks out on all of the above. Pbb all has good continuity. Cpu has continuity and q29 and pre driver seem to be good in diode test. I may reflow solder but looks good. Black and red wire have continuity between the two boards.

#4 2 years ago

I have taken the cover off of the relay and in flasher mode I activate the relay with my hand and still nothing

#5 2 years ago

Ok I took a look at my Lethal Weapon. It has the exact same board set as R & B. I started a game and K1 energized and stayed energized. Is your game doing that? If not, that leads back to my thoughts about the relay not being activated. If it is being activated then we know that it is working correctly and you should now focus on why flashers and coils aren't getting power or the ground path has been lost.

#6 2 years ago

You hear the relay on the cpu click. Can’t tell if pbb is

#7 2 years ago

Shine a flashlight on it. You will be able to see the contacts move.

#8 2 years ago

Just fired it up and nothing

#9 2 years ago

Looks like the one on the cpu isn’t moving either

#10 2 years ago

I have 38v on both sides of the diode in front of relay on ppb

#11 2 years ago

Ok try this. While the game running in attract mode use a piece of wire and attach it to the metal ground plate that all the boards are screwed to. Then BRIEFLY touch the other end of the wire to the metal tab of Q29.If all is well the K1 relay will energize/click. This will confirm the ground path to K1 from Q29 is functioning.The relay coil needs to be grounded for it to work . This is where the CPU comes into play. It is possible that Q21 or Q29 test good but don't really work. Further upstream are a couple of 7408 chips and a 6821 PIA that drive the transistors in that row and may not be doing their job. I'm not sure how to check them for proper operation though. You may have to replace them if nothing else is resolving the problem. 38v on both sides of D22 in attract mode is correct. When you start a game the relay energizes and the non banded side of D22 drops to zero volts and the banded side remains at 38v.

#12 2 years ago

Get nothing grounding 29,39,40,4145,46 all the others I get coil fire. No relay switching either

#13 2 years ago

This may sound like a dumb question but is Cn 13 on the CPU board plugged in?

#14 2 years ago

Yes it’s plugged in

#15 2 years ago

How about J3 on the PPB

#16 2 years ago

Yup. It’s in.

#17 2 years ago

Kinda out of ideas to try at the moment. Seems to be a grounding problem knowing that there is 38v to the relay.

#18 2 years ago

I appreciate the help. I’ll do some checking on the grounds

#19 2 years ago

so I didn't start a game until this morning. the lion insert and playfield vuk fire a few times then stop. about 30 seconds later they fire three more times. I did check that diode by the relay and both sides still have 38v

#20 2 years ago

http://www.ipdb.org/search.pl?searchtype=quick You can find a very good copy of the R&B manual here. It has a back box wiring diagram and full schematics. Maybe it will give you some ideas to try and find the root of the problem.

#21 2 years ago

Thanks Mikat11. I will do some digging. any idea why I would have voltage on both sides of the diode when game is started?

#22 2 years ago

All coils behave in this manner. Flippers, pop bumpers vuk etc. The diode is connected to both ends of the coil winding. Applied voltage flows through one end of the coil wire to the other end of the coil wire. When one end is connected to ground the coiled wire creates a magnetic field. In this instance the Q 29 transistor circuit on the CPU board provides the ground path for the coil in relay K1. The diodes purpose is to prevent back-emf induced voltage from damaging the drive transister (Q29) when the magnetic field collapses. Think of the diode as a one way gate. Voltage can pass through the gate but not return back through the gate.

#23 2 years ago

So in attract mode getting 38v on both sides is ok. During a game the diode should only have volts on one side correct? With it having voltage on both sides during a game could that be an issue? Could that be why the relay is not activating or charging?

#24 2 years ago

In attract mode 38v on both sides of D22 is normal. When the relay energizes as it should in game play there will be 38v on one side of D22 only. The problem seems to be the coil winding in the relay is not being grounded/energized/clicks as it should be when a game is started. Focus on this issue first.

#25 2 years ago

Gotcha. Will report back with any findings. Thank you

3 weeks later
#26 2 years ago

So pulled the ppb board this morning and grounds on board have continuity. Connector to ppb for ground has continuity to cpu ground. Maybe pull cpu and do some continuity testing on grounds? Some coils fire and some don’t. Seems it’s a section that isn’t working. Had the cpu on a test rig and all checks out. I’m stumped

#27 2 years ago

Night bump

#28 2 years ago

So pulled cpu this morning and tested ground to transistors. All have continuity. Tested all transistors and all check out. I see that the coils that are not working are tied to different 7408 chips so all 3 shouldn’t be bad right? Where else can I start poking

#29 2 years ago

So just found a ground connector that had some corrosion and fixed that. Still same issues. So when game is started the 3 50v coils fire a couple times then fire again about 30 secs later. When those coils fire, the diode before the relay does drop to 0 for a sec when the 50v coils fire (non banded side of diode). So what else could I check?

4 months later
#30 2 years ago

Bax1, was this ever solved?

#31 2 years ago

not yet. I am doing a power supply rebuild and need to inspect under the game to make sure there are not shorted wires. I am hoping the power supply rebuild will cure it. A buddy of mine had some funky stuff like this going on and he put in a new power supply and all went away.

1 year later
#32 1 year ago

bax1 , Did you ever solve this? Mine just started doing the same thing. The when the flashers hit, the playfield vuk and Lion coil fire. But the outhole and trough kickers don't work.

1 week later
#33 1 year ago

For anyone else who stumbles across this post and has the same issue, mine turned out to be the power supply board. I didn't have enough voltage to trip the coil / flasher relay K1. I replaced the whole power supply board with a Xpin and everything fired right up.

#34 1 year ago

was surprised to see this thread back up. I did get it figured out. it was a ground wire that came off of the left ramp gate switch causing all of the issues. crazy how that can trigger such a long string of issues.

Promoted items from the Pinside Marketplace
From: $ 18.00
Apparel - Men
Pinside Shop
From: $ 9.99
From: $ 40.00
Lighting - Interactive
Professor Pinball
$ 12.50
Cabinet - Sound/Speakers
Gweem's Mods
$ 79.99
Cabinet - Armor And Blades
PinGraffix Pinside Shop
$ 30.00
Playfield - Other
Filament Printing
$ 35.00
Filament Printing
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 99.00
Playfield - Other
Arcade Upkeep
$ 35.00
Cabinet - Other
Arcade Upkeep
$ 14.95
Playfield - Toys/Add-ons
From: $ 20.00
Cabinet - Other
Rock Custom Pinball

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside