(Topic ID: 297062)

Close encounters: no displays, partially playable

By Dengo87

69 days ago



Topic Stats

  • 8 posts
  • 2 Pinsiders participating
  • Latest reply 58 days ago by Tuukka
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

View topic image gallery

DS AC coupling (resized).png
Output 8 Z29 (resized).png
Z27 (resized).png
TC2 Pin11 Clock Pulse (resized).PNG
TC1 Pin14 ON OFF (resized).png
bottom leg of crystal (resized).png
Top leg of crystal (resized).png
IMG_20210714_160915 (resized).jpg
IMG_20210714_160919 (resized).jpg

#1 69 days ago

Hello everyone,
I'm new to the forum and hope I can get some help with my "close encounters of the third kind" pinball machine. I want to restore it into it's original state (kinda in honor of my grandfather who recently passed away).
I'll try to be as thorough as possible. First time I booted close encounters nothing worked except the displays.
After opening the backbox the known issue of the leaked battery was clearly visible. I then changed the battery into an original (varta instead of data) and replaced a bunch of resistors, diodes and repinned almost everything of the MCU board. After that I put the MCU back, I was very happy as flippers, drop down, sounds, roto target all worked, everything seemed to work except the displays.

But now, the game seems to be stuck in some kind of game state... The moment I push the "ON" switch I can immediately control the flippers and basically start playing without putting in a coin. The drop targets don't reset and roto target also doesn't work. I think i've measured all possible voltages which are OK, all fuses are OK. I don't think the MCU is dead but just stuck in some kind of mode and it can't be reset. I believe it has something to do the with the reset circuit...

To summarize after pushing ON button:
- flippers work
- poppers work
- drop target and roto target doesn't work
- outhole doesn't "reset" the game
- All voltages are OK (MCU, PS, Display)
- Displays don't work

I hope I was a bit clear on the problem and hope someone can help me out.

I also made a quick vid and put it on youtube:

Thanks in advance!

IMG_20210714_160915 (resized).jpgIMG_20210714_160919 (resized).jpg
#2 68 days ago

Pop bumpers and flippers are not controlled by MPU. They work if game over relay under playfield is on. Looks like you have some random lamps on playfield lit, the game over relay is also controlled by the lamp driver so it is probably on also.

Since none of the controlled solenoids or displays work, the MPU is not running. I would first start by checking the reset circuitry on MPU board.

#3 64 days ago

Tuukka thanks for the reply!
Had to wait for my scope before I could decently measure something.
From the info I have (Pinrepair.com), after power up TC1 pin14 should drop to -12V and rapidly change to +5V.
As you can see below, this is happens... only it's -10.6V and +4.9V. So I'm guessing the reset circuit is ok, although the time is very short (87ms)
Do you have any idea how long it should be?

I also checked the clock circuit, although I'm getting pulses not sure if it's ok. The top leg of the crystal (big one, left side of the board) pulses (at 3.57MHz), but the bottom leg doesn't pulse (steady -0.3V). I checked TC1 pins 1-13 and have pulses on 1-9 and steady 5V on pins 10-13

@TC1 Pin14 Reset circuit (PB on/off):
TC1 Pin14 ON OFF (resized).png

@Top leg crystal
Top leg of crystal (resized).png

@Bottom leg crystal
bottom leg of crystal (resized).png

These are all measured at TC1, I'll try to measure at the chips directly. In the meantime any other ideas?

Edit: Game over relay is indeed active.

Thanks in advance!

#4 63 days ago

The reset looks OK, I dont remember how long the pulse should be, but think 87 ms is enough. Anyway I have seen some boards with bad capacitors C31 and C32 near the 4528 reset monostable Z2 causing the reset pulse to be missing or too short.

Also the clock seems to be OK. It is normal that you can't get signal from the other crystal leg. Your probe and scope load the circuit and it stops oscillating. To make sure that CPU is clocked, check test socket TC2 pin 11 for 198 kHz CPU clock.

7404 inverters Z27 and Z29 sometimes fail. With scope, it should be easy to check that all inverters are working.

#5 62 days ago

Tuukka ; I checked TC2 pin 11 and I'm having 198kHz CPU clock.

I also checked Z27 and Z29, but all outputs (2, 4, 6, 8, 10, 12, 14) are low... 5V is also present at pin 14 and following schematics this is connected to "adjustable parameter matrix".
Are this the small switches on top or what is this matrix?

Can I assume as all outputs are low, something is wrong with these two? I would think that because I changed the battery and a bunch of resistors. The problem would lie somewhere in this location. I'm starting to think I did some wrong repinning, although I changed pin per pin.

TC2 Pin11 Clock Pulse (resized).PNGZ27 (resized).png
#6 62 days ago

Yes the parameter matrix is the DIP switches. Z27 outputs should be pulsing if switches are ON. If all switches are OFF then the outputs will stay low. Check the input pins also. High at input should result in low at output, and vice versa.

But if your CPU is not running, it does not scan the switch matrix and the DS lines will not be pulsing. Check Z29.

#7 58 days ago

Tuukka I checked Z27 and Z29 again and compared input vs. output. States are inverted, but I'm not seeing any pulses (only some noise as you can see in the first pic (Z29 pin 8)... Can I assume CPU is not running? Which IC is the "main CPU" I havn't been able to figure that out yet.
Output 8 Z29 (resized).png

I do however measured DS1,DS2 and DS3 and I'm seeing some pulsing on top of the 5V DC (second pic but with AC coupling).

DS AC coupling (resized).png

#8 58 days ago

It does look like the CPU is not running, at least not the correct program.

The spider chips are:
U1 11660CF CPU
U2 10696 I/O for CMOS RAM control
U3 10696 I/O for lamps + dip switches
U4 A1753CE I/O+ROM solenoids
U5 A1752CF I/O+ROM switches
U6 10788PA display controller

U4 and U5 contain the program ROM, so might be good to check that all data and address lines are intact. The game PROM does not contain executable code, and the board will boot even without it.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside