(Topic ID: 1742)

Cleopatra kick hole problem


By Letter_K

8 years ago



Topic Stats

  • 3 posts
  • 2 Pinsiders participating
  • Latest reply 8 years ago by Letter_K
  • No one calls this topic a favorite

You

Linked Games

#1 8 years ago

Our Cleopatra's left kick hole works on start up, kicks after a ball is lost, and scores and moves the lights on the playfield like it is supposed to, but when the ball drops into the hole, nothing...

Anyone have any suggestions?

#2 8 years ago

Does it do the same sequence every time or is it random?
Look for loose or poor coil and switch connections, etc.
Check the harness pins and connections from the Driver PCB.
Check the Xistor that fires that coil.
Check the switch matrix connectors at the cpu pcb and maybe a possible leaky diode?

I had a similar issue with my Count-Down kick out hole at the top but it was random.
Turned out it was a flaky Driver Transistor.

#3 8 years ago

It works every time in the situations I detailed above. Only when the ball pushes down the switch does it not kick.

Promoted items from the Pinside Marketplace
$ 45.00
Gameroom - Decorations
Pinball Photos
$ 399.95
$ 55.00
Gameroom - Decorations
Pinball Photos
$ 45.00
Gameroom - Decorations
Pinball Photos
$ 49.00
€ 8.40
$ 209.99
Lighting - Led
PinballBulbs
$ 4.99
Playfield - Plastics
ULEKstore
$ 69.00
From: $ 99.99
Cabinet - Other
Lighted Pinball Mods
$ 27.99
Eproms
Matt's Basement Arcade
$ 69.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 369.00
Cabinet - Decals
Mircoplayfields
$ 48.00
Playfield - Toys/Add-ons
ModFather Pinball Mods

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside