(Topic ID: 351693)

Cleopatra few switches not working

By Redfivexw

18 days ago



Topic Stats

  • 2 posts
  • 1 Pinsider participating
  • Latest reply 18 days ago by Redfivexw
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

View topic image gallery

IMG_6667 (resized).jpeg
IMG_6667 (resized).jpeg

#1 18 days ago

Working on a Cleopatra. Got non working. Repinned all the connectors. Installed a new power supply, a new driver board and a used niwumpf board (sold as fully working). Everything is working except the switches at the top and sides (I believe these are the 10 pt switches ) and the switches on the slings activate the coil but don’t score (assuming they are supposed to). I checked the matrix and there are other things on this line that work. I also put a meter between the blu/wht connector(a1j7-13) and the actual switches and they come back good . Also the niwumpf shows no stuck switches. So, what am I missing?

IMG_6667 (resized).jpegIMG_6667 (resized).jpeg

IMG_6667 (resized).jpegIMG_6667 (resized).jpeg

#2 18 days ago

Problem solved. After reading for a while, and checking all the playfield switches again, found one that looked good on the top but was bent underneath. All set now!

Promoted items from the Pinside Marketplace
From: $ 12.99
Cabinet - Other
The Pinball Scientist
Other
$ 5.95
Playfield - Protection
The Pinball Scientist
Protection
From: $ 2.99
From: $ 110.00
Cabinet - Shooter Rods
Super Skill Shot Shop
Shooter rods
$ 4.00
Playfield - Decals
UpKick Pinball
Decals
$ 89.00
Electronics
That Old Pinball
Electronics
$ 7.50
Electronics
That Old Pinball
Electronics
From: $ 5.95
Playfield - Protection
The Pinball Scientist
Protection
Great pinball charity
Pinball Edu

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, subscribe to Pinside+!


This page was printed from https://pinside.com/pinball/forum/topic/cleopatra-few-switches-not-working- and we tried optimising it for printing. Some page elements may have been deliberately hidden.

Scan the QR code on the left to jump to the URL this document was printed from.