(Topic ID: 331505)

Chime coil plunger issue

By Budman

1 year ago



Topic Stats

  • 3 posts
  • 2 Pinsiders participating
  • Latest reply 1 year ago by Budman
  • Topic is favorited by 1 Pinsider

You

Linked Games

No games have been linked to this topic.

    Topic Gallery

    View topic image gallery

    Strange World 10s chime (resized).jpg
    #1 1 year ago

    Fully restored Strange World chime unit is acting up on me. The very first time one of the tens point sling gets hit and fires, the chime unit( smallest bar) rings normally. From then on, the metal plunger that strikes the bar is held up into the coil until I power off the game. With the game off, the plunger drops out and then easily goes in and out of the coil. Is there some sort of magnetization going on? Any help is appreciated. Thanks!

    #2 1 year ago

    Does the N/10 Point relay relax, and does the switch that drives the chime open?
    Strange World 10s chime (resized).jpgStrange World 10s chime (resized).jpg
    /Mark

    1 week later
    #3 1 year ago

    Got it working, thank you!
    It was simply a slightly loose switch stack that I didn’t notice at first inspection.
    My thanks to you, Clay Harrell and Ken Mattozzi.

    Reply

    Wanna join the discussion? Please sign in to reply to this topic.

    Hey there! Welcome to Pinside!

    Donate to Pinside

    Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, subscribe to Pinside+!


    This page was printed from and we tried optimising it for printing. Some page elements may have been deliberately hidden.

    Scan the QR code on the left to jump to the URL this document was printed from.