New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 2610)

check your WH2O's (G.I. related)


By NoVArcade

9 years ago



Topic Stats

  • 14 posts
  • 13 Pinsiders participating
  • Latest reply 8 years ago by PinballHelp
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

There have been 2 images uploaded to this topic. (View topic image gallery).

wh20gi2.jpg
wh2oGI1.jpg

You're currently viewing posts by Pinsider novarcade.
Click here to go back to viewing the entire thread.

#1 9 years ago

judremy, this might have been the culprit to your blown fuse. I've been chasing an intermittent high resistence reading to ground on the upper playfield GI circuit. I believe I've found the culprit, the fix was easy, but the location of this socket boggles my mind. There should have been a service bulletin for this. Put a piece of tape on the backside of the socket that might come in contact with the left side rail.

wh2oGI1.jpg wh20gi2.jpg

Promoted items from the Pinside Marketplace
$ 159.99
Lighting - Other
Lighted Pinball Mods
$ 79.99
Cabinet - Shooter Rods
Lighted Pinball Mods
From: $ 369.95
Boards
PinSound
From: $ 18.00
Apparel - Men
Pinside Shop

You're currently viewing posts by Pinsider novarcade.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside