(Topic ID: 79267)

CFTBL- Fans and members welcome!!!


By vilant

6 years ago



Topic Stats

  • 2,827 posts
  • 337 Pinsiders participating
  • Latest reply 5 days ago by Guy_with_a_Pin
  • Topic is favorited by 183 Pinsiders

You

Linked Games

Topic Gallery

There have been 915 images uploaded to this topic. (View topic image gallery).

IMG_1989 (1) (resized).jpg
IMG_1986 (1) (resized).jpg
IMG_1985 (1) (resized).jpg
IMG_0971 (2) (resized).jpg
0DCD5EA6-9DD0-4963-A60F-9D81C9BFA77A (resized).jpeg
41D2DE8E-845B-40E3-B312-7A9A84C4200C (resized).jpeg
pasted_image (resized).png
foto-sotto (resized).jpg
foto-sopra (resized).jpg
DSCF0287 (resized).JPG
DSCF0286 (resized).JPG
3F161ACD-0E15-4209-8C8F-966F89F5530E (resized).jpeg
9320CE4E-1ECA-446E-A3F3-4626DC8A5616 (resized).png
5D75CEDE-4114-440B-A94B-9A9D4DBDAF85 (resized).jpeg
20200123_210439_HDR.jpg
20200123_210413_HDR.jpg

There are 2827 posts in this topic. You are on page 16 of 57.
#751 3 years ago
Quoted from AlexSMendes:

Nah, I like the vintage poster look!

Then this is the one for you..

pinball_backglass_test_1A_sm_(resized).jpg

#753 3 years ago
Quoted from matt_adams:

I was just playing my Creature and I wondered if there was an adjustment anywhere to get video mode lit with fewer ramp shots. Am I missing something or is it fixed?

From the manual:
Adjustment A. 2 18 Right Ramp Increment Counter
This sets the number of shots required to light the next right ramp feature.
Settings: 2-5 (default 3)

I'd swear the default is 4, though...

#754 3 years ago
Quoted from mot:

From the manual:
Adjustment A. 2 18 Right Ramp Increment Counter
This sets the number of shots required to light the next right ramp feature.
Settings: 2-5 (default 3)
I'd swear the default is 4, though...

Fantastic, thank you, it was worded a bit posh for me to spot!

#755 3 years ago

Those alternate back glasses are very nice but how would they incorporate the sequential lights on the back panel behind the word "Creature"? Would probably have to remove them? Just curious.

#756 3 years ago

I want to change some lightbulbs in the backbox with colored leds. Has anyone done this and are there lights in the backbox which are dimmed?

#757 3 years ago
Quoted from PeterG:

I want to change some lightbulbs in the backbox with colored leds. Has anyone done this and are there lights in the backbox which are dimmed?

There are a ton of bulbs in the backbox that dim. In particular the lights behind the title. I had all LEDs in there for a bit and recently switched back to almost all incandescents even though I have all LEDs in the playfield. It just looks better IMO. I'll get a pic of my setup and send it over when I have a chance.

#758 3 years ago
Quoted from Wescobar:

There are a ton of bulbs in the backbox that dim. In particular the lights behind the title. I had all LEDs in there for a bit and recently switched back to almost all incandescents even though I have all LEDs in the playfield. It just looks better IMO. I'll get a pic of my setup and send it over when I have a chance.

I'd like to see that too!

#759 3 years ago
Quoted from Wescobar:

There are a ton of bulbs in the backbox that dim. In particular the lights behind the title. I had all LEDs in there for a bit and recently switched back to almost all incandescents even though I have all LEDs in the playfield. It just looks better IMO. I'll get a pic of my setup and send it over when I have a chance.

I love to see that, I saw this picture, looks like the creature bulbs are green, skin tones and explosion are pink?? They also did the title ones - as you said and I already saw in my machine - not an option because of dimming.

cftbl_backglass_(resized).jpg

#760 3 years ago

I've done a few spot color LEDs in my backglass to bring out some of the art (like green behind the creature), but mostly left incandescents in as well.

#761 3 years ago

Here is mine. I feel like less is more with this game in the backbox. I experimented with some pinkish bulbs to get the skin to look better but in the end I settled on what you see here.

https://vid.me/F3Ky

For the Creature I feel like the middle 2 bulbs for the body should not be green. It results in over saturation IMO and you lose some detail. I've got an Optix Maximus from Comet in the bottom right to bring out the hero. Just the one orange for the explosion.

Also replaced the light baffle as mine was basically turning to dust. You can get those from pinball life here: http://www.pinballlife.com/index.php?p=product&id=3901

#762 3 years ago
Quoted from Wescobar:

Here is mine. I feel like less is more with this game in the backbox. I experimented with some pinkish bulbs to get the skin to look better but in the end I settled on what you see here.
https://vid.me/F3Ky

I prefer incandescents, but I have to say what you did in the backbox looks very good.

#763 3 years ago

OK, I tested some led lights in the backbox, but have to agree, incandescents are way better. Unlike other backbox of games I own (most Stern with just a fluorescent beam) but also an IJ, this backbox is constantly dimming, flickering. It just comes to life. Great backbox. I got the leds out, tried some colored #555 but also that was not the best result. So I will keep it as is. As you see not all changes with future material are the best.....but they did not know that back in 1992

#764 3 years ago
Quoted from Wescobar:

The GI flickers during the start of multiball but other than that it's fine. Playfield inserts don't flicker noticeably unless you shoot a slow motion video. The backbox makes use of a lot of fade effects so I keep 90% incandescents there (it looks better too) The OCD boards aren't an option IMO because they apparently cause the ramp lights to stay on permanently

Which ramp specifically? I haven't noticed this.

#765 3 years ago

See attachment from the GI OCD site. Are you running GI OCD with no issues? I'd love to be wrong here. That disclaimer put me off ordered it.

image_(resized).jpeg

#766 3 years ago

Jgaltr56 has an LED OCD, which is fine. GI OCD does have the issue mentioned by Wescobar.

#767 3 years ago
Quoted from PeterG:

OK, I tested some led lights in the backbox, but have to agree, incandescents are way better. Unlike other backbox of games I own (most Stern with just a fluorescent beam) but also an IJ, this backbox is constantly dimming, flickering. It just comes to life. Great backbox. I got the leds out, tried some colored #555 but also that was not the best result. So I will keep it as is. As you see not all changes with future material are the best.....but they did not know that back in 1992

I came to the same conclusion, but I did cheat in two places. I put an orange led under the explosion/fire on the boat, and put a color changer under the Universal Monsters circular logo.

#768 3 years ago
Quoted from Billy16:

color changer under the Universal Monsters circular logo.

Nice idea!

#769 3 years ago

Funny, i just did the same thing with mine behind the logo. Nice effect I think.

#770 3 years ago

Just picked up a creech!
spent a few hours fixing some small problems but its working 100%.

Mine came with black legs and it sits taller then the STTNG beside it.
I think these are the wrong legs?

what have people done with the pops?
i wanna change them out any ideas?

#771 3 years ago
Quoted from urbanledge:

Just picked up a creech!
spent a few hours fixing some small problems but its working 100%.
Mine came with black legs and it sits taller then the STTNG beside it.
I think these are the wrong legs?
what have people done with the pops?
i wanna change them out any ideas?

Black legs are right. I changed I lanes and pop bumpers to teal

#772 3 years ago
Quoted from romulusx:

Black legs are right. I changed I lanes and pop bumpers to teal

oh any pics of the teal?
recently changed the red pops in my sttng to clear and they look great.

#773 3 years ago

Hi Guys,
I'm new here, many compliments for the forum!
CFTBL has been my first pinball machine and this thread has been really useful to me, even if mine isn't completed yet
See you around, bye!

#774 3 years ago
Quoted from urbanledge:

oh any pics of the teal?
recently changed the red pops in my sttng to clear and they look great.

See post #741 in this thread for my teal caps using EVO Britecaps. Not for everyone but I like em

#775 3 years ago
Quoted from urbanledge:

Mine came with black legs and it sits taller then the STTNG beside it.
I think these are the wrong legs?

May be SEGA legs....

#776 3 years ago
Quoted from AlexSMendes:

May be SEGA legs....

I was thinking the same.
Gives me an excuse to buy purple ones tho.

#777 3 years ago

Not the best pic but mine are also teal. I think they look great.

image_(resized).jpeg

#778 3 years ago

MikeD just posted in another thread he is going to discontinue his fantastic video mod. Major bummer!

Quoted from PinballMikeD:

Sorry guys, I've run into numerous supplier issues and my work life doesn't appear to be easing up anytime soon. Therefore, I've decide to discontinue this product. I hate leaving people hanging, but I just don't see a realistic time frame for making anymore of these MODs in the foreseeable future.

#779 3 years ago

Hey guys. I bought my creetch about 14 months ago. I completely restored it, including clearcoating the playfield, new cab, Mike D mod, etc etc etc. The only thing thats missing is the deluxe speaker panel. I've been hunting high and low for one, all to no avail. I've posted on PPS's website, imploring them to do another run, no success.

So................by an offshot, does anyone know of where to get one of these? I'm particularly looking for the Deluxe version, mirrored. Thanks in advance.

#780 3 years ago
Quoted from urbanledge:

oh any pics of the teal?
recently changed the red pops in my sttng to clear and they look great.

get-attachment-4.aspx_(resized).jpeg

#781 3 years ago
Quoted from urbanledge:

Mine came with black legs and it sits taller then the STTNG beside it.
I think these are the wrong legs?

I got my game NIB and it came with black legs.

#782 3 years ago
Quoted from Bigbossfan:

Hey guys. I bought my creetch about 14 months ago. I completely restored it, including clearcoating the playfield, new cab, Mike D mod, etc etc etc. The only thing thats missing is the deluxe speaker panel. I've been hunting high and low for one, all to no avail. I've posted on PPS's website, imploring them to do another run, no success.
So................by an offshot, does anyone know of where to get one of these? I'm particularly looking for the Deluxe version, mirrored. Thanks in advance.

Bought mine from Pin Tech in New Zealand, great piece of kit. It doesn't have the blinking tail lights but these always seemed OOT anyway, does have the sequential starlight and colour changing UFO though.

http://pintech.co.nz/creature-from-the-black-logoon-speaker-panel-mod-kit/

#783 3 years ago
Quoted from thewool:

Bought mine from Pin Tech in New Zealand, great piece of kit. It doesn't have the blinking tail lights but these always seemed OOT anyway, does have the sequential starlight and colour changing UFO though.
http://pintech.co.nz/creature-from-the-black-logoon-speaker-panel-mod-kit/

Out of stock.

#784 3 years ago
Quoted from Fifty:

Out of stock.

Yep, I'd contacted them a while ago. Bummer!

#785 3 years ago

Pintechs mod was $390.00 plus shipping. At that rate would anybody here be willing to sell you theirs for that kind of money? I know it gets me thinking.

#786 3 years ago

Ah sorry about that chaps. I thought they were making them up to order.

Don't forget the $ is NZD and not USD, I thought the panel was great value.

#787 3 years ago

Looking for some help... There's a random black wire hanging loose near the left flipper coil. It runs back up into the harness. Please can someone have a quick look to see if they have anything similar?

Wasn't sure if the flipper EOS has two wires on one connector?

Cheers all.

IMG_20160314_213617832_(resized).jpg

#788 3 years ago

Hello all, just a bump on my loose wire issue. Thanks in advance to anyone who can take a quick look to see if this is normal.

If it helps to identify it, it seems a bit thinner guage than the wires going to the coils.

#789 3 years ago
Quoted from thewool:

Hello all, just a bump on my loose wire issue. Thanks in advance to anyone who can take a quick look to see if this is normal.
If it helps to identify it, it seems a bit thinner guage than the wires going to the coils.

Just checked mine and there is no extra wire on mine and there is only one black wire on the EOS switch.

#790 3 years ago
Quoted from fiberdude120:

Just checked mine and there is no extra wire on mine and there is only one black wire on the EOS switch.

Thanks for that dude. Did you happen to notice a thin black wire in that bundle at all? I wonder where the feck it goes...

#791 3 years ago
Quoted from thewool:

Thanks for that dude. Did you happen to notice a thin black wire in that bundle at all? I wonder where the feck it goes...

I did not see any extra wire or thin wire in there. perhaps the previous owner put it there for some reason. Tomorrow I will take another look and get you a count of how many wires are in the harness by the flipper. I have to leave for work now.

#792 3 years ago
Quoted from fiberdude120:

I did not see any extra wire or thin wire in there. perhaps the previous owner put it there for some reason. Tomorrow I will take another look and get you a count of how many wires are in the harness by the flipper. I have to leave for work now.

If you could do that at some point it would be great!

It can't be anything serious as the machine runs fine, only thing is sometimes the end of ball count doesn't kick in but I think that's an issue with the trough switch.

#793 3 years ago

I'm new to the hobby so excuse any lack of terminology on my part. Is the wire pure black? After looking at mine it looks like it could be one of three wires:

Black with occasional blue dot: goes to left flipper assembly (EOS switch?)
Black with occasional brown stripe: goes to a light
Solid black: goes to unused (on my machine)

If it's solid black, my Creature doesn't use it. It goes to a connector that would plug into slot J1 on the small board on the left, but mine is not connected so I've never touched it. Picture below. Hope this helps.

20160317_130738_(resized).jpg

#794 3 years ago

After looking at my manual, it looks like that board controls the mirror motor for the hologram. I have the LCD mod, which explains why mine isn't connected since i don't need the mirror motor. Do you have the LCD mod installed?

#795 3 years ago

Just finished refurbing one for a customer - check is out
http://www.weirpinball.com/gallery/index.php/Currently-In-Work/Creature-from-the-Black-Lagoon---fix-and-customize?page=1

IMG_0834_(resized).JPG

IMG_0832_(resized).JPG

IMG_0830_(resized).JPG

IMG_0833_(resized).JPG

#796 3 years ago

They look so naked to me without the speaker panel tail light mod?

#797 3 years ago
Quoted from yzfguy:

They look so naked to me without the speaker panel tail light mod?

If it wasn't for MikeD's video mod, Jeff's speaker panel mod would be the best mod ever in pinball.

#798 3 years ago
Quoted from WeirPinball:

Just finished refurbing one for a customer - check is out
http://www.weirpinball.com/gallery/index.php/Currently-In-Work/Creature-from-the-Black-Lagoon---fix-and-customize?page=1

IMG_0834_(resized).JPGIMG_0832_(resized).JPGIMG_0830_(resized).JPGIMG_0833_(resized).JPG

Beautiful machine, love the green. Just wonder how that will hold on the metal when balls meet those parts

#799 3 years ago
Quoted from CryHavoc:

I'm new to the hobby so excuse any lack of terminology on my part. Is the wire pure black? After looking at mine it looks like it could be one of three wires:
Black with occasional blue dot: goes to left flipper assembly (EOS switch?)
Black with occasional brown stripe: goes to a light
Solid black: goes to unused (on my machine)
If it's solid black, my Creature doesn't use it. It goes to a connector that would plug into slot J1 on the small board on the left, but mine is not connected so I've never touched it. Picture below. Hope this helps.
20160317_130738_(resized).jpg

Cryhavoc I think you might have it there. On my Triac control board, on that connector I have a red and blue (green) but no black. I have the hologram installed and the mirror motor and wiggle motor working fine. Think I might add that black in though as it looks like it's supposed to be there. Thanks for looking!

#800 3 years ago

That looks awesome, nice work and like the green trim

Promoted items from the Pinside Marketplace
$ 29.99
Playfield - Toys/Add-ons
Full Tilt Pinball LEDs
$ 35.00
Cabinet - Other
Arcade Upkeep
There are 2827 posts in this topic. You are on page 16 of 57.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside