(Topic ID: 104406)

CFTBL DMD issue


By netminda

5 years ago



Topic Stats

  • 19 posts
  • 8 Pinsiders participating
  • Latest reply 5 years ago by netminda
  • Topic is favorited by 2 Pinsiders

You

Linked Games

#1 5 years ago

Hello-

I installed a color DMD in my CFTBL last evening. Everything went great, played a few games and shut it off. Just turned it back on earlier and it fired right up...then I heard a coil firing over and over again from the other room and now the color DMD is not working. Don't see any burned fuses and now when I power the game on I get one coil fire and the DMD is not working.

Any ideas on what may have happened and where to start troubleshooting this?

Thanks, Rob

#2 5 years ago

Check fuses by pulling them and using a meter, not by seeing. Sounds like you lost 12 volts.

LTG : )™

#3 5 years ago

Lloyd hit it. F116 at the upper left corner of the driver board.

In most cases, the fuse blows when the creature lamp kicks on during multiball and is usually due to having a higher than normal brightness bulb. There are some other threads here where it was resolved by changing the bulb.

It could also potentially be caused by a failing 12V bridge rectifier/capacitor. TP1 should read over 12.5V when the game is running. If it's lower than that you may need to replace the bridge and/or capacitor on your power driver board, or reflow the solder connections.

Randy

#4 5 years ago

Thanks for the quick responses. F116 didn't appear to be blown, but it was. Replaced it and the game is running perfectly. I have had zero issues with this game for 3+ years, but I recently added the MikeD hologram mod and the color DMD. I am thinking the extra 12v draw must be hitting a weak rectifier or capacitor. Probably time to send the power driver board to Clive for a going through.

Thanks, Rob

#5 5 years ago

If the fuse continues to blow, it could also just be the total load is too much for the circuit. You might want to consider adding an external power supply for the colorDMD and/or the hologram mod.

#6 5 years ago

Thanks for the response. Has anyone else run into this issue with their Creature's having too much load for the circuit while running the color DMD and the hologram mod? My Creature is all original, low play, HUO game, with matching boards that all look to be a great shape.

I don't have any other mods on my Creature...I see other Pinsiders with the backboard mod, playfield lighted cars, etc....plus the hologram mod and the color DMD. Do folks that have all of those mods have external power supplies or are they running everything off the PDB?

Both the hologram mod and color DMD are just incredible upgrades to my Creature. I need to pull the PD board out and do some testing and I am hoping it will just be a weak BR. If I need to run an external power supply I will, in order to keep both mods, but I am hoping it won't come to that.

Thanks again, Rob

#7 5 years ago

I have cree h with holo mod, colordmd, tail light mod, car with lights, and a light up monster bash creech figure....no alternate power supply and no problems.

2 weeks later
#8 5 years ago

Update...got my PD board back from Coin-Op Cauldron and my Creature is now running perfectly with the hologram mod and Color DMD. From the report from Coin-Op, my PD board definitely needed some work. Thanks for the responses!

Rob

#9 5 years ago

what specifically was wrong? i am having the same issue ( HUO no issues ) added the color dmd and backboard mod and poof f116 blew twice. 3a slow blow. I was thinking it was the bridge but saving tech time might help. glad it is fixed, I miss my breech, hopefully this week it gets fixed.

#10 5 years ago

I tested my PD board prior to shipping it out and I believe the main cause of the F116 fuse blowing was a bad 12v bridge rectifier. Here is all of the work Coin-Op did to my board and why I wanted to have it fully serviced vs. replacing just the one bad bridge rectifier...well worth the $88 +shipping:

Williams WPC-1 Power Driver board: C2 (100uf/50v/105c), C4 (100uf/16v), C5, C6, C7, C11 (4x 15000uf/25v/105c) and C8 (100uf/100v/105c) capacitors. BR1 and BR2 (2x GBPC3506) bridge rectifiers. U7 and U8 (2x 4n25) Opto-coupler ICs as standard. J101, J114, J115, J120 and J121 upgraded to high temperature headers. 0.33uf/35v military grade tantalum capacitor (C9). 10k 1/2 watt resistor (R260). LM323K 5 volt regulator (ST) plus sil-pad. +5 volt boost modification (12 ohms). Fuses removed and checked. Reflow. Board cleaned-up. Two-tier full functional testing.

#11 5 years ago

Well...I thought I had this problem solved, but even with my newly refreshed PD Board from Coin-Op Cauldron...the F116 fuse just blew again after my CFTBL ran in attract mode for about 30 minutes.

So I know it's not a PD board issue and it seems that with just the color DMD and hologram mod, it should not be too much load on the circuit. A few folks have chimed in on this thread that a running the same mods plus and are not having any F116 issues.

I have been running the hologram mod for several months and this issue just popped up when I installed the color DMD...could I have done something incorrect in the color DMD install to cause this issue?

Thanks, Rob

#12 5 years ago

I was running green undercab lighting, ColorDMD, MikeD TV mod (hologram replacement), and taillight speaker panel. Tried to add the new EL-wire snackbar mod and blew F116 and something else too. I replaced the F116 fuse and got the ColorDMD and undercab lighting working, but still have to find the second problem that has knocked out the flipper power and flashers and images to the MikeD TV (the TV itself is powered up but constantly displays NO SIGNAL). I think I need to find the remaining problem and fix that, but still need to add a 12-volt power source off the incoming 110 to drive some of my mods and take the strain off the game's 12-volt circuit.

#13 5 years ago
Quoted from netminda:

Well...I thought I had this problem solved, but even with my newly refreshed PD Board from Coin-Op Cauldron...the F116 fuse just blew again after my CFTBL ran in attract mode for about 30 minutes.
So I know it's not a PD board issue and it seems that with just the color DMD and hologram mod, it should not be too much load on the circuit. A few folks have chimed in on this thread that a running the same mods plus and are not having any F116 issues.
I have been running the hologram mod for several months and this issue just popped up when I installed the color DMD...could I have done something incorrect in the color DMD install to cause this issue?
Thanks, Rob

Bummer - i was hoping this solved it.

#14 5 years ago

I am kind of stumped at this point as to why the F116 fuse continues to blow. PD Board has been fully refreshed and just the hologram mod and the Color DMD shouldn't be enough to overload the 12v while in attract mode.

Not sure what else I can do other than remove the Color DMD until MikeD's Universal WPC Power Supply MOD is ready.

#15 5 years ago

i have my super tech Rich Corbo coming over on Friday - i will report back. I do not have the lcd mod

only the color dmd and the tail light mod.

mark

#16 5 years ago

I have had a similar problem after installing the MikeD lcd mod... but it was after I installed undercabinet flash strips. After removing them I have had no more problems but flippers seem a bit weaker. May need to send my board off for re-work also?

#17 5 years ago

There is only so much juice on the 12v line and all the add ons are going though the same juice box. Don't waste your money on beefing up the boards, get the external power supply and run them on their own from the 110. Electricity is like water, sometimes we live close to the source and get good flow, sometime we live far off and only get a dribble.

#18 5 years ago

Try a 4a SB fuse. You will not not cause any damage and I think it is drawing a bit above 3a and blowing it. I swapped mine and good thus far. My BR cnecked out ok.

#19 5 years ago

How is the larger fuse working out after a few days? Is that bad for the PDR and/or the game to up to fuse from 3a to 4a?

I ended up just taking out the ColorDMD and putting it in my WH2O. Since removing the ColorDMD from the CFTBL, I am not having any further F116 issues. I am just going to wait until MikeD's Universal WPC Power Supply MOD is available, then get another ColorDMD for my CFTBL.

The ColorDMD on the WH2O is fantastic...my plan was to just put it there until the CFTBL was ready for it, but now it looks like I am going to have to buy another one. So cool how easy it is to download the ROMs and swap between games.

Thanks, Rob

Promoted items from the Pinside Marketplace
Trade
Machine - For Trade
Danvers, MA
Wanted
Machine - Wanted
Bakersfield, CA
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
Wanted
Machine - Wanted
Van Alstyne, TX
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside