(Topic ID: 188827)

Certain coils fire on power-up

By zacaj

4 years ago



Topic Stats

  • 3 posts
  • 2 Pinsiders participating
  • Latest reply 4 years ago by Otaku
  • Topic is favorited by 1 Pinsider

You

Linked Games

#1 4 years ago

Working on a Prospector, and whenever I plug it in (power switch was bypassed), a few coils fire. The two that I've noticed are the right pop bumper (which is DC) and one of the chimes (AC). They're not locking on, they just pulse once and then are fine. I had the chimes off the unit to clean them and the chime plunger flew at least three feet in the air and landed on the ground outside the machine. Other two chimes and bumpers don't do a thing. Have no idea what could be causing it.... The playfield doesn't even have power at that point since the game over relay is off?

#2 4 years ago

Well of course I figure it out as soon as I post.. Bumper switch was closed, that chime was the one for 100 points. Noticed the 100pt relay was also sitting at 1 afterwards. Apparently the game over relay was unlatched every time for some reason, Lock relay would always latch it immediately, so only the quick pulse.

Note to self: don't adjust pop bumper switches when the playfield is upside down

#3 4 years ago

That'll do it! (and unless it's a different kind that does a physical latch/toggle sort of thing, a latch really only is a secondary coil so I'm not surprised it dies out with the game off)

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside