(Topic ID: 48888)

Centaur Club.....Members Only!

By vster23

8 years ago


Topic Heartbeat

Topic Stats

  • 1,435 posts
  • 238 Pinsiders participating
  • Latest reply 24 days ago by Dakine747
  • Topic is favorited by 96 Pinsiders

You

Linked Games

Topic Gallery

View topic image gallery

AEE0F422-72E5-4CE0-BF1C-60ED3EC0F2FF (resized).jpeg
FAE2643A-3E16-464E-BB49-A9C95D362685 (resized).jpeg
8F085A61-4E7F-4335-8FC9-BF834F854D9A (resized).jpeg
20211111_205237 (resized).jpg
075F52AA-C823-494E-A099-451058F29751 (resized).png
switch v2 (resized).jpg
centaur_champer_normal_ball (resized).jpg
Centaur playfield (resized).jpeg
Centaur (resized).jpeg
Centaur and Fathom (resized).jpeg
Card (resized).png
It's (resized).png
1373963-1_large (resized).jpg
56DE9561-21AB-4035-BF1D-E9DE4FA2F323 (resized).jpeg
C2E062AF-E18C-479C-8D5D-5CB63430F832 (resized).jpeg
46AAEC07-B17D-4D49-B720-961F757E341B (resized).jpeg

There are 1,435 posts in this topic. You are on page 20 of 29.
#951 2 years ago
Quoted from Fortytwo:

Good tip, ill give it a try!! I have seen some protector sets on eBay, any suggestions that others had success with?

I got mine from BAA/PPS, but they were in a laserific marked bag. The fit was too tight to the flipper (dragging on the rubber). So I got out the dremel and shaped it back until they were clear.

#952 2 years ago
Quoted from lordloss:

I bought a centaur playfield. It's missing the 5 bank drop target.... Anyone have a spare to sell!?
[quoted image]

Pics for reference of part I need

9989b68348ed34c8cb7302b7c2ae1cb5d1ab2ea5 (resized).jpgfa43362ba0ff770ae63a90793715d728e858b1aa (resized).jpg
#953 2 years ago
Quoted from lordloss:

Pics for reference of part I need
[quoted image][quoted image]

I’ve got two five drop banks from a night fever playfield. Appears to be a very similar design. This one has the coil on the opposite side but the parts can be swapped around.

image (resized).jpg
#954 2 years ago
Quoted from Fortytwo:

any suggestions that others had success with?

I used polycarbonate plastic... for the return lanes... put the OEMs on top... never had them break?
It was done many years ago.
Stern's Fight 2000 wanted one to drill two holes and add a metal guide rail just under the plastic.

#955 2 years ago
Quoted from vec-tor:

I used polycarbonate plastic... for the return lanes... put the OEMs on top... never had them break?
It was done many years ago.
Stern's Fight 2000 wanted one to drill two holes and add a metal guide rail just under the plastic.

Thanks. I had a F2K. And that change was actually a stern bulletin. Mine had it done already.

1 week later
#956 2 years ago

I see there have been some playfields printed in the past but didn't find any available for sale. Are these still around or do we know if they are printing more?

Thanks

Edit:
I saw the mirco was talking about running these, hopefully this happens soon!

#957 2 years ago
Quoted from ViperJelly:

I see there have been some playfields printed in the past but didn't find any available for sale. Are these still around or do we know if they are printing more?
Thanks
Edit:
I saw the mirco was talking about running these, hopefully this happens soon!

I sent a playfield to Mirco and I am trying to patiently wait for a new playfield.

#958 2 years ago
Quoted from ViperJelly:

I see there have been some playfields printed in the past but didn't find any available for sale. Are these still around or do we know if they are printing more?
Thanks
Edit:
I saw the mirco was talking about running these, hopefully this happens soon!

CPR did a run a of playfields some time ago however event those are hard to come by now. I just glad a have a NOS playfield onhand to put into mine whan I start restoring it.

#959 2 years ago

You just don't know if they will be run again. I don't remember if CPR did one or two runs. I recall turning down a Centaur for $650 because the playfield was trashed....otherwise in good condition. I bought quite a few playfields over the years from CPR and Kevin said the were going to do a "boutique" run of 17 Centaurs well after the first run. Believe he said it was for employee benefit. Anyway, he asked me if I wanted one.....Hell Yes. I've only got 2 playfields left...Centaur and Eight Ball Deluxe. The quality on both of these is extraordinary. But alas, I also have a Centaur to restore.

Check that Mirco Thread here on Pinside. Pretty sure the Centaur playfield has been lobbied to them. Look through and if you see it, chime in as well!

#960 2 years ago
Quoted from Freeplay40:

I don't remember if CPR did one or two runs.

They did two runs.

If you remember, the first run had a couple "special" playfields where they did a base white layer over the entire surface. The end result was a true black/white/red playfield with the most noticeable difference being a white shooter lane.

The second run was much shorter, maybe 30 playfields. I believe they were just using up extra stock of inserts on hand. I think they did a small run of Xenon at the same time. I bought a playfield from this run and asked Kevin if there was any possibility of getting another "special" playfield made. He said the only reason they made them in the first place was because the wood was ugly and they needed to paint it. They had no plans to make any more like that.

#961 2 years ago

Any one need a nos playfield send me pm

3D529102-8378-4199-9F3D-9898FBF3B455 (resized).jpegAA0F343E-53B1-465B-A18B-7FD10718AC5F (resized).png
#962 2 years ago

Re this post and the issue with the random strange sound that I'm still having an issue with https://pinside.com/pinball/forum/topic/centaur-clubmembers-only/page/15#post-3932337

Quick update is I now have ALL new boards including the parlor city pinball repro centaur say it again board and the Mypinballs @applejuice Squawk and Talk board and I have replaced multiple diodes and caps and connectors and I'm over it.

Just this week yet another Centaur owner posted on my local Aussie Arcade forum that he is having the same issue, and someone replied that it is sound #19 which seems to be an unused sound on the soundboard.

So that has me wondering would it be possible for someone to hack the sound rom and remove that unused sound so that myself and others who are struggling with this issue don't have to put up with this sound or the endless troubleshooting?

Is there anyone here that can do it or could you suggest anyone that I could ask? and then burn it to a rom that I can put in my new S&T soundboard?

#963 2 years ago

Can someone post a pics of J1 on the squawk and talk board? My new-to-me centaur has no sounds. My J1 looks pretty hacky. From the circuit diagram, I should see pins 16, 17, & 18 used, but I don't even seem to have wires for them. My J2s on squawk and talk and the say it again are pretty hacky too.

I wish there were wire colors in the diagram.

155546380341191888133021601648 (resized).jpg

IMG_20190416_221814555 (resized).jpg
#964 2 years ago

Both of those connections are correct from the factory.

The connection to the say it again board has the gel in the connectors for the gray wires.

2139D9FC-BC42-4668-8222-93E5A7053D76 (resized).jpeg

#965 2 years ago
Quoted from djblouw:

Both of those connections are correct from the factory.
The connection to the say it again board has the gel in the connectors for the gray wires.
[quoted image]

Wow, that's ugly. Thought it had to be a hack, especially with the circuit diagram. Thanks for the confirmation, I'll start by replacing the connectors with like connectors then.

#966 2 years ago

Broken speaker wire brought sound fx back.

Shitty pots are killing speech, if I press the speech one Centaur talks to me.

J3 is not actually used.

Still missing my background drone. Anyone had sound fx, speech, but no drone?

#967 2 years ago

You probably have no echo on the speech, along with no background sounds. Connectors, amps, caps, bad SAD chip, etc. Go figure.

#968 2 years ago
Quoted from EvanDickson:

Still missing my background drone. Anyone had sound fx, speech, but no drone?

Are all settings 16 and up set to 03 from the front door test button?

#969 2 years ago

Did anyone here snag the 1 owner Centaur from the Mr Pinball ads a few days ago?

#970 2 years ago
Quoted from dothedoo:

Are all settings 16 and up set to 03 from the front door test button?

This! I missed the line in the manual about setting #18, thank you! No rebuild required at this time.

#971 2 years ago
Quoted from pincoin:

Did anyone here snag the 1 owner Centaur from the Mr Pinball ads a few days ago?

It was a scam. He would not accept cash upon pick up. Had to wire it to his bank. If that's not a tip off, I don't know what is. Not happening here.

1 week later
#972 2 years ago

Let's talk flipper alignment. How do y'all have your flippers aligned? I just did a rebuild, but I feel like I'll never get enough power to get all the left drop targets, certainly not the left release.

IMG_20190428_093346034 (resized).jpg
#973 2 years ago
Quoted from EvanDickson:

Let's talk flipper alignment. How do y'all have your flippers aligned?

Bally playfields have a little divot near the tip of each flipper. You align the centre (pointiest) part of the flipper tip to the divot.

See the example on a Medusa below:
You have your flippers set up past the divots such that flipping to the left drop targets is weaker.

IMG_0013a (resized).jpg

#974 2 years ago
Quoted from Quench:

Bally playfields have a little divot near the tip of each flipper. You align the centre (pointiest) part of the flipper tip to the divot.
See the example on a Medusa below:
You have your flippers set up past the divots such that flipping to the left drop targets is weaker.
[quoted image]

I put mine a little above the divots, so the inlane guide makes a straight line with the flipper. I'm used to wpc where the divots hold a toothpick that the flipper rests on while you tighten it all up. Will adjust this evening, thanks!

1 week later
#975 2 years ago

Can someone do me a favor? What are the dimensions of the support bracket? Looking for a location to mount the brackets in my restore.

pasted_image (resized).png
#976 2 years ago
Quoted from TomDK:

Hello to the club !
I had a very very worn out playfield, the worm had also fun with it. With a friend of mine we rescreened it. Due to the bad wood we had to print all the playfield. Here is the result.
If you are located in Europe and need a rescreen , just contact me. Outside USA is too expensive in shipping.

[quoted image][quoted image][quoted image]

We have an other playfield rescreened and can offer it as "normal version" or black as on the pictures.
Just PM me if intrested.

BTW: The playfield on the pictures was shipped to the USA.

1 week later
#977 2 years ago

Am I hearing things, or is one of the call outs "screw off, you"?

#978 2 years ago
Quoted from EvanDickson:

Am I hearing things, or is one of the call outs "screw off, you"?

You're hearing things. It's "Slow, aren't you?" You might need to turn down the reverb a bit.

#979 2 years ago
Quoted from semicolin:

You're hearing things. It's "Slow, aren't you?" You might need to turn down the reverb a bit.

I know he says "slow, aren't you" and "bad move human" when you hit rollover switches that are already lit. But there's another callout that seems to happen late in high scoring games. Maybe it's custom? I'll have to set up something to record. I'm 99% sure my Centaur tells me "Screw... off... you" occasionally.

Edit: I got a recording and I hear one sometimes and the other sometimes. It's totally the "slow aren't you" callout, but I think it's kind of a pinball version of Yanni / Laurel, helped along by the sharp sounds of drop targets and jets messing with the overall audio properties.

#980 2 years ago

Yessss I'm in this club since last friday! Bought a fully working Centaur II and a lot of goodies for (what I think is) a really great price: 1250 euro.

Goodies include a spare backglass (both are in great shape), an extra (new) pastic set, Alltek boardset plus original boardset ánd a heap of spare boards.

I'm stoked!!

mp01 (resized).jpgmp02 (resized).jpgmp04 (resized).jpgmp05 (resized).jpgmp06 (resized).jpgbackglass (resized).jpgboards (resized).jpg
#981 2 years ago

I dream of getting a centaur II. Nice find!

#982 2 years ago

Hi guys, I'm looking for four *white* Chamber drop targets to get the playfield of my Centaur II up to factory specs. Anybody know where I can find these?

As some of you might know, Centaur II had the colours of the drop targets exchanged: White in the Chamber and black for the ORBS and 1234. I already snagged a black set of both the ORBS and 1234.

#983 2 years ago

Speaking of centaur II. I have an opportunity to buy one that looks decent for $2400. I see the average price is $2500 according to the site but there aren't many listings in the archives. Playfield wear looks minimal and new drop targets, LEDs, etc. I know this price isn't a steal but does it at least seem fair?

Thanks

#984 2 years ago
Quoted from Jappie:

Hi guys, I'm looking for four *white* Chamber drop targets to get the playfield of my Centaur II up to factory specs. Anybody know where I can find these?
As some of you might know, Centaur II had the colours of the drop targets exchanged: White in the Chamber and black for the ORBS and 1234. I already snagged a black set of both the ORBS and 1234.

Centaur #1 had black chamber and white O,R,B,S as well as white 1,2,3,4.
Centaur #2 had white chamber and black O,R,B,S as well as white 1,2,3,4.
However, sometime in late supplying of parts, Bally made black 1,2,3,4 targets that somehow
became the defaulting for Centaur #2.
Black 1,2,3,4, targets did not show up till about 1984 after the run of Centaur #2.
As far as targets go... try Pinball Resource.

#985 2 years ago
Quoted from vec-tor:

Centaur #1 had black chamber and white O,R,B,S as well as white 1,2,3,4.
Centaur #2 had white chamber and black O,R,B,S as well as white 1,2,3,4.
However, sometime in late supplying of parts, Bally made black 1,2,3,4 targets that somehow
became the defaulting for Centaur #2.
Black 1,2,3,4, targets did not show up till about 1984 after the run of Centaur #2.
As far as targets go... try Pinball Resource.

Cheers for that info! I guess the white 1234's stay in then

May I ask where you gained this wisdom? I found it very hard to find anything on this subject.

#986 2 years ago
Quoted from Jappie:

Cheers for that info! I guess the white 1234's stay in then
May I ask where you gained this wisdom? I found it very hard to find anything on this subject.


This kind of sums it up... for all the game operator that went to the game shows
back in the day... You got to see the newest releases from the top 4ish pinball manufactures.
Bally, Williams, Gottlieb, Stern... Game Plan... Zaccaria... "Pinball kits" from Europe...
1983 was a cutback year.
Bally would produce games that only had little development that would not cost much.
At that time there was still a demand for Eight Ball Deluxe Deluxe and Centaur... and
Bally had over produced cabinets to Rapid Fire So...the rest is history.

1 month later
#987 2 years ago

Has anyone ever had the "kick to playfield" for multi balls stop kicking? Mine stopped working 98% of the time (I can occasionally get it to kick once or twice in test, then it stops again).

So far I've:
- replaced connector J5, no change.
- replaced the coil, old one tests fine out of circuit.
- swapped transistor Q11 with Q12 to see if the problem would move but it didn't.
- Socketed and replaced U3

I've ordered replacement chips for U also but they haven't arrived yet, that's next on my list of things to do

Looking at the schematics, I think U2 is the last possible culprit. Wondering if there's anything else anyone thinks I should be looking at.

#988 2 years ago

do you have a logic probe? you can see if the transistor is indeed being pulsed by the chips.....sounds like a connection......will it kick reliably if you momentarily jump the transistor tab to ground? you could have a cold solder joint on the connector.....

#989 2 years ago

Be sure to look at the board that controls it under the playfield (solenoid expander). It's common for them to have cracked solder joints on the header pins.

The design of the circuit makes me nervous. You can't see the coil from the top of the playfield, so when the circuit fails you have no idea the coil is locked on until you see smoke rolling out of the plunger area. Since the mech is essentially a sideways flipper, I replaced the coil with a flipper coil, wired in an EOS switch and mounted it on the bracket. Now if the coil locks on it will only energize the "hold" circuit instead of melting the coil.

#990 2 years ago

Oh, I didn't look for cold solder, good idea, thanks, I'll do that next!

The good news is, it doesn't lock on, it just doesn't fire. I like the flipper eos idea.

#991 2 years ago

Most of the time this issue is caused by the micro switches not sensing all the balls in the trough under the playfield. If the actuator wires on any of the switches get bent out of shape just a bit, the coil won’t fire. In switch test, make sure all four switches are activating correctly.

#992 2 years ago

Another way to test this is to set dip switch 30 on the mpu to on. Power up and while in attract mode all five balls should kick on to the playfield every 15 minutes.

#993 2 years ago

Mine stopped working awhile back but it started working after replacing a broken “ORBS” drop target.

#994 2 years ago

- replaced connector J5, no change.
- replaced the coil, old one tests fine out of circuit.
- swapped transistor Q11 with Q12 to see if the problem would move but it didn't.
- Socketed and replaced U3

I've ordered replacement chips for U also but they haven't arrived yet, that's next on my list of things to do

Looking at the schematics, I think U2 is the last possible culprit. Wondering if there's anything else anyone thinks I should be looking at.

You have to go to switch test. All this other stuff was unnecessary.
Other than the Knocker, that solenoid circuit gets used less than any other. I doubt that any of the components are bad.

#995 2 years ago
Quoted from jj44114:

- replaced connector J5, no change.
- replaced the coil, old one tests fine out of circuit.
- swapped transistor Q11 with Q12 to see if the problem would move but it didn't.
- Socketed and replaced U3
I've ordered replacement chips for U also but they haven't arrived yet, that's next on my list of things to do
Looking at the schematics, I think U2 is the last possible culprit. Wondering if there's anything else anyone thinks I should be looking at.
You have to go to switch test. All this other stuff was unnecessary.
Other than the Knocker, that solenoid circuit gets used less than any other. I doubt that any of the components are bad.

Ran what exists for a switch test today. Tests ok, I think. I could be missing something though, the trough does have a weird setup and the switch test is pretty rudimentary. So both actual trough switches seem to register fine. I don't understand the setup fully, with two balls on switches and two not, and a third switch that no ball will ever reach (maybe the trough gets 5 balls in a different game on this MPU?).

Also reflowed solder at J5 pins. Still no go.

U2 is my last hope (save me Bono!).

#996 2 years ago

Test each switch with a ball. Does it close with a ball running past it? THE BALLS REACH ALL SWITHES AS THEY RUN BY THEM.
and all five balls do run through the trough on multiball. and if your lucky they keep running through multiball as they go into the outhole. There are 4 switches in the trough. Check them all.

#997 2 years ago
Quoted from jj44114:

Test each switch with a ball. Does it close with a ball running past it? THE BALLS REACH ALL SWITHES AS THE RUN BY THEM.

All 3 register with a ball touching them. I guess the first one counts balls on entry to the trough?

#998 2 years ago

I think there are 4. The last one is the most important. Its at the end of the trough where the balls eject to the playfield.

#999 2 years ago

It gets bent because when you lift the playfield all the balls push against that switch wire. And its hard to take the balls out first.

#1000 2 years ago

The one at the eject point works too. I don't think it could be a switch issue, since the kick out cool should fire every time in test regardless of switches. Hoping it's u2. Otherwise I guess I'm looking at a broken wire that doesn't look broken, somewhere between board and coil.

There are 1,435 posts in this topic. You are on page 20 of 29.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside