(Topic ID: 235244)

Captain Fantastic Cycling Through to Game Over

By ratfink903

2 years ago



Topic Stats

  • 4 posts
  • 3 Pinsiders participating
  • Latest reply 27 days ago by Enaud
  • No one calls this topic a favorite

You

Topic Gallery

View topic image gallery

Rollover_switch (resized).png

#1 2 years ago

People, I have a 1976 Captain Fantastic Commercial (not the home edition) but HUO. It was working 100% until I took the playfield out to svc- bulbs, clean, wax, rubbers etc... Upon reinstalling the playfield it now has issues. Press 1 player- you now cannot select more than 1..., Totals reset, Targets reset. Ball kicks out chute to launcher, then registers 1000 pts,(On the backboard only not on the playfield) (Ball still sitting waiting to be launched), resets undropped targets, registers 2nd ball on display, engages kickout, registers 1000 pts,(on the backboard only) resets undropped targets, registers 3rd ball, engages kickout, registers 1000 pts ( On both backboard & playfield) & moves to game over. If you then make the exit/outhole switch it resets the still undropped targets & clears the 1000pt light on playfield. The display on the backboard registers movement from ball 1 through to 2 & 3 & onto game over. This entire episode takes around 5 seconds. The flippers react within this small period. There is no jammed or stuck switch on the ball exit/return/Outhole, I thought maybe a stuck "tilt" mechanism, but all good there. I know I have bent a switch or blade somewhere on removal or replacement of playfield but cannot find for the life of me. Any help would be HUGLEY and gratefully appreciated. Cheers

#2 2 years ago
Quoted from ratfink903:

There is no jammed or stuck switch on the ball exit

Are you sure about that? Are the wires touching?

Game logic is saying that the reason for the kickout is because you drained the ball, even if you didn't. The fact that you are registering 1000 points tells me that game thinks you drained so it gave you 1000 in bonus and tried to kick out another ball.

I'd be inspecting that switch pretty hard, wires and all.

#3 2 years ago

Hey MEuRah, Thanks for the up, It is operational again, I'm not sure what it was, I'm pretty sure it wasn't the outhole switch because it would cycle to the next ball automatically without scoring any other points, ive checked manually & if ball goes through without scoring any points it just ejects back out again- you can only check this manually because the ball always scores SOMETHING on the playfield. - Trust me I checked that bad boy switch MULTIPLE times & even had a piece of cardboard in between blades on that switch & tilts...It had me buggered because after it went into game over mode you THEN made that switch to reset the 1000pt light - I think it would do it automatically if the switch was already made... Somewhere along the way I loaded up 4 players & when I went through the motions it was back to normal again.... Ghost in the machine. Thanks heaps for your response anyway & still no clearer to the issue but up & running anyway Rock on

2 years later
#4 27 days ago

Wow! I had the exact same issue happen to me tonight. (Of course while I was hosting our pinball league.)
The game would start, go to ball 1, ball 2, ball 3, game over.
After league I opened it up and found that the top rollover on the left orbit was stuck. I freed it up and all was good. So, that might have been your issue, too.
Hope this helps!

Rollover_switch (resized).png

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside