(Topic ID: 292031)

Capt Fantastic Bonus hesitation

By fb_rider

1 year ago


Topic Heartbeat

Topic Stats

  • 34 posts
  • 8 Pinsiders participating
  • Latest reply 1 year ago by fb_rider
  • Topic is favorited by 1 Pinsider

You

Topic Gallery

View topic image gallery

printed out schematics (resized).jpg
pasted_image (resized).png
switch 2 (resized).jpg
switch 1 (resized).jpg
20210422_084233 (1) (resized).jpg
20210422_084122 (1) (resized).jpg
pasted_image (resized).png
Capt. Fantastic Bonus Count (resized).jpg

You're currently viewing posts by Pinsider fb_rider.
Click here to go back to viewing the entire thread.

#1 1 year ago

After fixing a few minor issues, my Capt Fantastic is working "fantastic"!

But I have one remaining item that I wanted to get some advice on:
When collecting bonus at the end of each ball, there is some hesitation on racking up the bonus points. This is not 100% consistent, but seems to happen about every 3000 bonus points - it seems to hesitate for one bonus advance, then continues. It happens on regular or double bonus, but still seems to give you the correct total of bonus points.

I don't seem to remember this happening on other Capt Fantastic machines I've played, but wanted to run it by you all.

Thanks in advance for any advice!

#3 1 year ago

Thanks for the response, but this happens after the ball drains when collecting bonus. I think you are describing something that takes place during game play.

#6 1 year ago

Thanks for the info. I have a video but don't see a way to post it?

#9 1 year ago

They sounds exactly like what I'm experiencing. Let me see what I can do on the video

#11 1 year ago

Here's what I'm talking about

#16 1 year ago

Thanks for all the info everyone. Yes all of my normal scoring and reel reset is normal. It's only when collecting bonus after the ball drains.

I'm somewhat new to EM machines, but I've done pretty well getting everything else working correctly. Just to make sure, the scoring motor is the one in the bottom of the cabinet front left side, correct? There's also some type of bonus mechanism attached to the underside of the playfield on the middle right - could that be part of the issue as well?

#20 1 year ago

thanks again for all the help!

I'm probably not going to have time to look at this until late next week, but I will post an update once I've had a chance to check everything out!

#21 1 year ago

So I was able to spend about an hour working on it Thurs night. The count up/count down on the bonus wheel works great manually, but doesn't always fire when counting down in game play. The score motor seems to work well, but there definitely some slop in the joint that connects the gear box to the shaft with the cams. I watched, cleaned, and adjusted switches on cams 2 and 9 with no change. Double bonus seems to work pretty well, the issue seems to mostly be single bonus. I learned a lot but no fix yet.

What fires the count down solenoid?

#23 1 year ago

Thanks I'm going to need to take some time studying this when I get back in town next week.

1 week later
#27 1 year ago

Funny you wrote this post. This is exactly what I've been doing this morning with exactly the same results. I'm just having difficulty figuring out what holds that relay closed. On my machine it's coil number 13. It says bonus on the label on not sure what else - it's too hard to see.

Once one of us figure this out I think we'll both be able to fix our machines!

#28 1 year ago

ok IT's FIXED

Basically the switch on the bonus stepper unit that tells the relay to stay closed wasn't making good contact. To me, it looked like it was backwards at the "points" weren't facing each other. I took it apart, turned it around, and put it back together. Then adjusted it and everything works like it should. Maybe I didn't need to turn it around, but cleaning and adjusting it the way it was wasn't working. Here are before and after pics:

switch 1 (resized).jpgswitch 2 (resized).jpg
#29 1 year ago
Quoted from HowardR:

It looks like you have 2 issues. (1) The playfield Bonus indicator doesn't count down smoothly, and (2) The bonus doesn't award 1000s smoothly.
They're probably related but let's start with #1
Inspect and diagnose this circuit with Alligator clip jumper wires
http://www.planetimming.com/Pinball/troubleshooting/EM%20Troubleshooting.pdf
http://www.pinrepair.com/em/index3.htm#features
Example of a pinsider actually doing this https://pinside.com/pinball/forum/topic/red-baron-tech-question#post-5858156
[quoted image]

I'm sure this is a dumb question, but what are the numbers in the rectangles on the schematic, like 31-1, 52-4, etc?

#31 1 year ago

Perfect, thanks!

#32 1 year ago

I'm bound and determined to get a better perspective on these schematics. I printed them out and taped them together poster style

printed out schematics (resized).jpg
#34 1 year ago

Great info, thanks!

Put a bunch of games on the Capt. last night and everything works great!

Promoted items from the Pinside Marketplace
$ 22.50
$ 5.95
Playfield - Protection
The EM Scientist
From: $ 18.00
Apparel - Men
Pinside Shop
$ 25.00
Cabinet Parts
Flashinstinct
$ 125.00
Gameroom - Decorations
Maine Home Recreation

You're currently viewing posts by Pinsider fb_rider.
Click here to go back to viewing the entire thread.

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, become a Pinside+ member!