(Topic ID: 231631)

Calling all early Bally SS experts! EBD help needed!


By Dewey68

10 months ago



Topic Stats

  • 67 posts
  • 15 Pinsiders participating
  • Latest reply 10 days ago by frunch
  • Topic is favorited by 3 Pinsiders

You

Linked Games

Topic Gallery

There have been 17 images uploaded to this topic. (View topic image gallery).

Screenshot_20191006_084054_com.google.android.apps.docs(1).jpg
IMG_3125 (resized).jpg
1609691829.png
426191644.png
IMG_3121 (resized).jpg
IMG_3120 (resized).jpg
1966438453.png
Screenshot_20190905_093345_com.google.android.apps.docs(1).jpg
1966438453.png
2026343671.png
BookKeeping_CurrentCredits.jpg
It boots! (resized).jpg
IMG_2956 (resized).jpg
IMG_2955 (resized).jpg
IMG_2954 (resized).jpg
IMG_2953 (resized).jpg

You're currently viewing posts by Pinsider dewey68.
Click here to go back to viewing the entire thread.

#1 10 months ago

The goal for my weekend is to try to get an EBD LE working. I picked this up a while ago from a guy retiring and moving to Florida and am just now really working on it.

History since I've had it: When I got it home it was working mostly correctly, but in the process of fixing things under the playfield it has started failing. One of the first problems was that the sounds were off from what was happening in the game. I had a different thread on that. I recapped the squawk and talk board, but I don't think that was the issue, but since I had the parts, I figured I'd go ahead and do it. I think it was a wiring issue, and might still be the root cause. I also put new pins on the expanded light board for one connector and replaced the IDC connector with a new one with the turficon (sp?) connectors.

This game has an Alltek universal solenoid driver board in it. It also has a Rottendog rectifier board as well.

Currently, the game will boot up, and I can start a game with the start button, but only the left flippers will work. The EOS switches for the left flippers have a huge arc when activated. If I push the pop bumper skirts the Alltek board will light some red LED's for different solenoids. I think that indicates a short? I took voltage readings on the Alltek board, and noticed that the 12 volt feed is coming in at 17 volts.

Also, once the game has booted, if I pull up on the two large sets of wires running from the playfield up to the the boards, the game will reset. This is why I think I have a wiring problem.

All fuses on the rectifier board are good (it has blown a fuse in there before) and all fuses under the playfield test good (a couple of them have also blown after fixing switches, etc). I did find one strand of one of the wires going to the right flipper solenoid that was touching the adjacent lug on the solenoid.

The rotating LED's on the Alltek board are good, with the #19 LED being lit green.

So, should I tackle the 12 volt issue first?

#3 10 months ago

Thanks for the post Xenon75, I'll start with redoing those connectors and report back. I feel a hand cramp may be in my future....

#4 10 months ago

Turns out I don't have the right size for the smaller connectors, so I'll be placing another order with GPE. Can I reuse the plastic Molex connector housings going to the rectifiler board, and should I plan on replacing the connectors going between the playfield and the backbox pictured?

IMG_2758 (resized).jpg
#6 10 months ago
Quoted from cody_chunn:

Those big square ones I wouldn't worry about until there is solid proof it's bad. They are very dependable.

Thanks Cody, so basically just replace the connectors in the backbox if they haven't been already. I haven't had a pin this old so I thought maybe those go south too.

#9 10 months ago

I really appreciate the tips guys. Just got done polishing all the pin legs and reflowing connections on the MPU.

I found one bad MCR106-1 on one of the light boards. Besides those and some 2N5060's, can you recommend any other transistors that you commonly run into from pins from this era? Most of the ones I have on hand are for newer pins.

5 months later
#11 5 months ago

Reviving old thread. Finally got around to replacing all of the connectors on the CPU board, and the pin still won't boot. Looking for help on where to look next. Thanks!

#14 4 months ago
Quoted from Billc479:

Did you replace the pins on the cable connectors, too?

I didn't replace the pins on the board, but replaced the IDC wiring connectors with the crimp on connectors. This weekend I'm going to revisit Clay's guide that covers the Bally pins of this era.

#16 4 months ago

Diagnostic LED on the MPU board is solid, no flashes. For clarification purposes, does it matter if my 12 volt supply is providing 17 volts?

#18 4 months ago
Quoted from Quench:

What changed between your first post when the game was booting and now where the MPU board wont start?

Not really, it's normally between 14.5 - 16.5 volts.
What voltages do you read at TP5 and TP2 on the MPU board? Use TP4 on the MPU board as the ground connection for your multi-meter.
Post some clear high resolution pictures of the MPU board.

Since originally getting the game I have fixed some bad connections under the playfield and replaced one bad transistor on the lighting board, and replaced the caps on the Squawk and Talk board. I replaced the IDC connectors with pin on connectors for the MPU board, and reflowed the solder on the header pins on the MPU board.

TP5 is showing 5.01 volts, and TP2 is 17.35 volts. I did notice that when I first turned the game on the LED was off and I had nothing at TP2. Turned it off and back on and had 17.35 volts.

Here are some shots of the MPU board.

IMG_2953 (resized).jpgIMG_2954 (resized).jpgIMG_2955 (resized).jpgIMG_2956 (resized).jpg
#20 4 months ago

Thanks for the help Quench. I'll take a look tonight when I get home from work on U6. I forgot that I did pull the chips on the board and cleaned the pins so it is very possible that I put it in backwards and put U2 in the wrong socket. Are those RAM chips hard to obtain now or readily available?

#22 4 months ago

Quench is da man!

It boots! (resized).jpg
#23 4 months ago

U6 was correctly installed. Moved U2 to it's correct socket and installed the connector at J3 correctly and the game booted up. If you're in the Chicago area let me know and drinks are on me! I've got a couple of lights still out but this is most encouraging! Thanks again!

#24 4 months ago

The game boots, but it's back to calling out the wrong setting when I turn it on and it won't take credits. When I power it on now it says "5 ball" and then when it finishes booting "eight ball deluxe...4 ball". It was playing 3 ball when it was booting correctly. It plays the sound for credits but it doesn't add them.

#27 4 months ago
Quoted from Quench:

Your credit display above shows you have 40 credits. That's the maximum credits this game supports with factory ROMs. DIP switches 25 and 26 on the MPU board configure maximum credits between 10 and 40. If you want support for more than 40 credits you need aftermarket ROMs. On location games were generally set to 10 credits max preventing players clocking up too many credits.

I thought that was the match for the last game. Maybe I should have put the lower glass back on. So it's taking credits, but the start button isn't starting a game.

Quoted from Quench:

The number of balls per game is configured by DIP switches 31 and 32. Do you still have both these switches "off" for 3 ball?
When exactly is it announcing "5 ball"

They are both set to off. The game says "5 ball" while it is booting (around flash 3-4 of the MPU LED sequence). Then after it boots it calls out "eight ball deluxe....4 ball"

#29 4 months ago

Switch test showed #31, left slingshot. Found a bent switch lug that was touching the other lug. Bent it over, now switch test is flashing 0. Rebooted, same behavior, calling out 5 ball during boot process, after boot, "EBD.....4 ball". I did have to power cycle the game to get it to boot correctly after the test.

#31 4 months ago

It won't start a game. The start button is not registering. I guess I could test that with the switch test......actually, the start button is probably not on the switch matrix.....

#33 4 months ago

Credit button, along with all other switches are working in the switch test. Sounds like it may be time for this MPU to get some work done.

#36 4 months ago

Tried flexing the MPU while pushing the credit button, nothing. Quench, the game still has the 40 credits. Credit button does nothing in attract mode.

Earlier the game called out "Shoot the five ball" instead of "Eight ball deluxe - 4 ball", but a couple of boots later it went back to the "EBD 4 ball". Just mentioning it.

Are the flipper switches supposed to register in the switch test?

#39 4 months ago
Quoted from frunch:

You probably already went over this, but just to be sure: you put a ball in the game, right?
If so, run the switch test and make sure the game sees that the ball is in the outhole.

No, this was done without a ball in the game. I'll check that tonight when I get home.

Quench, I'll perform your steps as well, I really appreciate the suggestions guys.

#41 4 months ago

The plot thickens. I reset the credits in the audit mode, or at least I thought I did. Turned the game back on, it still showed 40 credits. Wouldn't start a game.

Went back into test mode, and noticed that the pin would reset during the solenoid test when it was firing the bank that knocks down the drop targets on the right for the ball targets. Raised the playfield, pulled the bank of solenoids off the housing and didn't see anything obviously wrong with the wiring, so I reinstalled them.

With the playfield raised, turned the pin on, and didn't get the "5 ball" callout and got a normal boot, complete with the sound effects that I had forgotten about when the game boots and all the lights flash. Now it shows 19 credits, but it still won't start a game. Put the playfield down, and got the screwy boot with the "5 ball" callout during the boot process and back to "Eight ball deluxe....4 ball" without the sound effects.

I unplugged the the wiring running to the right drop target assembly, and now the game boots normally, playfield raised, lowered, whatever, so I must have a wiring issue with the wiring running through those connectors. I noticed I can't do any tests with that bundle disconnected so without looking at the manual I'm guessing some of those wires run to the coin door.

#44 4 months ago

Busy weekend but I did have some time to do some troubleshooting.

Turned out I pulled off the lower right connector from the MPU board when I was messing with the playfield which caused the test button not to work.

Since the solenoid bank that drops the right drop targets kept making the game reset during the solenoid test, I pulled the bank of solenoids out and looked over all the wiring once again. When you run the solenoid test out of the housing the bank fires without any issues. Put it back in the game, and the game would reboot during the solenoid test when it gets to the bank. I resoldered a few connections that looked suspect, but it didn't seem to matter. It seemed like it was the position of the wires once the solenoid bank was in place more than anything, but I didn't see anything looking like a short. To a make a short story long, after messing with the bank it started working in the solenoid test while mounted without the pin rebooting.

Oh, no LED's in this game and the relay clicks fine when testing, BTW.

The switch test will now show that the A rollover switch is closed if I raise and lower the playfield during the test. It looks fine. Ugh.

Quench, what setting in the audits is for credits? I'm not seeing any number that matches the credits displayed when I cycle through the audits. I couldn't find it in the manual.

Since the lower right connector kept coming off the MPU board and those header pins were the only ones that were original I decided to replace them. Two pads lifted while removing the pins, so at this point I may just send the board off to have it looked at and have a pro fix the pads and put in new pins.

2 months later
#47 43 days ago

Okay, reviving this old thread. I took the CPU board over to test it in a working EBD because I thought the credit button was working in test mode. The CPU board worked fine. After putting the board back in and running a switch test I noticed that it's not switch 6, the credit button that comes up when I push the credit button, but switch 5, inline back target. I checked the diode at the switch and it tests good.

I've been looking over the wiring schematics and I haven't found the credit button switch yet. If anyone has next steps on troubleshooting this please let me know.

Edit: found the credit switch, but I don't see how this could tie in to the rear inline switch.

#50 41 days ago
Quoted from frunch:

Looks like the rear inline target and credit button are both on the same switch matrix strobe line, ST0.
Has the female connector for J2 or J3 been re-pinned for the mpu? Almost sounds like it could have a wire on the wrong pin or something like that.
[quoted image][quoted image]

Yes, all connectors have been redone for the MPU board. I tried to pull one wire at a time and crimp on the end and place it in the new connector, but it's very possible I screwed up.

I'm not the greatest at reading schematics. Looking at the above drawing, pin 12 should go to the in-line back target. Is it pin 2 that should be going to the credit switch? I'll take a picture of my wiring when I get home tonight and paste it.

Thanks for the help!

#53 37 days ago

Thursday night I forgot the Bears were on and it's taken me this long to bring myself off the ledge. Now back to pinball. The connectors look to be pinned correctly.

IMG_3120 (resized).jpgIMG_3121 (resized).jpg
#55 37 days ago
Quoted from frunch:

You appear to have your pins in the wrong spots at the bottom of the J3 connector! See where pin 14 is, the blue/white wire? You have it at position *13*. You need to double check your wiring for J3 on the schematic, but you probably just need to move those last 3 pins down one spot. Move blue/white to 14, black/brown to 15, and yellow to 16. (The last slot in the connector is pin 16)
[quoted image]
Found the wiring chart in the schematic, btw. Just use the color code chart above to determine which wires go to which spots. Note that they may reference wires that aren't present at your connector--that's ok. Just make sure the wires that are present at the connector are in their appropriate slots. Looking over there chart, it looks like the wires in the middle of the connector are also in the wrong spots... a bit of connector work and hopefully you'll be up and running!
[quoted image]

D'oh! Thank you so much for the help, I'll check that connector and post back with my results.

#57 37 days ago
Quoted from BigAl56:

Now read the matrix like a road map. You need to drive from S0 to via the credit button to I4. If that route forces you to go backwards through a diode there's your problem.

BigAl56, thanks to the Waze app I can't read a map now either!

I'll check that out if correcting the pin layout doesn't fix the issue. Thank you.

#58 36 days ago

It's getting there! I moved those pins down and it will start a game now. Three outstanding issues I need to track down that I noticed. 1) no flippers 2) right bumper is not firing 3) There's no background sound effects. Other than those 3 things it seems to working correctly. Thanks for all the help.

#61 35 days ago
Quoted from frunch:

Nice! Have you tested all the playfield switches to make sure they all register properly?
As far as the bumper problem, which one are you referring to? The right slingshot or the right pop bumper?
You can run the coil test and see if the bumper fires in the test. If it does, it may just be the activation switch that needs to be adjusted. If it doesn't fire, then we'll need to do a little more digging. Note that the flipper relay should click at some point in the coil test, listen carefully for it towards the end of the cycle. The relay is on the solenoid driver board in the backbox. Do you hear it click?

All switches registering except one on the bank of ball drop targets. The right pop bumper switch is registering, but the solenoid is not firing. The pin has an Alltek solenoid board in it and it does have a red flashing LED during the solenoid test which looks like it's indicating a short?

The relay is clicking on the solenoid driver board. I'm wondering if I've screwed up the pin sequence on a connector there too.

What is the circular component that isn't connected correctly on the right pop bumper switch here? A resistor?

IMG_3125 (resized).jpg
#64 35 days ago
Quoted from Billc479:

The round thing is a capacitor. Clip one side off (or desolder) and see if the problem goes away. It’s possible the capacitor is shorted.

Is that to help clean up the signal? It's already clipped on one side. That's why I was curious what it was. I'll leave it as it is for now.

Quoted from frunch:

The soldering looks a little heavy-handed around the pop bumper switch, I'd get a close look and make sure none of the solder lugs on the switch are touching each other or anything nearby. As billc479 suggested, i also would recommend clipping off the cap and see if that corrects the behavior.

Heavy-handed is being polite, it's a frigging mess. I'll be removing the globs and stripping the wiring back and re-soldering those. The signal striped wire going to the coil lug should be the ground side, correct? If I ground that side it should fire.

I'll try the flipper button in the coil test.

3 weeks later
#66 10 days ago

And the fun continues. The right pop bumper is working, and I now have one working flipper. The J2 connector to the solenoid board was reversed. The left flippers are working, but not the right one. From the schematics it looks like they should be on pin 1 and pin 2 correct?

Promoted items from the Pinside Marketplace
2,400
From: $ 13.00
Electronics
Third Coast Pinball
$ 14.50
Electronics
PinballElectronics.com
$ 399.95
$ 149.95
Boards
Allteksystems
$ 7.00
Electronics
Third Coast Pinball
From: $ 18.00
Apparel - Men
Pinside Shop
$ 20.00
Electronics
Yorktown Parts and Equip
From: $ 159.95
$ 16.00
Electronics
Yorktown Parts and Equip

You're currently viewing posts by Pinsider dewey68.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside